Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Уникальные по трем столбцам - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Уникальные по трем столбцам (Формулы/Formulas)
Уникальные по трем столбцам
serg_sch Дата: Понедельник, 17.05.2021, 09:37 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Всем доброго времени суток!
Прошу помощи! Необходимо из вкладки "Выгрузка" со столбцов "В" "С" "D" вытащить данные во вкладку "М" только уникальные по всем трем столбцам (это уже сделано в примере) но не получается допилить формулу на выбор с уникальных столбцов "В" "С" с указанием критерия столбца "D" (вкладка "М" ячейка "F1"
К сообщению приложен файл: 8772579.xls(228.0 Kb)


Serg_SCH

Сообщение отредактировал serg_sch - Понедельник, 17.05.2021, 20:56
 
Ответить
СообщениеВсем доброго времени суток!
Прошу помощи! Необходимо из вкладки "Выгрузка" со столбцов "В" "С" "D" вытащить данные во вкладку "М" только уникальные по всем трем столбцам (это уже сделано в примере) но не получается допилить формулу на выбор с уникальных столбцов "В" "С" с указанием критерия столбца "D" (вкладка "М" ячейка "F1"

Автор - serg_sch
Дата добавления - 17.05.2021 в 09:37
Serge_007 Дата: Понедельник, 17.05.2021, 17:47 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14482
Репутация: 2389 ±
Замечаний: ±

Excel 2010
Здравствуйте

...выбор уникальных jс...
Что такое "уникальные jc"?


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

...выбор уникальных jс...
Что такое "уникальные jc"?

Автор - Serge_007
Дата добавления - 17.05.2021 в 17:47
serg_sch Дата: Понедельник, 17.05.2021, 20:57 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

опечатка


Serg_SCH
 
Ответить
Сообщениеопечатка

Автор - serg_sch
Дата добавления - 17.05.2021 в 20:57
Pelena Дата: Понедельник, 17.05.2021, 21:20 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 17877
Репутация: 3980 ±
Замечаний: ±

Excel 2016 & Mac Excel
Вариант на основе Вашей формулы для ячейки В2
Код
=ЕСЛИОШИБКА(ИНДЕКС(Выгрузка!B$2:B$222;НАИМЕНЬШИЙ(ЕСЛИ((ПОИСКПОЗ(Выгрузка!$Q$2:$Q$222;Выгрузка!$Q$2:$Q$222;0)=СТРОКА(Выгрузка!$Q$2:$Q$222)-СТРОКА(Выгрузка!$Q$1))*(Выгрузка!$D$2:$D$222=$F$1);СТРОКА(Выгрузка!$Q$2:$Q$222)-СТРОКА(Выгрузка!$Q$1));СТРОКА(B1:C1:D1)));0)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВариант на основе Вашей формулы для ячейки В2
Код
=ЕСЛИОШИБКА(ИНДЕКС(Выгрузка!B$2:B$222;НАИМЕНЬШИЙ(ЕСЛИ((ПОИСКПОЗ(Выгрузка!$Q$2:$Q$222;Выгрузка!$Q$2:$Q$222;0)=СТРОКА(Выгрузка!$Q$2:$Q$222)-СТРОКА(Выгрузка!$Q$1))*(Выгрузка!$D$2:$D$222=$F$1);СТРОКА(Выгрузка!$Q$2:$Q$222)-СТРОКА(Выгрузка!$Q$1));СТРОКА(B1:C1:D1)));0)

Автор - Pelena
Дата добавления - 17.05.2021 в 21:20
serg_sch Дата: Вторник, 18.05.2021, 08:20 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Спасибо огромное, я пытался через "ЕСЛИ" решать, но только учусь понемногу.


Serg_SCH
 
Ответить
СообщениеСпасибо огромное, я пытался через "ЕСЛИ" решать, но только учусь понемногу.

Автор - serg_sch
Дата добавления - 18.05.2021 в 08:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Уникальные по трем столбцам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!