Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор чисел после проверки условия - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор чисел после проверки условия (Формулы/Formulas)
Выбор чисел после проверки условия
Арес Дата: Понедельник, 24.05.2021, 07:46 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Добрый день.

Не понимаю как выполнить подбор чисел после проверки условия. Во вложении есть пример сравнение. Есть массив числовой в столбе 2, в столбе 3 мы сравниваем выполняется условие или нет. Если условие выполняется, то ставится "+", если нет, то ставится "Нет". А вот задача такая: Нужно массив скорректировать в соответствии с условием и в столбе 5 подобрать новый массив исключив из него числа неудовлетворяющие условию.

Пробовал через индекс и ранг, но не пошло. Прошу помощи.
К сообщению приложен файл: PrimerSravnenie.xlsx(9.5 Kb)
 
Ответить
СообщениеДобрый день.

Не понимаю как выполнить подбор чисел после проверки условия. Во вложении есть пример сравнение. Есть массив числовой в столбе 2, в столбе 3 мы сравниваем выполняется условие или нет. Если условие выполняется, то ставится "+", если нет, то ставится "Нет". А вот задача такая: Нужно массив скорректировать в соответствии с условием и в столбе 5 подобрать новый массив исключив из него числа неудовлетворяющие условию.

Пробовал через индекс и ранг, но не пошло. Прошу помощи.

Автор - Арес
Дата добавления - 24.05.2021 в 07:46
Nic70y Дата: Понедельник, 24.05.2021, 08:28 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6875
Репутация: 1574 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ(D3="+";СТРОКА(B1);СТРОКА(B1)&"")
число
Код
=ВПР(НАИМЕНЬШИЙ(B$3:B$25;СТРОКА(F1));B$3:C$25;2;)
К сообщению приложен файл: 7360565.xlsx(9.9 Kb)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИ(D3="+";СТРОКА(B1);СТРОКА(B1)&"")
число
Код
=ВПР(НАИМЕНЬШИЙ(B$3:B$25;СТРОКА(F1));B$3:C$25;2;)

Автор - Nic70y
Дата добавления - 24.05.2021 в 08:28
Арес Дата: Понедельник, 24.05.2021, 08:31 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, Спасибо большое за помошь, можешь объяснить формулу СТРОКА и ВПР? Не сталкивался с ними.
 
Ответить
СообщениеNic70y, Спасибо большое за помошь, можешь объяснить формулу СТРОКА и ВПР? Не сталкивался с ними.

Автор - Арес
Дата добавления - 24.05.2021 в 08:31
Nic70y Дата: Понедельник, 24.05.2021, 08:41 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 6875
Репутация: 1574 ±
Замечаний: 0% ±

Excel 2010


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
СообщениеСТРОКА()
ВПР()

Автор - Nic70y
Дата добавления - 24.05.2021 в 08:41
Арес Дата: Вторник, 25.05.2021, 08:10 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, доброе утро

Честно вчера пытался разобраться с твоём варианте решения и применить к своей задаче, но не получилось. Можешь объяснить несколько моментов?
Первый, зачем прописывать в столбце № =ЕСЛИ(D3="+";СТРОКА(B1);СТРОКА(B1)&"") эту формулу.
Второй, почему Вы пошли через функцию наименьший в искомом значении в ВПР?
 
Ответить
СообщениеNic70y, доброе утро

Честно вчера пытался разобраться с твоём варианте решения и применить к своей задаче, но не получилось. Можешь объяснить несколько моментов?
Первый, зачем прописывать в столбце № =ЕСЛИ(D3="+";СТРОКА(B1);СТРОКА(B1)&"") эту формулу.
Второй, почему Вы пошли через функцию наименьший в искомом значении в ВПР?

Автор - Арес
Дата добавления - 25.05.2021 в 08:10
Egyptian Дата: Среда, 26.05.2021, 01:25 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 115
Репутация: 42 ±
Замечаний: 0% ±

Excel 2013/2016
Арес,
Ну я попробую объяснить. Формула
Код
=ЕСЛИ(D3="+";СТРОКА(B1);СТРОКА(B1)&"")
прописывается для того, чтобы образно говоря разделить котлеты и мух, то бишь, если в ячейке D3 обнаруживается плюс, то функция СТРОКА()
выдает номер, если же плюс не обнаруживается то номер все равно выдается, но с одной немаловажной разницей: обратите внимание на эту конструкцию - &"". Она превращает число в текст.
Итак, после применения формулы по всему столбцу образуется невидимый коктейль из настоящих чисел и текста, выглядящего как числа (псевдочисла).
Далее, формула
Код
SMALL(B$3:B$25,ROW(F2))
, которая псевдочисла не видит, извлекает только настоящие числа и передает функции
Код
VLOOKUP()
в качестве критерия.
Та, в свою очередь извлекает числа из диапазона, причем в нужном порядке. Собственно, все.
Если хотите увидеть эти псевдочисла то введите эту формулу в файл выложенный Nic70y, в ячейку G3 и протяните вниз:
Код
=IF(ISTEXT(B3);B3;"")


Ну и напоследок мой вариант:
Код
=IFERROR(INDEX($C$3:$C$25,AGGREGATE(15,6,ROW($A$1:$A$25)/(($D$3:$D$25="+")),ROW(A1))),"")
К сообщению приложен файл: 3487840.xlsx(10.1 Kb)


Сообщение отредактировал Egyptian - Среда, 26.05.2021, 02:04
 
Ответить
СообщениеАрес,
Ну я попробую объяснить. Формула
Код
=ЕСЛИ(D3="+";СТРОКА(B1);СТРОКА(B1)&"")
прописывается для того, чтобы образно говоря разделить котлеты и мух, то бишь, если в ячейке D3 обнаруживается плюс, то функция СТРОКА()
выдает номер, если же плюс не обнаруживается то номер все равно выдается, но с одной немаловажной разницей: обратите внимание на эту конструкцию - &"". Она превращает число в текст.
Итак, после применения формулы по всему столбцу образуется невидимый коктейль из настоящих чисел и текста, выглядящего как числа (псевдочисла).
Далее, формула
Код
SMALL(B$3:B$25,ROW(F2))
, которая псевдочисла не видит, извлекает только настоящие числа и передает функции
Код
VLOOKUP()
в качестве критерия.
Та, в свою очередь извлекает числа из диапазона, причем в нужном порядке. Собственно, все.
Если хотите увидеть эти псевдочисла то введите эту формулу в файл выложенный Nic70y, в ячейку G3 и протяните вниз:
Код
=IF(ISTEXT(B3);B3;"")


Ну и напоследок мой вариант:
Код
=IFERROR(INDEX($C$3:$C$25,AGGREGATE(15,6,ROW($A$1:$A$25)/(($D$3:$D$25="+")),ROW(A1))),"")

Автор - Egyptian
Дата добавления - 26.05.2021 в 01:25
Арес Дата: Среда, 26.05.2021, 07:34 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Egyptian, огромное спасибо за разъяснения! Сегодня попробую Ваш вариант.
 
Ответить
СообщениеEgyptian, огромное спасибо за разъяснения! Сегодня попробую Ваш вариант.

Автор - Арес
Дата добавления - 26.05.2021 в 07:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор чисел после проверки условия (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!