Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/День недели в зависимости от даты - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » День недели в зависимости от даты (Формулы/Formulas)
День недели в зависимости от даты
Юрий_Ф Дата: Суббота, 05.06.2021, 00:10 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 388
Репутация: -5 ±
Замечаний: 20% ±

Excel 2010
Добрый день, уважаемые админы, гуру, знатоки!

Подскажите, пожалуйста, как получать день недели в ячейках столбца D в зависимости от года (столбец А), месяца (столбец В) и числа (столбец С)?
Попытался отыскать соответствующую функцию в перечне их, но что-то не нашёл. Возможно, не там искал?
Прошу помочь! %)
К сообщению приложен файл: 6270029.xlsx(8.1 Kb)


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!


Сообщение отредактировал Юрий_Ф - Суббота, 05.06.2021, 00:11
 
Ответить
СообщениеДобрый день, уважаемые админы, гуру, знатоки!

Подскажите, пожалуйста, как получать день недели в ячейках столбца D в зависимости от года (столбец А), месяца (столбец В) и числа (столбец С)?
Попытался отыскать соответствующую функцию в перечне их, но что-то не нашёл. Возможно, не там искал?
Прошу помочь! %)

Автор - Юрий_Ф
Дата добавления - 05.06.2021 в 00:10
Светлый Дата: Суббота, 05.06.2021, 07:53 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1681
Репутация: 448 ±
Замечаний: 0% ±

Excel 2013, 2016
Добрый день!
В числовом виде:
Код
=ДЕНЬНЕД(C3&" "&ЛЕВБ(B3;3)&" "&A3;2)
*Даже так:
Код
=ДЕНЬНЕД(C3&ЛЕВБ(B3;3)&A3;2)
**И по заданию:
Код
=ПРОПНАЧ(ТЕКСТ(ДЕНЬНЕД(C3&ЛЕВБ(B3;3)&A3);"дддд"))
Код
=ПРОПНАЧ(ТЕКСТ(C3&ЛЕВБ(B3;3)&A3;"дддд"))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Суббота, 05.06.2021, 08:03
 
Ответить
СообщениеДобрый день!
В числовом виде:
Код
=ДЕНЬНЕД(C3&" "&ЛЕВБ(B3;3)&" "&A3;2)
*Даже так:
Код
=ДЕНЬНЕД(C3&ЛЕВБ(B3;3)&A3;2)
**И по заданию:
Код
=ПРОПНАЧ(ТЕКСТ(ДЕНЬНЕД(C3&ЛЕВБ(B3;3)&A3);"дддд"))
Код
=ПРОПНАЧ(ТЕКСТ(C3&ЛЕВБ(B3;3)&A3;"дддд"))

Автор - Светлый
Дата добавления - 05.06.2021 в 07:53
Юрий_Ф Дата: Суббота, 05.06.2021, 15:27 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 388
Репутация: -5 ±
Замечаний: 20% ±

Excel 2010
Светлый

Огромное спасибо!
А если нужно обозначить в дне недели только первые две буквы (Суббота - Сб, Вторник - Вт), то что надо в формулах поменять?


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеСветлый

Огромное спасибо!
А если нужно обозначить в дне недели только первые две буквы (Суббота - Сб, Вторник - Вт), то что надо в формулах поменять?

Автор - Юрий_Ф
Дата добавления - 05.06.2021 в 15:27
Светлый Дата: Суббота, 05.06.2021, 16:51 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1681
Репутация: 448 ±
Замечаний: 0% ±

Excel 2013, 2016
что надо в формулах поменять?

Убрать одну букву "д" и внешнюю функцию.:
Код
=ТЕКСТ(C3&ЛЕВБ(B3;3)&A3;"ддд")


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
что надо в формулах поменять?

Убрать одну букву "д" и внешнюю функцию.:
Код
=ТЕКСТ(C3&ЛЕВБ(B3;3)&A3;"ддд")

Автор - Светлый
Дата добавления - 05.06.2021 в 16:51
Юрий_Ф Дата: Суббота, 05.06.2021, 21:25 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 388
Репутация: -5 ±
Замечаний: 20% ±

Excel 2010
Светлый

Спасибо, уважаемый гуру!
hands


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеСветлый

Спасибо, уважаемый гуру!
hands

Автор - Юрий_Ф
Дата добавления - 05.06.2021 в 21:25
Юрий_Ф Дата: Воскресенье, 06.06.2021, 13:18 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 388
Репутация: -5 ±
Замечаний: 20% ±

Excel 2010
Ещё вопрос!
Если заполнены ячейки ГОД и МЕСЯЦ, но нет числа, по крайней вашей формуле день недели выводит Пн.
А как сделать, чтобы при отсутствии числа и в ячейке день недели было пусто?
(Попробовал поэксперементировать с &""&, но что-то не вышло.)


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеЕщё вопрос!
Если заполнены ячейки ГОД и МЕСЯЦ, но нет числа, по крайней вашей формуле день недели выводит Пн.
А как сделать, чтобы при отсутствии числа и в ячейке день недели было пусто?
(Попробовал поэксперементировать с &""&, но что-то не вышло.)

Автор - Юрий_Ф
Дата добавления - 06.06.2021 в 13:18
DrMini Дата: Понедельник, 07.06.2021, 05:48 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 626
Репутация: 22 ±
Замечаний: 0% ±

Excel 2010, 2013, 2019 RUS
Юрий_Ф,
Так?
Код
=ЕСЛИ(C3<>0;ТЕКСТ(C3&ЛЕВБ(B3;3)&A3;"ддд");"")
 
Ответить
СообщениеЮрий_Ф,
Так?
Код
=ЕСЛИ(C3<>0;ТЕКСТ(C3&ЛЕВБ(B3;3)&A3;"ддд");"")

Автор - DrMini
Дата добавления - 07.06.2021 в 05:48
Юрий_Ф Дата: Понедельник, 07.06.2021, 10:33 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 388
Репутация: -5 ±
Замечаний: 20% ±

Excel 2010
DrMini

Спасибо большое! Работает, как часы!


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеDrMini

Спасибо большое! Работает, как часы!

Автор - Юрий_Ф
Дата добавления - 07.06.2021 в 10:33
MCH Дата: Понедельник, 07.06.2021, 11:21 | Сообщение № 9
Группа: Админы
Ранг: Старожил
Сообщений: 1969
Репутация: 737 ±
Замечаний: ±

чуть короче
Код
=ЕСЛИ(C3;ТЕКСТ(C3&B3&A3;"ДДД");"")
 
Ответить
Сообщениечуть короче
Код
=ЕСЛИ(C3;ТЕКСТ(C3&B3&A3;"ДДД");"")

Автор - MCH
Дата добавления - 07.06.2021 в 11:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » День недели в зависимости от даты (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!