Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывести значения нескольких столбцов без повторного ВПР - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести значения нескольких столбцов без повторного ВПР (Формулы/Formulas)
Вывести значения нескольких столбцов без повторного ВПР
kadig Дата: Вторник, 29.06.2021, 00:54 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Доброй ночи. Подскажите, можно ли облегчить вычисления в файле и не вычислять дважды и более раз ВПР. Например, есть данные о товаре, цене и единице измерения. При выборе товара в таблицу, необходимо, чтобы кроме цены, подставлялись данные об единице измерения без повторного поиска в списке товара.
К сообщению приложен файл: 5029661.xlsx(11.1 Kb)
 
Ответить
СообщениеДоброй ночи. Подскажите, можно ли облегчить вычисления в файле и не вычислять дважды и более раз ВПР. Например, есть данные о товаре, цене и единице измерения. При выборе товара в таблицу, необходимо, чтобы кроме цены, подставлялись данные об единице измерения без повторного поиска в списке товара.

Автор - kadig
Дата добавления - 29.06.2021 в 00:54
китин Дата: Вторник, 29.06.2021, 07:45 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6495
Репутация: 992 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
как понял., так и сделал
Код
=ВПР($A11;$A$2:$C$6;ПОИСКПОЗ(E$10;$A$1:$C$1;0);0)
К сообщению приложен файл: 0290913.xlsx(9.2 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениекак понял., так и сделал
Код
=ВПР($A11;$A$2:$C$6;ПОИСКПОЗ(E$10;$A$1:$C$1;0);0)

Автор - китин
Дата добавления - 29.06.2021 в 07:45
Nic70y Дата: Вторник, 29.06.2021, 08:32 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 6932
Репутация: 1599 ±
Замечаний: 0% ±

Excel 2010
[vba]
Код
Private Sub Worksheet_Change(ByVal Target As Range)
    If Not Intersect(Target, Range("a11:a65536")) Is Nothing Then
        u = Application.Match(Target.Value, Range("a2:a6"), 0)
        v = Application.IsNumber(u)
        If v Then
            Target.Offset(0, 2) = Range("b" & u + 1).Value
            Target.Offset(0, 4) = Range("c" & u + 1).Value
        Else
            Target.Offset(0, 2).ClearContents
            Target.Offset(0, 2).ClearContents
            If Target.Value <> "" Then MsgBox "Товар в справочнике не найден."
        End If
    End If
End Sub
[/vba]апдэйт
промахнулся
            Target.Offset(0, 2).ClearContents
            Target.Offset(0, 2).ClearContents
надо конечно
            Target.Offset(0, 2).ClearContents
            Target.Offset(0, 4).ClearContents
К сообщению приложен файл: 5029661.xlsm(15.0 Kb)


ЮMoney(Яндекс Деньги) 41001841029809

Сообщение отредактировал Nic70y - Вторник, 29.06.2021, 11:17
 
Ответить
Сообщение[vba]
Код
Private Sub Worksheet_Change(ByVal Target As Range)
    If Not Intersect(Target, Range("a11:a65536")) Is Nothing Then
        u = Application.Match(Target.Value, Range("a2:a6"), 0)
        v = Application.IsNumber(u)
        If v Then
            Target.Offset(0, 2) = Range("b" & u + 1).Value
            Target.Offset(0, 4) = Range("c" & u + 1).Value
        Else
            Target.Offset(0, 2).ClearContents
            Target.Offset(0, 2).ClearContents
            If Target.Value <> "" Then MsgBox "Товар в справочнике не найден."
        End If
    End If
End Sub
[/vba]апдэйт
промахнулся
            Target.Offset(0, 2).ClearContents
            Target.Offset(0, 2).ClearContents
надо конечно
            Target.Offset(0, 2).ClearContents
            Target.Offset(0, 4).ClearContents

Автор - Nic70y
Дата добавления - 29.06.2021 в 08:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести значения нескольких столбцов без повторного ВПР (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!