Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Присвоение ячейки значение 0 при сложном условии - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Присвоение ячейки значение 0 при сложном условии (Формулы/Formulas)
Присвоение ячейки значение 0 при сложном условии
aaronn9256162 Дата: Вторник, 06.07.2021, 15:08 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Всем доброго времени суток!
Народ, прошу помощи, всю голову уже сломал. Нужна коллективная помощь)
Есть ячейка с данными - артикул и название продукта. Допустим, 1000010001 Болт.
Во второй ячейке нужно присвоить значение 0, если 6-я цифра в артикуле, (т.е. в случае с 1000010001 это цифра 1) равна 2, либо 6, либо 8.
Если это условие не соблюдается (как в нашем случае), то ячейка остается без изменений. Прилагаю пример.
Всем заранее спасибо.
К сообщению приложен файл: test.xlsx(9.6 Kb)
 
Ответить
СообщениеВсем доброго времени суток!
Народ, прошу помощи, всю голову уже сломал. Нужна коллективная помощь)
Есть ячейка с данными - артикул и название продукта. Допустим, 1000010001 Болт.
Во второй ячейке нужно присвоить значение 0, если 6-я цифра в артикуле, (т.е. в случае с 1000010001 это цифра 1) равна 2, либо 6, либо 8.
Если это условие не соблюдается (как в нашем случае), то ячейка остается без изменений. Прилагаю пример.
Всем заранее спасибо.

Автор - aaronn9256162
Дата добавления - 06.07.2021 в 15:08
amfor Дата: Вторник, 06.07.2021, 15:21 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 213
Репутация: 64 ±
Замечаний: 0% ±

Excel 2016
Добрый. Как понял.
К сообщению приложен файл: 7670213.xlsx(10.2 Kb)


Семь бед - один RESET.
 
Ответить
СообщениеДобрый. Как понял.

Автор - amfor
Дата добавления - 06.07.2021 в 15:21
YouGreed Дата: Вторник, 06.07.2021, 15:22 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 581
Репутация: 120 ±
Замечаний: 0% ±

Excel 2010
aaronn9256162, Попробуем так:
Код
=ЕСЛИ(ИЛИ(--ПСТР(C2;6;1)=2;--ПСТР(C2;6;1)=6;--ПСТР(C2;6;1)=8);ЗАМЕНИТЬ(C2;6;1;0);C2)


Сделал правки в исходных данных, для проверки работы формулы :)
К сообщению приложен файл: __.xlsx(10.3 Kb)


Сообщение отредактировал YouGreed - Вторник, 06.07.2021, 15:28
 
Ответить
Сообщениеaaronn9256162, Попробуем так:
Код
=ЕСЛИ(ИЛИ(--ПСТР(C2;6;1)=2;--ПСТР(C2;6;1)=6;--ПСТР(C2;6;1)=8);ЗАМЕНИТЬ(C2;6;1;0);C2)


Сделал правки в исходных данных, для проверки работы формулы :)

Автор - YouGreed
Дата добавления - 06.07.2021 в 15:22
aaronn9256162 Дата: Вторник, 06.07.2021, 15:26 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

amfor, почти все так, спасибо! только он должен присваивать в случае несоблюдения условия не этой же строчки(т.е. артикул с названием), а значение в выходной ячейке по умолчанию (т.е. пусто допустим) и артикул может не всегда начинаться с =10000, а может быть произвольный набор цифр, важно значение только шестой цифры, в этом вся соль)


Сообщение отредактировал aaronn9256162 - Вторник, 06.07.2021, 15:28
 
Ответить
Сообщениеamfor, почти все так, спасибо! только он должен присваивать в случае несоблюдения условия не этой же строчки(т.е. артикул с названием), а значение в выходной ячейке по умолчанию (т.е. пусто допустим) и артикул может не всегда начинаться с =10000, а может быть произвольный набор цифр, важно значение только шестой цифры, в этом вся соль)

Автор - aaronn9256162
Дата добавления - 06.07.2021 в 15:26
alexa1965 Дата: Вторник, 06.07.2021, 15:27 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 242
Репутация: 18 ±
Замечаний: 0% ±

2003> 2010> 2016
Если правильно понял
Код
=ЕСЛИ(ИЛИ(--ПСТР(C2;6;1)=2;--ПСТР(C2;6;1)=6;--ПСТР(C2;6;1)=8);0;C2)


Главное не быть балабастиком

Сообщение отредактировал alexa1965 - Вторник, 06.07.2021, 15:35
 
Ответить
СообщениеЕсли правильно понял
Код
=ЕСЛИ(ИЛИ(--ПСТР(C2;6;1)=2;--ПСТР(C2;6;1)=6;--ПСТР(C2;6;1)=8);0;C2)

Автор - alexa1965
Дата добавления - 06.07.2021 в 15:27
YouGreed Дата: Вторник, 06.07.2021, 15:30 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 581
Репутация: 120 ±
Замечаний: 0% ±

Excel 2010
aaronn9256162, А мое решение?
 
Ответить
Сообщениеaaronn9256162, А мое решение?

Автор - YouGreed
Дата добавления - 06.07.2021 в 15:30
aaronn9256162 Дата: Вторник, 06.07.2021, 15:36 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

YouGreed, почти) спасибо вам тоже
идею понял, попробую доработать сам
 
Ответить
СообщениеYouGreed, почти) спасибо вам тоже
идею понял, попробую доработать сам

Автор - aaronn9256162
Дата добавления - 06.07.2021 в 15:36
amfor Дата: Вторник, 06.07.2021, 15:38 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 213
Репутация: 64 ±
Замечаний: 0% ±

Excel 2016
Цитата aaronn9256162, 06.07.2021 в 15:08, в сообщении № 1 ()
Если это условие не соблюдается (как в нашем случае), то ячейка остается без изменений.

Нужно показывать все возможные варианты.
Код
=ЕСЛИ(ИЛИ(--ПСТР(C2;6;1)=2;--ПСТР(C2;6;1)=6;--ПСТР(C2;6;1)=8);0;"")


Семь бед - один RESET.

Сообщение отредактировал amfor - Вторник, 06.07.2021, 15:43
 
Ответить
Сообщение
Цитата aaronn9256162, 06.07.2021 в 15:08, в сообщении № 1 ()
Если это условие не соблюдается (как в нашем случае), то ячейка остается без изменений.

Нужно показывать все возможные варианты.
Код
=ЕСЛИ(ИЛИ(--ПСТР(C2;6;1)=2;--ПСТР(C2;6;1)=6;--ПСТР(C2;6;1)=8);0;"")

Автор - amfor
Дата добавления - 06.07.2021 в 15:38
Serge_007 Дата: Вторник, 06.07.2021, 16:03 | Сообщение № 9
Группа: Админы
Ранг: Местный житель
Сообщений: 14333
Репутация: 2368 ±
Замечаний: ±

Excel 2010
Для разнообразия:
Код
=ЛЕВБ(C2;5)&НЕ(СУММ((--ПСТР(C2;6;1)={2:6:8})+0))*ПСТР(C2;6;1)&ПСТР(C2;7;99)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеДля разнообразия:
Код
=ЛЕВБ(C2;5)&НЕ(СУММ((--ПСТР(C2;6;1)={2:6:8})+0))*ПСТР(C2;6;1)&ПСТР(C2;7;99)

Автор - Serge_007
Дата добавления - 06.07.2021 в 16:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Присвоение ячейки значение 0 при сложном условии (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!