Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Ищу формулу для поиска истины среди ложных значений - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ищу формулу для поиска истины среди ложных значений (Формулы/Formulas)
Ищу формулу для поиска истины среди ложных значений
lyzianina3851 Дата: Среда, 07.07.2021, 16:33 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Доброго времени суток. Есть вопрос. У меня есть диапазон ячеек со значениями ЛОЖЬ и только одной ячейкой ИСТИНА. Нужна такая формула, которая позволит найти эту самую ячейку со значением ИСТИНА (вместо слова истина в ячейке находится какое-либо значение). Бывает такая формула? По типу, если в диапазоне есть значение истина, то показать его.
 
Ответить
СообщениеДоброго времени суток. Есть вопрос. У меня есть диапазон ячеек со значениями ЛОЖЬ и только одной ячейкой ИСТИНА. Нужна такая формула, которая позволит найти эту самую ячейку со значением ИСТИНА (вместо слова истина в ячейке находится какое-либо значение). Бывает такая формула? По типу, если в диапазоне есть значение истина, то показать его.

Автор - lyzianina3851
Дата добавления - 07.07.2021 в 16:33
Pelena Дата: Среда, 07.07.2021, 16:37 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17793
Репутация: 3958 ±
Замечаний: ±

Excel 2016 & Mac Excel
Файл с примером помог бы в понимании проблемы


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФайл с примером помог бы в понимании проблемы

Автор - Pelena
Дата добавления - 07.07.2021 в 16:37
Serge_007 Дата: Среда, 07.07.2021, 17:43 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 14333
Репутация: 2368 ±
Замечаний: ±

Excel 2010
Здравствуйте

Код
=ИНДЕКС(A1:E10;СУММПРОИЗВ((A1:E10=ИСТИНА)*СТРОКА(1:10));СУММПРОИЗВ((A1:E10=ИСТИНА)*СТОЛБЕЦ(A1:E1)))
К сообщению приложен файл: 20210707_lyzian.xls(60.0 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Код
=ИНДЕКС(A1:E10;СУММПРОИЗВ((A1:E10=ИСТИНА)*СТРОКА(1:10));СУММПРОИЗВ((A1:E10=ИСТИНА)*СТОЛБЕЦ(A1:E1)))

Автор - Serge_007
Дата добавления - 07.07.2021 в 17:43
lyzianina3851 Дата: Среда, 07.07.2021, 17:55 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Serge_007, спасибо, это то что нужно, но как преобразовать формулу, если у меня только один столбик в диапазоне?
 
Ответить
СообщениеSerge_007, спасибо, это то что нужно, но как преобразовать формулу, если у меня только один столбик в диапазоне?

Автор - lyzianina3851
Дата добавления - 07.07.2021 в 17:55
Serge_007 Дата: Среда, 07.07.2021, 17:57 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 14333
Репутация: 2368 ±
Замечаний: ±

Excel 2010
Можно ничего не менять в формуле, всё-равно будет работать, а можно убрать из формулы лишнее:
Код
=ИНДЕКС(A1:A10;СУММПРОИЗВ((A1:E10=ИСТИНА)*СТРОКА(1:10)))


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеМожно ничего не менять в формуле, всё-равно будет работать, а можно убрать из формулы лишнее:
Код
=ИНДЕКС(A1:A10;СУММПРОИЗВ((A1:E10=ИСТИНА)*СТРОКА(1:10)))

Автор - Serge_007
Дата добавления - 07.07.2021 в 17:57
lyzianina3851 Дата: Среда, 07.07.2021, 18:14 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Serge_007, пробовал вставить эту формулу в вашу же таблицу выдает ошибку 501. Никак не получается воссоздать вашу формулу применимую к одному столбцу.
 
Ответить
СообщениеSerge_007, пробовал вставить эту формулу в вашу же таблицу выдает ошибку 501. Никак не получается воссоздать вашу формулу применимую к одному столбцу.

Автор - lyzianina3851
Дата добавления - 07.07.2021 в 18:14
Serge_007 Дата: Среда, 07.07.2021, 22:29 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 14333
Репутация: 2368 ±
Замечаний: ±

Excel 2010
Цитата lyzianina3851, 07.07.2021 в 18:14, в сообщении № 6 ()
выдает ошибку 501
Формулы не возвращают номерные ошибки
Приложите скрин
К сообщению приложен файл: 0233671.xls(58.0 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Цитата lyzianina3851, 07.07.2021 в 18:14, в сообщении № 6 ()
выдает ошибку 501
Формулы не возвращают номерные ошибки
Приложите скрин

Автор - Serge_007
Дата добавления - 07.07.2021 в 22:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ищу формулу для поиска истины среди ложных значений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!