Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчет зарплаты. Распределение зп другим работникам при невы - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет зарплаты. Распределение зп другим работникам при невы (Формулы/Formulas)
Расчет зарплаты. Распределение зп другим работникам при невы
azatey-85 Дата: Понедельник, 12.07.2021, 22:15 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Расчитать зарплату работникам, желательно использовать 2 вариант, но если 2 вариант не получается можно сделать 1 вариант
В экселе я ни бум бум, максимум что я могу сделать это только автосумма :D 8)

Это 1-вый вариант
Нужно что бы в ячейках итого у каждого работника считалась зарплата, но если мы ставим какой-нибудь символ работнику за не выход, его зарплата распределяется между тем кто работал. может быть и такое что 2 человека не выйдут, тогда зарплата этих 2 человек делятся между тем кто выходил.

Это 2-й вариант
Почти тоже самое, но немного усложнено. Там уже нужно делать расчет с учетом понедельника.

Более подробно в файлике excel
Помогите пожалуйста :oops:
К сообщению приложен файл: _XLSX-2-.xlsx(16.3 Kb)
 
Ответить
СообщениеРасчитать зарплату работникам, желательно использовать 2 вариант, но если 2 вариант не получается можно сделать 1 вариант
В экселе я ни бум бум, максимум что я могу сделать это только автосумма :D 8)

Это 1-вый вариант
Нужно что бы в ячейках итого у каждого работника считалась зарплата, но если мы ставим какой-нибудь символ работнику за не выход, его зарплата распределяется между тем кто работал. может быть и такое что 2 человека не выйдут, тогда зарплата этих 2 человек делятся между тем кто выходил.

Это 2-й вариант
Почти тоже самое, но немного усложнено. Там уже нужно делать расчет с учетом понедельника.

Более подробно в файлике excel
Помогите пожалуйста :oops:

Автор - azatey-85
Дата добавления - 12.07.2021 в 22:15
Pelena Дата: Понедельник, 12.07.2021, 22:44 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17793
Репутация: 3958 ±
Замечаний: ±

Excel 2016 & Mac Excel
И Вам здравствуйте.
для 1 варианта
Код
=СУММПРОИЗВ((B15:G15<>"-")*1040*ЧСТРОК($B$15:$G$19)/МУМНОЖ(ТРАНСП(СТРОКА($B$15:$G$19))^0;--($B$15:$G$19<>"-")))

про второй вариант не поняла условие
К сообщению приложен файл: 4247719.xlsx(17.6 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИ Вам здравствуйте.
для 1 варианта
Код
=СУММПРОИЗВ((B15:G15<>"-")*1040*ЧСТРОК($B$15:$G$19)/МУМНОЖ(ТРАНСП(СТРОКА($B$15:$G$19))^0;--($B$15:$G$19<>"-")))

про второй вариант не поняла условие

Автор - Pelena
Дата добавления - 12.07.2021 в 22:44
azatey-85 Дата: Вторник, 13.07.2021, 13:36 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Pelena, Расписал как можно подробнее в файлике
К сообщению приложен файл: 7804071.xlsx(15.5 Kb)
 
Ответить
СообщениеPelena, Расписал как можно подробнее в файлике

Автор - azatey-85
Дата добавления - 13.07.2021 в 13:36
Pelena Дата: Вторник, 13.07.2021, 18:39 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 17793
Репутация: 3958 ±
Замечаний: ±

Excel 2016 & Mac Excel
Наверное, можно оптимизировать, но пока так
Код
=ЕСЛИ(СУММ((ИНДЕКС($B$64:$H$68;0;ПОИСКПОЗ($H$53;$B$63:$H$63;0))="+")*($B$55:$B$59="-"));(СУММПРОИЗВ(((ИНДЕКС($B$64:$H$68;ПОИСКПОЗ($A55;$A$64:$A$68;0);ПОИСКПОЗ($H$53;$B$63:$H$63;0))={"+";""})*1040))+ЕСЛИОШИБКА(1040*СУММПРОИЗВ((ИНДЕКС($B$64:$H$68;0;ПОИСКПОЗ($H$53;$B$63:$H$63;0))="+")*($B$55:$B$59="-"))/МУМНОЖ(ТРАНСП(СТРОКА($B$55:$B$59))^0;(ИНДЕКС($B$64:$H$68;0;ПОИСКПОЗ($H$53;$B$63:$H$63;0))="+")*($B$55:$B$59<>"-"));0)*(ИНДЕКС($B$64:$H$68;ПОИСКПОЗ($A55;$A$64:$A$68;0);ПОИСКПОЗ($H$53;$B$63:$H$63;0))="+"))*(B55<>"-")+СУММПРОИЗВ((C55:G55<>"-")*1040*ЧСТРОК($C$55:$G$59)/МУМНОЖ(ТРАНСП(СТРОКА($C$55:$G$59))^0;--($C$55:$G$59<>"-")));СУММПРОИЗВ((B55:G55<>"-")*1040*ЧСТРОК($B$55:$G$59)/МУМНОЖ(ТРАНСП(СТРОКА($B$55:$G$59))^0;--($B$55:$G$59<>"-"))))
К сообщению приложен файл: 9575800.xlsx(17.2 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНаверное, можно оптимизировать, но пока так
Код
=ЕСЛИ(СУММ((ИНДЕКС($B$64:$H$68;0;ПОИСКПОЗ($H$53;$B$63:$H$63;0))="+")*($B$55:$B$59="-"));(СУММПРОИЗВ(((ИНДЕКС($B$64:$H$68;ПОИСКПОЗ($A55;$A$64:$A$68;0);ПОИСКПОЗ($H$53;$B$63:$H$63;0))={"+";""})*1040))+ЕСЛИОШИБКА(1040*СУММПРОИЗВ((ИНДЕКС($B$64:$H$68;0;ПОИСКПОЗ($H$53;$B$63:$H$63;0))="+")*($B$55:$B$59="-"))/МУМНОЖ(ТРАНСП(СТРОКА($B$55:$B$59))^0;(ИНДЕКС($B$64:$H$68;0;ПОИСКПОЗ($H$53;$B$63:$H$63;0))="+")*($B$55:$B$59<>"-"));0)*(ИНДЕКС($B$64:$H$68;ПОИСКПОЗ($A55;$A$64:$A$68;0);ПОИСКПОЗ($H$53;$B$63:$H$63;0))="+"))*(B55<>"-")+СУММПРОИЗВ((C55:G55<>"-")*1040*ЧСТРОК($C$55:$G$59)/МУМНОЖ(ТРАНСП(СТРОКА($C$55:$G$59))^0;--($C$55:$G$59<>"-")));СУММПРОИЗВ((B55:G55<>"-")*1040*ЧСТРОК($B$55:$G$59)/МУМНОЖ(ТРАНСП(СТРОКА($B$55:$G$59))^0;--($B$55:$G$59<>"-"))))

Автор - Pelena
Дата добавления - 13.07.2021 в 18:39
azatey-85 Дата: Среда, 14.07.2021, 10:13 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Pelena, Большое спасибо Хорошо что есть такие милые и бескорыстные человеки готовы помочь за обнимашку :shy: yahoo respect flowers
 
Ответить
СообщениеPelena, Большое спасибо Хорошо что есть такие милые и бескорыстные человеки готовы помочь за обнимашку :shy: yahoo respect flowers

Автор - azatey-85
Дата добавления - 14.07.2021 в 10:13
Светлый Дата: Среда, 14.07.2021, 13:05 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1639
Репутация: 437 ±
Замечаний: 0% ±

Excel 2013, 2016
У меня такая массивная формула получилась для 1 варианта:
Код
=СУММ(1040*СЧЁТЗ(A$55:A$59)/МУМНОЖ(ТРАНСП(СТРОКА(B$55:B$59)^0);Ч(B$55:G$59=""))*(B55:G55=""))
А для учёта понедельников:
Код
=СУММ(СЧЁТЗ(A$55:A$59)/МУМНОЖ(ТРАНСП(СТРОКА(B$55:B$59)^0);Ч(C$55:G$59=""))*(C55:G55="");ЕСЛИ(B55="";ЕСЛИ(ИНДЕКС(B64:H64;ЛЕВБ(H$53))="";1;СУММ(Ч(ИНДЕКС(B$64:H$68;;ЛЕВБ(H$53))="+"))/СУММ((ИНДЕКС(B$64:H$68;;ЛЕВБ(H$53))="+")*(B55:B59="")))))*1040


Программировать проще, чем писать стихи.
 
Ответить
СообщениеУ меня такая массивная формула получилась для 1 варианта:
Код
=СУММ(1040*СЧЁТЗ(A$55:A$59)/МУМНОЖ(ТРАНСП(СТРОКА(B$55:B$59)^0);Ч(B$55:G$59=""))*(B55:G55=""))
А для учёта понедельников:
Код
=СУММ(СЧЁТЗ(A$55:A$59)/МУМНОЖ(ТРАНСП(СТРОКА(B$55:B$59)^0);Ч(C$55:G$59=""))*(C55:G55="");ЕСЛИ(B55="";ЕСЛИ(ИНДЕКС(B64:H64;ЛЕВБ(H$53))="";1;СУММ(Ч(ИНДЕКС(B$64:H$68;;ЛЕВБ(H$53))="+"))/СУММ((ИНДЕКС(B$64:H$68;;ЛЕВБ(H$53))="+")*(B55:B59="")))))*1040

Автор - Светлый
Дата добавления - 14.07.2021 в 13:05
azatey-85 Дата: Среда, 14.07.2021, 21:44 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Светлый, Тоже огромное спасибо Жму крепкую руку настоящего мужика booze
 
Ответить
СообщениеСветлый, Тоже огромное спасибо Жму крепкую руку настоящего мужика booze

Автор - azatey-85
Дата добавления - 14.07.2021 в 21:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет зарплаты. Распределение зп другим работникам при невы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!