Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор конкретных значений, исходя из определенных условий - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор конкретных значений, исходя из определенных условий (Формулы/Formulas)
Выбор конкретных значений, исходя из определенных условий
ПАМ Дата: Четверг, 15.07.2021, 09:54 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 214
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте, уважаемые форумчане! Помогите мне пожалуйста разобраться вот с какой проблемой:

В ячейках AE4-AE28 находятся определенные даты (в примере 1 января); в ячейках AF4-AF28 стоят определенные часы, исходя из месяца.
Мне нужно чтобы исходя из месяца, (согласно дате) вставить определенный час с листа СО, а они там могут быть не по порядку.
Пробовал через
Код
=ВПР(ТЕКСТ(AE4;"ММММ");СО!$A$1:$B$147;2;ЛОЖЬ)

Но Эксель находит только первый час, а дальше не двигается, хотя в январе часов много.

Заранее Всем Спасибо!
К сообщению приложен файл: 0768127.xlsx(16.9 Kb)
 
Ответить
СообщениеЗдравствуйте, уважаемые форумчане! Помогите мне пожалуйста разобраться вот с какой проблемой:

В ячейках AE4-AE28 находятся определенные даты (в примере 1 января); в ячейках AF4-AF28 стоят определенные часы, исходя из месяца.
Мне нужно чтобы исходя из месяца, (согласно дате) вставить определенный час с листа СО, а они там могут быть не по порядку.
Пробовал через
Код
=ВПР(ТЕКСТ(AE4;"ММММ");СО!$A$1:$B$147;2;ЛОЖЬ)

Но Эксель находит только первый час, а дальше не двигается, хотя в январе часов много.

Заранее Всем Спасибо!

Автор - ПАМ
Дата добавления - 15.07.2021 в 09:54
Nic70y Дата: Четверг, 15.07.2021, 10:07 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6932
Репутация: 1599 ±
Замечаний: 0% ±

Excel 2010
вставить определенный час
какой?
из описания не понятно.
Вы бы вручную нарисовали требуемый результат


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
вставить определенный час
какой?
из описания не понятно.
Вы бы вручную нарисовали требуемый результат

Автор - Nic70y
Дата добавления - 15.07.2021 в 10:07
ПАМ Дата: Четверг, 15.07.2021, 10:22 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 214
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
Nic70y,
Цитата
вручную нарисовали


Пример за январь
К сообщению приложен файл: 4744023.xlsx(17.0 Kb)
 
Ответить
СообщениеNic70y,
Цитата
вручную нарисовали


Пример за январь

Автор - ПАМ
Дата добавления - 15.07.2021 в 10:22
Nic70y Дата: Четверг, 15.07.2021, 10:33 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 6932
Репутация: 1599 ±
Замечаний: 0% ±

Excel 2010
ели дата начинаются с 1-го числа и идут в порядке возрастания можно так:
Код
=ИНДЕКС(СО!B:B;ПОИСКПОЗ(ТЕКСТ(AE4;"ММММ");СО!A:A;)+СТРОКА(AE1)-ПОИСКПОЗ(КОНМЕСЯЦА(AE4;-1)+1;AE$4:AE4))


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщениеели дата начинаются с 1-го числа и идут в порядке возрастания можно так:
Код
=ИНДЕКС(СО!B:B;ПОИСКПОЗ(ТЕКСТ(AE4;"ММММ");СО!A:A;)+СТРОКА(AE1)-ПОИСКПОЗ(КОНМЕСЯЦА(AE4;-1)+1;AE$4:AE4))

Автор - Nic70y
Дата добавления - 15.07.2021 в 10:33
Serge_007 Дата: Четверг, 15.07.2021, 10:34 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 14333
Репутация: 2368 ±
Замечаний: ±

Excel 2010
Здравствуйте

Формула массива:
Код
=НАИМЕНЬШИЙ(ЕСЛИ(ТЕКСТ(AE4;"ММММ")=СО!A$2:A$147;СО!B$2:B$147;"");СТРОКА(A1))
К сообщению приложен файл: 20210715_.xls(82.0 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Формула массива:
Код
=НАИМЕНЬШИЙ(ЕСЛИ(ТЕКСТ(AE4;"ММММ")=СО!A$2:A$147;СО!B$2:B$147;"");СТРОКА(A1))

Автор - Serge_007
Дата добавления - 15.07.2021 в 10:34
ПАМ Дата: Четверг, 15.07.2021, 11:21 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 214
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
Nic70y, не обязательно с 1 числа, может и с 9 числа. Спасибо Вам огромное!
 
Ответить
СообщениеNic70y, не обязательно с 1 числа, может и с 9 числа. Спасибо Вам огромное!

Автор - ПАМ
Дата добавления - 15.07.2021 в 11:21
ПАМ Дата: Четверг, 15.07.2021, 11:22 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 214
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
Serge_007, очень благодарен!
 
Ответить
СообщениеSerge_007, очень благодарен!

Автор - ПАМ
Дата добавления - 15.07.2021 в 11:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор конкретных значений, исходя из определенных условий (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!