Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск позиции по заданному условию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск позиции по заданному условию (Формулы/Formulas)
Поиск позиции по заданному условию
gge29 Дата: Суббота, 17.07.2021, 14:58 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 233
Репутация: 3 ±
Замечаний: 0% ±

Помогите пожалуйста реализовать(описание внутри файла)
К сообщению приложен файл: 8019549_1.xlsm(58.7 Kb)
 
Ответить
СообщениеПомогите пожалуйста реализовать(описание внутри файла)

Автор - gge29
Дата добавления - 17.07.2021 в 14:58
Pelena Дата: Суббота, 17.07.2021, 17:07 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17793
Репутация: 3958 ±
Замечаний: ±

Excel 2016 & Mac Excel
Как вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС({"Больничный":"Донорский день":"Отпуск":"Учебный отпуск":"Д/О":"Увольнение"};ПОИСКПОЗ(ИСТИНА;МУМНОЖ((D20<=ЕСЛИОШИБКА(ДЕНЬ('ОСНОВНОЙ ТАБЕЛЬ'!$H$9:$AL$9);0))*(ЕСЛИОШИБКА(ДЕНЬ('ОСНОВНОЙ ТАБЕЛЬ'!$H$9:$AL$9);0)<=F20)*(ИНДЕКС('ОСНОВНОЙ ТАБЕЛЬ'!$H$11:$AL$31;ПОИСКПОЗ(C20;'ОСНОВНОЙ ТАБЕЛЬ'!$E$11:$E$31;0);0)={"Б":"Д":"О":"Э":"Д/О":"У"});ТРАНСП(СТОЛБЕЦ('ОСНОВНОЙ ТАБЕЛЬ'!$H$9:$AL$10))^0)>0;0));"")
К сообщению приложен файл: 1179868.xlsm(58.3 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеКак вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС({"Больничный":"Донорский день":"Отпуск":"Учебный отпуск":"Д/О":"Увольнение"};ПОИСКПОЗ(ИСТИНА;МУМНОЖ((D20<=ЕСЛИОШИБКА(ДЕНЬ('ОСНОВНОЙ ТАБЕЛЬ'!$H$9:$AL$9);0))*(ЕСЛИОШИБКА(ДЕНЬ('ОСНОВНОЙ ТАБЕЛЬ'!$H$9:$AL$9);0)<=F20)*(ИНДЕКС('ОСНОВНОЙ ТАБЕЛЬ'!$H$11:$AL$31;ПОИСКПОЗ(C20;'ОСНОВНОЙ ТАБЕЛЬ'!$E$11:$E$31;0);0)={"Б":"Д":"О":"Э":"Д/О":"У"});ТРАНСП(СТОЛБЕЦ('ОСНОВНОЙ ТАБЕЛЬ'!$H$9:$AL$10))^0)>0;0));"")

Автор - Pelena
Дата добавления - 17.07.2021 в 17:07
gge29 Дата: Понедельник, 19.07.2021, 11:34 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 233
Репутация: 3 ±
Замечаний: 0% ±

Добрый день!Не могу разобраться с массивом при переносе на основной лист(даже на этом,только нажав на формулу скобки пропадают нажимаю F2 Ctrl+shift+enter выдаёт ошибку) %) "Изменить часть объединённой ячейки невозможно"
 
Ответить
СообщениеДобрый день!Не могу разобраться с массивом при переносе на основной лист(даже на этом,только нажав на формулу скобки пропадают нажимаю F2 Ctrl+shift+enter выдаёт ошибку) %) "Изменить часть объединённой ячейки невозможно"

Автор - gge29
Дата добавления - 19.07.2021 в 11:34
Serge_007 Дата: Понедельник, 19.07.2021, 12:18 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14333
Репутация: 2368 ±
Замечаний: ±

Excel 2010
gge29, отмените объединение ячеек, введите формулу и объедините ячейки


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщениеgge29, отмените объединение ячеек, введите формулу и объедините ячейки

Автор - Serge_007
Дата добавления - 19.07.2021 в 12:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск позиции по заданному условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!