Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма произведений по столбцам - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма произведений по столбцам (Формулы/Formulas)
Сумма произведений по столбцам
npbzemlya Дата: Среда, 21.07.2021, 09:06 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Добрый день! Подскажите пожалуйста как PQ записать формулу суммы произведений по столбцам.
В примере это столбец В все столбцы это именованные диапазоны. Использую PQ так как столкнулся с ограничением количества аргументов в формуле и длинной самой формулы, а необходимо обработать 1000 пар столбцов.
Если есть решение без PQ, подскажите пожалуйста.
Благодарю!
К сообщению приложен файл: 6365572.xlsx(9.1 Kb)


Сообщение отредактировал npbzemlya - Среда, 21.07.2021, 09:42
 
Ответить
СообщениеДобрый день! Подскажите пожалуйста как PQ записать формулу суммы произведений по столбцам.
В примере это столбец В все столбцы это именованные диапазоны. Использую PQ так как столкнулся с ограничением количества аргументов в формуле и длинной самой формулы, а необходимо обработать 1000 пар столбцов.
Если есть решение без PQ, подскажите пожалуйста.
Благодарю!

Автор - npbzemlya
Дата добавления - 21.07.2021 в 09:06
Pelena Дата: Среда, 21.07.2021, 10:10 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17961
Репутация: 4001 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Посмотрите, может, без PQ обойдёмся, формулой
Код
=СУММПРОИЗВ(D2:J2*ЕЧИСЛО(ПОИСК("Цена";$D$1:$J$1));E2:K2*ЕЧИСЛО(ПОИСК("Кол-во";$E$1:$K$1)))
К сообщению приложен файл: 3570169.xlsx(9.9 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Посмотрите, может, без PQ обойдёмся, формулой
Код
=СУММПРОИЗВ(D2:J2*ЕЧИСЛО(ПОИСК("Цена";$D$1:$J$1));E2:K2*ЕЧИСЛО(ПОИСК("Кол-во";$E$1:$K$1)))

Автор - Pelena
Дата добавления - 21.07.2021 в 10:10
npbzemlya Дата: Четверг, 22.07.2021, 14:20 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Посмотрите, может, без PQ обойдёмся, формулой

Здравствуйте, все отлично работает!
Благодарю!


Сообщение отредактировал npbzemlya - Четверг, 22.07.2021, 14:20
 
Ответить
Сообщение
Посмотрите, может, без PQ обойдёмся, формулой

Здравствуйте, все отлично работает!
Благодарю!

Автор - npbzemlya
Дата добавления - 22.07.2021 в 14:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма произведений по столбцам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!