Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсветка определенного текста, по условиям всей строке - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсветка определенного текста, по условиям всей строке (Формулы/Formulas)
Подсветка определенного текста, по условиям всей строке
radox Дата: Пятница, 23.07.2021, 16:53 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Убил 3 часа и не смог понять, как подсветить нужный текст при определенных условиях.

Задача.
Нужно чтобы слово Игнор подсвечивалось желтым цветом, при условии, что на одной строке с этим словом нет одного из 3-х слов "Согласен; Отказ; Контакт)

В таблице excel, на первом листе черновик, на втором листе результат который хочу получить.

Пробовал
Код
=И(A2<>"Согласен";A$2<>"Отказ";A$2<>"Контакт";A2="Игнор")
, в итоге если в столбце A соблюдаются условия, все ок. На остальных столбцах это не работает.
К сообщению приложен файл: 4083516.xlsx(10.8 Kb)


Сообщение отредактировал Serge_007 - Пятница, 23.07.2021, 17:14
 
Ответить
СообщениеУбил 3 часа и не смог понять, как подсветить нужный текст при определенных условиях.

Задача.
Нужно чтобы слово Игнор подсвечивалось желтым цветом, при условии, что на одной строке с этим словом нет одного из 3-х слов "Согласен; Отказ; Контакт)

В таблице excel, на первом листе черновик, на втором листе результат который хочу получить.

Пробовал
Код
=И(A2<>"Согласен";A$2<>"Отказ";A$2<>"Контакт";A2="Игнор")
, в итоге если в столбце A соблюдаются условия, все ок. На остальных столбцах это не работает.

Автор - radox
Дата добавления - 23.07.2021 в 16:53
Nic70y Дата: Пятница, 23.07.2021, 17:01 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7117
Репутация: 1641 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММ(--ЕЧИСЛО(ПОИСК($A2:$D2;"Согласен;Отказ;Контакт")))*2+(A2="Игнор")=1
К сообщению приложен файл: 24.xlsx(9.1 Kb)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
Код
=СУММ(--ЕЧИСЛО(ПОИСК($A2:$D2;"Согласен;Отказ;Контакт")))*2+(A2="Игнор")=1

Автор - Nic70y
Дата добавления - 23.07.2021 в 17:01
radox Дата: Пятница, 23.07.2021, 17:41 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Спасибо!
 
Ответить
СообщениеСпасибо!

Автор - radox
Дата добавления - 23.07.2021 в 17:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсветка определенного текста, по условиям всей строке (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!