Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Посчитать сумму ячеек с буквами и цифрами - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать сумму ячеек с буквами и цифрами (Формулы/Formulas)
Посчитать сумму ячеек с буквами и цифрами
igor13071 Дата: Понедельник, 02.08.2021, 22:04 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Добрый день,

Вопрос состоит в том, а возможно ли создать универсальную (одну) формулу для трех примеров (прикладываю файл) для подсчёта только суммы цифр исключая все буквы?

С уважением
К сообщению приложен файл: 5982948.xlsx(9.6 Kb)
 
Ответить
СообщениеДобрый день,

Вопрос состоит в том, а возможно ли создать универсальную (одну) формулу для трех примеров (прикладываю файл) для подсчёта только суммы цифр исключая все буквы?

С уважением

Автор - igor13071
Дата добавления - 02.08.2021 в 22:04
Pelena Дата: Понедельник, 02.08.2021, 22:19 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17889
Репутация: 3982 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Код
=СУММПРОИЗВ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ(B1:AE1;"/DN";"");0))
К сообщению приложен файл: 7329838.xlsx(10.6 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=СУММПРОИЗВ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ(B1:AE1;"/DN";"");0))

Автор - Pelena
Дата добавления - 02.08.2021 в 22:19
igor13071 Дата: Вторник, 03.08.2021, 21:17 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Спасибо большое. Но вставляю в свой лист и получаю 0. Пробовал сохранять в xls, тоже показывает 0. В чем проблема как думаете?
 
Ответить
СообщениеСпасибо большое. Но вставляю в свой лист и получаю 0. Пробовал сохранять в xls, тоже показывает 0. В чем проблема как думаете?

Автор - igor13071
Дата добавления - 03.08.2021 в 21:17
bigor Дата: Вторник, 03.08.2021, 21:49 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 492
Репутация: 94 ±
Замечаний: 0% ±

нет
В чем проблема как думаете?

Вряд ли у кого настолько прокачаны навыки ясновидения :) Покажите свой лист, что бы не гадать
 
Ответить
Сообщение
В чем проблема как думаете?

Вряд ли у кого настолько прокачаны навыки ясновидения :) Покажите свой лист, что бы не гадать

Автор - bigor
Дата добавления - 03.08.2021 в 21:49
igor13071 Дата: Среда, 04.08.2021, 19:37 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Вряд ли у кого настолько прокачаны навыки ясновидения Покажите свой лист, что бы не гадать


Прошу.
К сообщению приложен файл: 3748747.xlsx(10.3 Kb)
 
Ответить
Сообщение
Вряд ли у кого настолько прокачаны навыки ясновидения Покажите свой лист, что бы не гадать


Прошу.

Автор - igor13071
Дата добавления - 04.08.2021 в 19:37
bigor Дата: Среда, 04.08.2021, 20:16 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 492
Репутация: 94 ±
Замечаний: 0% ±

нет
Прошу.

Как бы не вижу ошибки
зы массивный ввод для SUMPODUCT() избыточен в Excel без него не работает
К сообщению приложен файл: 4210713.png(41.4 Kb)


Сообщение отредактировал bigor - Среда, 04.08.2021, 20:20
 
Ответить
Сообщение
Прошу.

Как бы не вижу ошибки
зы массивный ввод для SUMPODUCT() избыточен в Excel без него не работает

Автор - bigor
Дата добавления - 04.08.2021 в 20:16
Egyptian Дата: Среда, 04.08.2021, 22:32 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 166
Репутация: 54 ±
Замечаний: 0% ±

Excel 2013/2016
Увы, тут без массивного ввода через CTRL+SHIFT+ENTER не обойдешься.
 
Ответить
СообщениеУвы, тут без массивного ввода через CTRL+SHIFT+ENTER не обойдешься.

Автор - Egyptian
Дата добавления - 04.08.2021 в 22:32
bmv98rus Дата: Четверг, 05.08.2021, 07:49 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3656
Репутация: 649 ±
Замечаний: 0% ±

Excel 2013/2016
тут без массивного ввода через CTRL+SHIFT+ENTER не обойдешься.

ну почему же
Код
=SUMPRODUCT(--TEXT(SUBSTITUTE(B1:AE1;"/DN";"");"0;0;0;\0"))


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
тут без массивного ввода через CTRL+SHIFT+ENTER не обойдешься.

ну почему же
Код
=SUMPRODUCT(--TEXT(SUBSTITUTE(B1:AE1;"/DN";"");"0;0;0;\0"))

Автор - bmv98rus
Дата добавления - 05.08.2021 в 07:49
Egyptian Дата: Четверг, 05.08.2021, 09:53 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 166
Репутация: 54 ±
Замечаний: 0% ±

Excel 2013/2016
Да, действительно. Буду знать!
 
Ответить
СообщениеДа, действительно. Буду знать!

Автор - Egyptian
Дата добавления - 05.08.2021 в 09:53
igor13071 Дата: Четверг, 05.08.2021, 20:22 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

ну почему же
Код
=СУММПРОИЗВ(--ТЕКСТ(ПОДСТАВИТЬ(B1:AE1;"/DN";"");"0;0;0;\0"))
Спасибо! Работает!


Сообщение отредактировал Serge_007 - Пятница, 06.08.2021, 09:07
 
Ответить
Сообщение
ну почему же
Код
=СУММПРОИЗВ(--ТЕКСТ(ПОДСТАВИТЬ(B1:AE1;"/DN";"");"0;0;0;\0"))
Спасибо! Работает!

Автор - igor13071
Дата добавления - 05.08.2021 в 20:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать сумму ячеек с буквами и цифрами (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!