Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/в двумерном массиве посчитать кол-во строк по 2 условиям - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » в двумерном массиве посчитать кол-во строк по 2 условиям (Формулы/Formulas)
в двумерном массиве посчитать кол-во строк по 2 условиям
8sn888 Дата: Четверг, 12.08.2021, 22:11 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Добрый вечер!

Есть двумерный массив из 3 столбцов и 5 строк, в ячейках которого - числовые значения.
Нужно посчитать формулой количество строк в этом массиве, в которых присутствуют оба заданных по условию числа (вне зависимости, в каком из столбцов они стоят).
Прикладываю пример.

Если мои неудачные формулы в примере не сконвертировались автоматически, то я пыталась использовать СЧЁТЕСЛИ, ИНДЕКС с ПОИСКПОЗ, СУММПРОИЗВ.
Но это не релевантно, так как они всё равно не работают.


(исправлено цифры на число)
К сообщению приложен файл: 8412547.xlsx(12.3 Kb)


Сообщение отредактировал 8sn888 - Пятница, 13.08.2021, 10:24
 
Ответить
СообщениеДобрый вечер!

Есть двумерный массив из 3 столбцов и 5 строк, в ячейках которого - числовые значения.
Нужно посчитать формулой количество строк в этом массиве, в которых присутствуют оба заданных по условию числа (вне зависимости, в каком из столбцов они стоят).
Прикладываю пример.

Если мои неудачные формулы в примере не сконвертировались автоматически, то я пыталась использовать СЧЁТЕСЛИ, ИНДЕКС с ПОИСКПОЗ, СУММПРОИЗВ.
Но это не релевантно, так как они всё равно не работают.


(исправлено цифры на число)

Автор - 8sn888
Дата добавления - 12.08.2021 в 22:11
прохожий2019 Дата: Четверг, 12.08.2021, 23:56 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 667
Репутация: 169 ±
Замечаний: 0% ±

365 Beta Channel
55 - это две цифры, но одно число - не пишите больше так, а то слёзы от этого...
Код
=СУММ(--((СЧЁТЕСЛИ(СМЕЩ(B1;СТРОКА(A1:A5);;1;3);E8)+СЧЁТЕСЛИ(СМЕЩ(B1;СТРОКА(A1:A5);;1;3);F8))=2))
К сообщению приложен файл: 8119047.xlsx(13.2 Kb)
 
Ответить
Сообщение55 - это две цифры, но одно число - не пишите больше так, а то слёзы от этого...
Код
=СУММ(--((СЧЁТЕСЛИ(СМЕЩ(B1;СТРОКА(A1:A5);;1;3);E8)+СЧЁТЕСЛИ(СМЕЩ(B1;СТРОКА(A1:A5);;1;3);F8))=2))

Автор - прохожий2019
Дата добавления - 12.08.2021 в 23:56
Светлый Дата: Пятница, 13.08.2021, 09:15 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1676
Репутация: 447 ±
Замечаний: 0% ±

Excel 2013, 2016
Формула массива. Считает строки, где образцы встречаются только по одному разу:
Код
=СУММ(Ч(МУМНОЖ((СЧЁТЕСЛИ(E8;B2:D6)>0)*10+(СЧЁТЕСЛИ(F8;B2:D6)>0);ТРАНСП(B2:D2^0))=11))
*Второе решение аналогичное:
Код
=СУММ(Ч(МУМНОЖ(ЕСЛИОШИБКА(ПОИСКПОЗ(B2:D6;E8:F8;););ТРАНСП(B2:D2)^0)=3))
**Значение в строке может встречаться несколько раз, но второе значение в этой же строке тоже есть:
Код
=СУММ(Ч(МУМНОЖ(Ч(B2:D6=E8);ТРАНСП(B2:D2)^0)*МУМНОЖ(Ч(B2:D6=F8);ТРАНСП(B2:D2)^0)>0))
***Из первой группы:
Код
=СУММ(Ч(МУМНОЖ((B2:D6=E8)*2+(B2:D6=F8);ТРАНСП(B2:D2)^0)=3))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Пятница, 13.08.2021, 11:06
 
Ответить
СообщениеФормула массива. Считает строки, где образцы встречаются только по одному разу:
Код
=СУММ(Ч(МУМНОЖ((СЧЁТЕСЛИ(E8;B2:D6)>0)*10+(СЧЁТЕСЛИ(F8;B2:D6)>0);ТРАНСП(B2:D2^0))=11))
*Второе решение аналогичное:
Код
=СУММ(Ч(МУМНОЖ(ЕСЛИОШИБКА(ПОИСКПОЗ(B2:D6;E8:F8;););ТРАНСП(B2:D2)^0)=3))
**Значение в строке может встречаться несколько раз, но второе значение в этой же строке тоже есть:
Код
=СУММ(Ч(МУМНОЖ(Ч(B2:D6=E8);ТРАНСП(B2:D2)^0)*МУМНОЖ(Ч(B2:D6=F8);ТРАНСП(B2:D2)^0)>0))
***Из первой группы:
Код
=СУММ(Ч(МУМНОЖ((B2:D6=E8)*2+(B2:D6=F8);ТРАНСП(B2:D2)^0)=3))

Автор - Светлый
Дата добавления - 13.08.2021 в 09:15
8sn888 Дата: Пятница, 13.08.2021, 10:21 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Доброе утро, прохожий 2019 и Светлый!

Большое человеческое спасибо за ответ!
Работа продвинулась благодаря Вам!

:) :) :)

Прошу прощения за фундаментальную ошибку в школьных понятиях.
Вроде умная, а так ляпнула по-крупному(
(почувствовала себя героиней фильма "Рассказы", 4 часть)

Светлана
 
Ответить
СообщениеДоброе утро, прохожий 2019 и Светлый!

Большое человеческое спасибо за ответ!
Работа продвинулась благодаря Вам!

:) :) :)

Прошу прощения за фундаментальную ошибку в школьных понятиях.
Вроде умная, а так ляпнула по-крупному(
(почувствовала себя героиней фильма "Рассказы", 4 часть)

Светлана

Автор - 8sn888
Дата добавления - 13.08.2021 в 10:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » в двумерном массиве посчитать кол-во строк по 2 условиям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!