Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Не считает сумму по условию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Не считает сумму по условию (Формулы/Formulas)
Не считает сумму по условию
Oh_Nick Дата: Пятница, 20.08.2021, 09:30 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 201
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день!

Подскажите, пожалуйста, почему не складывает значения в ячейке I2 (колонка Saving Total Local) , лист Sheet1
К сообщению приложен файл: Stackable_savin.xlsm(45.3 Kb)
 
Ответить
СообщениеДобрый день!

Подскажите, пожалуйста, почему не складывает значения в ячейке I2 (колонка Saving Total Local) , лист Sheet1

Автор - Oh_Nick
Дата добавления - 20.08.2021 в 09:30
Serge_007 Дата: Пятница, 20.08.2021, 09:53 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14465
Репутация: 2384 ±
Замечаний: ±

Excel 2010
Здравствуйте

Данные в столбце F - это текст
Текст суммировать не получится

Так будет работать:
Код
=--ЕСЛИОШИБКА(savingRUB(B2;D2;E2);"")


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Данные в столбце F - это текст
Текст суммировать не получится

Так будет работать:
Код
=--ЕСЛИОШИБКА(savingRUB(B2;D2;E2);"")

Автор - Serge_007
Дата добавления - 20.08.2021 в 09:53
Oh_Nick Дата: Пятница, 20.08.2021, 10:27 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 201
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Serge_007,

спасибо большое!
 
Ответить
СообщениеSerge_007,

спасибо большое!

Автор - Oh_Nick
Дата добавления - 20.08.2021 в 10:27
Oh_Nick Дата: Пятница, 20.08.2021, 10:28 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 201
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Serge_007, а пустую ячейку как оставить? а то протягиваю и пишет VALUE
 
Ответить
СообщениеSerge_007, а пустую ячейку как оставить? а то протягиваю и пишет VALUE

Автор - Oh_Nick
Дата добавления - 20.08.2021 в 10:28
Erjoma1981 Дата: Пятница, 20.08.2021, 10:31 | Сообщение № 5
Группа: Проверенные
Ранг: Новичок
Сообщений: 32
Репутация: 16 ±
Замечаний: 0% ±

Здравствуйте.

Должно помочь : в столбце F вставить формулу
Код
=ЕСЛИОШИБКА(ЗНАЧЕН(savingRUB(B2;D2;E2));0)


В [vba]
Код
Function savingRUB(transport, city, price) As String
[/vba]

изменить [vba]
Код

If acell Is Nothing Then
    savingRUB = "NON CITY"
Else
    row = acell.row
End If
[/vba]
На
[vba]
Код

If acell Is Nothing Then
    savingRUB = "NON CITY"
    Exit Function
Else
    row = acell.row
End If
[/vba]

[vba]
Код

If acell Is Nothing Then
    savingRUB = "NON TRANSPORT"
Else
    col = acell.Column
End If
[/vba]
На
[vba]
Код

If acell Is Nothing Then
    savingRUB = "NON TRANSPORT"
    Exit Function
Else
    col = acell.Column
End If
[/vba]

Аналогичные замены сделать в [vba]
Код
savingEUR(transport, country, price) As String
[/vba]


Сообщение отредактировал Erjoma1981 - Пятница, 20.08.2021, 10:31
 
Ответить
СообщениеЗдравствуйте.

Должно помочь : в столбце F вставить формулу
Код
=ЕСЛИОШИБКА(ЗНАЧЕН(savingRUB(B2;D2;E2));0)


В [vba]
Код
Function savingRUB(transport, city, price) As String
[/vba]

изменить [vba]
Код

If acell Is Nothing Then
    savingRUB = "NON CITY"
Else
    row = acell.row
End If
[/vba]
На
[vba]
Код

If acell Is Nothing Then
    savingRUB = "NON CITY"
    Exit Function
Else
    row = acell.row
End If
[/vba]

[vba]
Код

If acell Is Nothing Then
    savingRUB = "NON TRANSPORT"
Else
    col = acell.Column
End If
[/vba]
На
[vba]
Код

If acell Is Nothing Then
    savingRUB = "NON TRANSPORT"
    Exit Function
Else
    col = acell.Column
End If
[/vba]

Аналогичные замены сделать в [vba]
Код
savingEUR(transport, country, price) As String
[/vba]

Автор - Erjoma1981
Дата добавления - 20.08.2021 в 10:31
Oh_Nick Дата: Пятница, 20.08.2021, 11:10 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 201
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Erjoma1981, помогла эта формула
Код
=--IFERROR(@savingRUB(B6;D6;E6);"")


А как убрать VALUE, чтобы при протягивании вниз пустая ячейка была?
 
Ответить
СообщениеErjoma1981, помогла эта формула
Код
=--IFERROR(@savingRUB(B6;D6;E6);"")


А как убрать VALUE, чтобы при протягивании вниз пустая ячейка была?

Автор - Oh_Nick
Дата добавления - 20.08.2021 в 11:10
Erjoma1981 Дата: Пятница, 20.08.2021, 11:33 | Сообщение № 7
Группа: Проверенные
Ранг: Новичок
Сообщений: 32
Репутация: 16 ±
Замечаний: 0% ±

помогла эта формула

с ошибкой в пустых ячейках?


Сообщение отредактировал Erjoma1981 - Пятница, 20.08.2021, 11:34
 
Ответить
Сообщение
помогла эта формула

с ошибкой в пустых ячейках?

Автор - Erjoma1981
Дата добавления - 20.08.2021 в 11:33
Oh_Nick Дата: Пятница, 20.08.2021, 11:40 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 201
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Erjoma1981, Вот так сейчас:

,
К сообщению приложен файл: 9413636.jpg(35.9 Kb)
 
Ответить
СообщениеErjoma1981, Вот так сейчас:

,

Автор - Oh_Nick
Дата добавления - 20.08.2021 в 11:40
Erjoma1981 Дата: Пятница, 20.08.2021, 11:47 | Сообщение № 9
Группа: Проверенные
Ранг: Новичок
Сообщений: 32
Репутация: 16 ±
Замечаний: 0% ±

[vba]
Код
=ЕСЛИОШИБКА(--savingRUB(B6;D6;E6);"")
[/vba]
 
Ответить
Сообщение[vba]
Код
=ЕСЛИОШИБКА(--savingRUB(B6;D6;E6);"")
[/vba]

Автор - Erjoma1981
Дата добавления - 20.08.2021 в 11:47
Serge_007 Дата: Пятница, 20.08.2021, 11:48 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 14465
Репутация: 2384 ±
Замечаний: ±

Excel 2010
как убрать VALUE, чтобы при протягивании вниз пустая ячейка была?
Код
=ЕСЛИОШИБКА(0+savingRUB(B2;D2;E2);"")


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
как убрать VALUE, чтобы при протягивании вниз пустая ячейка была?
Код
=ЕСЛИОШИБКА(0+savingRUB(B2;D2;E2);"")

Автор - Serge_007
Дата добавления - 20.08.2021 в 11:48
Oh_Nick Дата: Пятница, 20.08.2021, 12:37 | Сообщение № 11
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 201
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Serge_007, спасибо!
 
Ответить
СообщениеSerge_007, спасибо!

Автор - Oh_Nick
Дата добавления - 20.08.2021 в 12:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Не считает сумму по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!