Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подстановка максимальной цены товара - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка максимальной цены товара (Формулы/Formulas)
Подстановка максимальной цены товара
Timon6041 Дата: Понедельник, 23.08.2021, 00:06 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Есть список ТМЦ, так же отдельным листом вводятся приходные данные.

Так вот, чтобы цена на ТМЦ всегда была актуальна, надо из другого списка вытягивать информацию по артикулу и бренду максимальной стоимости товара
Например:
Всписке ТМЦ есть:
ТОВАР 1 цена 12
ТОВАР 2 цена 11

По приходу ТОВАР 1 цена изменилась на 12,5, надо в списке ТМЦ изменить цену на 12,5

Т.е. найти по бренду и артикулу максимальную стоимость и подставить в нужную ячейку


Сообщение отредактировал Timon6041 - Понедельник, 23.08.2021, 00:07
 
Ответить
СообщениеЕсть список ТМЦ, так же отдельным листом вводятся приходные данные.

Так вот, чтобы цена на ТМЦ всегда была актуальна, надо из другого списка вытягивать информацию по артикулу и бренду максимальной стоимости товара
Например:
Всписке ТМЦ есть:
ТОВАР 1 цена 12
ТОВАР 2 цена 11

По приходу ТОВАР 1 цена изменилась на 12,5, надо в списке ТМЦ изменить цену на 12,5

Т.е. найти по бренду и артикулу максимальную стоимость и подставить в нужную ячейку

Автор - Timon6041
Дата добавления - 23.08.2021 в 00:06
Светлый Дата: Понедельник, 23.08.2021, 06:34 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1685
Репутация: 450 ±
Замечаний: 0% ±

Excel 2013, 2016
И Вам, здравствуйте!
А если новое поступление с меньшей ценой, а старая уже закончилась. Цену выбирать, которой уже нет?
А если бы был файл, да с примером, было бы проще помочь.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеИ Вам, здравствуйте!
А если новое поступление с меньшей ценой, а старая уже закончилась. Цену выбирать, которой уже нет?
А если бы был файл, да с примером, было бы проще помочь.

Автор - Светлый
Дата добавления - 23.08.2021 в 06:34
Timon6041 Дата: Понедельник, 23.08.2021, 08:50 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Если приход по меньшей цене, то оставляем старую цену, которая была больше
Прикрепил пример
На одном листе список расходных материалов, на другом их поступление.
Надо выбрать из списка поступления и подставить цену в списке расходных материалов. Конкретный товар PC-118 PATRON очиститель

Спасибо большое
К сообщению приложен файл: 6446099.xlsx(9.1 Kb)
 
Ответить
СообщениеЕсли приход по меньшей цене, то оставляем старую цену, которая была больше
Прикрепил пример
На одном листе список расходных материалов, на другом их поступление.
Надо выбрать из списка поступления и подставить цену в списке расходных материалов. Конкретный товар PC-118 PATRON очиститель

Спасибо большое

Автор - Timon6041
Дата добавления - 23.08.2021 в 08:50
Nic70y Дата: Понедельник, 23.08.2021, 09:10 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 7034
Репутация: 1627 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММПРОИЗВ(МАКС((Поступления!$A$2:$A$15000=A2)*(Поступления!$D$2:$D$15000)))


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(МАКС((Поступления!$A$2:$A$15000=A2)*(Поступления!$D$2:$D$15000)))

Автор - Nic70y
Дата добавления - 23.08.2021 в 09:10
jakim Дата: Понедельник, 23.08.2021, 10:09 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1037
Репутация: 278 ±
Замечаний: 0% ±

Excel 2010
Код
=AGGREGATE(14;6;Поступления!D2:D800/(Поступления!A2:A800=A2);1)
 
Ответить
Сообщение
Код
=AGGREGATE(14;6;Поступления!D2:D800/(Поступления!A2:A800=A2);1)

Автор - jakim
Дата добавления - 23.08.2021 в 10:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка максимальной цены товара (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!