Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Преобразование времени из текстового в стандартный формат - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Преобразование времени из текстового в стандартный формат (Формулы/Formulas)
Преобразование времени из текстового в стандартный формат
luba130694 Дата: Понедельник, 23.08.2021, 12:16 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Добрый день! Помогите, пожалуйста, преобразовать время из текстового формата (например, 18 м. 45 с.) в стандартный ЧЧ:ММ:СС. В дальнейшем нужно все это время сложить.
К сообщению приложен файл: 5530755.xlsx(7.9 Kb)
 
Ответить
СообщениеДобрый день! Помогите, пожалуйста, преобразовать время из текстового формата (например, 18 м. 45 с.) в стандартный ЧЧ:ММ:СС. В дальнейшем нужно все это время сложить.

Автор - luba130694
Дата добавления - 23.08.2021 в 12:16
bmv98rus Дата: Понедельник, 23.08.2021, 12:36 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3656
Репутация: 649 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=--("00:"&TRIM(SUBSTITUTE(SUBSTITUTE(A3;" м. ";":");" c.";)))

но если появятся часы, то нужно усложнять


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Код
=--("00:"&TRIM(SUBSTITUTE(SUBSTITUTE(A3;" м. ";":");" c.";)))

но если появятся часы, то нужно усложнять

Автор - bmv98rus
Дата добавления - 23.08.2021 в 12:36
китин Дата: Понедельник, 23.08.2021, 12:43 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 6538
Репутация: 997 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
может так?
Код
=СУММ(--("00:"&СЖПРОБЕЛЫ(ПОДСТАВИТЬ(ПОДСТАВИТЬ($A$3:$A$15;" м. ";":");"c.";""))))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 5530755-1-.xlsx(9.3 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеможет так?
Код
=СУММ(--("00:"&СЖПРОБЕЛЫ(ПОДСТАВИТЬ(ПОДСТАВИТЬ($A$3:$A$15;" м. ";":");"c.";""))))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - китин
Дата добавления - 23.08.2021 в 12:43
luba130694 Дата: Понедельник, 23.08.2021, 12:49 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Спасибо всем большое, работает))
 
Ответить
СообщениеСпасибо всем большое, работает))

Автор - luba130694
Дата добавления - 23.08.2021 в 12:49
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Преобразование времени из текстового в стандартный формат (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!