Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчет максимального значения по условию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет максимального значения по условию (Формулы/Formulas)
Расчет максимального значения по условию
ankmine Дата: Вторник, 24.08.2021, 10:44 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Добрый день! Борюсь с климатом и появился вопрос, додумать который я не могу самостоятельно! Имеются данные за различные годы по месяцам. Мне нужно выбрать максимальное значение температуры за каждый месяц, каждого года. Раньше пока не было нужды я использовала формулу =МАКС(Если...). Формула ищет максимальные значения. Теперь мне нужно, чтобы считалось максимальное, но если не выполняется условие c<b<a, не считались данные за весь месяц, а не только за те строки в данном месяце где это условие не выполняется.
К сообщению приложен файл: 0971998.xlsx(11.4 Kb)
 
Ответить
СообщениеДобрый день! Борюсь с климатом и появился вопрос, додумать который я не могу самостоятельно! Имеются данные за различные годы по месяцам. Мне нужно выбрать максимальное значение температуры за каждый месяц, каждого года. Раньше пока не было нужды я использовала формулу =МАКС(Если...). Формула ищет максимальные значения. Теперь мне нужно, чтобы считалось максимальное, но если не выполняется условие c<b<a, не считались данные за весь месяц, а не только за те строки в данном месяце где это условие не выполняется.

Автор - ankmine
Дата добавления - 24.08.2021 в 10:44
Serge_007 Дата: Вторник, 24.08.2021, 11:31 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14486
Репутация: 2390 ±
Замечаний: ±

Excel 2010
Здравствуйте

Так надо:
Код
=МАКС((($E2:$E9>$D2:$D9)*($D2:$D9>$C2:$C9)*($B2:$B9=J5)*($A2:$A9=J4)*$C2:$E9))
?
К сообщению приложен файл: 20210824_ankmin.xls(69.5 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Так надо:
Код
=МАКС((($E2:$E9>$D2:$D9)*($D2:$D9>$C2:$C9)*($B2:$B9=J5)*($A2:$A9=J4)*$C2:$E9))
?

Автор - Serge_007
Дата добавления - 24.08.2021 в 11:31
ankmine Дата: Вторник, 24.08.2021, 12:12 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Serge_007, Я попробовала данную формулу. Она нашла строку, где выполняется условие c<b<a и выдала его. А мне надо (на примере 1 месяца) найти максимальное если это условие выполняется для всех строк 1 месяца, если в какой то строке это условие не выполняется, то максимальное не определяется для всего месяца.
 
Ответить
СообщениеSerge_007, Я попробовала данную формулу. Она нашла строку, где выполняется условие c<b<a и выдала его. А мне надо (на примере 1 месяца) найти максимальное если это условие выполняется для всех строк 1 месяца, если в какой то строке это условие не выполняется, то максимальное не определяется для всего месяца.

Автор - ankmine
Дата добавления - 24.08.2021 в 12:12
Serge_007 Дата: Вторник, 24.08.2021, 17:44 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14486
Репутация: 2390 ±
Замечаний: ±

Excel 2010
Не совсем понимаю, что должно получиться
Вручную проставьте в файле пару результатов, пояснив, почему так


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеНе совсем понимаю, что должно получиться
Вручную проставьте в файле пару результатов, пояснив, почему так

Автор - Serge_007
Дата добавления - 24.08.2021 в 17:44
ankmine Дата: Вторник, 24.08.2021, 18:21 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Serge_007, прикрепила пример файла, с которым я работаю и внутри расписала все
 
Ответить
СообщениеSerge_007, прикрепила пример файла, с которым я работаю и внутри расписала все

Автор - ankmine
Дата добавления - 24.08.2021 в 18:21
ankmine Дата: Вторник, 24.08.2021, 18:22 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

ankmine,
К сообщению приложен файл: _2.xlsx(65.6 Kb)
 
Ответить
Сообщениеankmine,

Автор - ankmine
Дата добавления - 24.08.2021 в 18:22
Pelena Дата: Вторник, 24.08.2021, 19:12 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 17889
Репутация: 3982 ±
Замечаний: ±

Excel 2016 & Mac Excel
Код
=МАКС((СУММПРОИЗВ(($D$2:$D$4000<$E$2:$E$4000)*($E$2:$E$4000<$F$2:$F$4000)*($B$2:$B$4000=L$155)*($C$2:$C$4000=L$156))=СУММПРОИЗВ(($B$2:$B$4000=L$155)*($C$2:$C$4000=L$156)*($F$2:$F$4000<>"")))*$F$2:$F$4000)
К сообщению приложен файл: _2-3-.xlsx(66.8 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=МАКС((СУММПРОИЗВ(($D$2:$D$4000<$E$2:$E$4000)*($E$2:$E$4000<$F$2:$F$4000)*($B$2:$B$4000=L$155)*($C$2:$C$4000=L$156))=СУММПРОИЗВ(($B$2:$B$4000=L$155)*($C$2:$C$4000=L$156)*($F$2:$F$4000<>"")))*$F$2:$F$4000)

Автор - Pelena
Дата добавления - 24.08.2021 в 19:12
ankmine Дата: Среда, 25.08.2021, 09:13 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Pelena, О! все работает спасибо hands Теперь буду разбираться как это устроено) А можно еще вопрос. Если мне нужно задать несколько условий, чтобы выполнялось или одно или другое, то вместо "*" можно поставить "+"?
 
Ответить
СообщениеPelena, О! все работает спасибо hands Теперь буду разбираться как это устроено) А можно еще вопрос. Если мне нужно задать несколько условий, чтобы выполнялось или одно или другое, то вместо "*" можно поставить "+"?

Автор - ankmine
Дата добавления - 25.08.2021 в 09:13
Serge_007 Дата: Среда, 25.08.2021, 09:14 | Сообщение № 9
Группа: Админы
Ранг: Местный житель
Сообщений: 14486
Репутация: 2390 ±
Замечаний: ±

Excel 2010
ankmine, "*" - это И(), "+" - это ИЛИ()


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщениеankmine, "*" - это И(), "+" - это ИЛИ()

Автор - Serge_007
Дата добавления - 25.08.2021 в 09:14
ankmine Дата: Среда, 25.08.2021, 09:37 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Serge_007, Спасибо ^_^
 
Ответить
СообщениеSerge_007, Спасибо ^_^

Автор - ankmine
Дата добавления - 25.08.2021 в 09:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет максимального значения по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!