Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/суммирование ячеек где есть ячейки #H/Д - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » суммирование ячеек где есть ячейки #H/Д (Формулы/Formulas)
суммирование ячеек где есть ячейки #H/Д
Afsati Дата: Суббота, 28.08.2021, 12:42 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Голову сломал всю! Ничего не могу сделать. Пробовал разными способами (агрегат, массив)-нет результата. Прошу помощи. Как суммировать значения ячеек строки, игнорируя ячейки #Н/Д? Табличку прилагаю
К сообщению приложен файл: 9410575.xlsx(8.3 Kb)
 
Ответить
СообщениеГолову сломал всю! Ничего не могу сделать. Пробовал разными способами (агрегат, массив)-нет результата. Прошу помощи. Как суммировать значения ячеек строки, игнорируя ячейки #Н/Д? Табличку прилагаю

Автор - Afsati
Дата добавления - 28.08.2021 в 12:42
Nic70y Дата: Суббота, 28.08.2021, 12:54 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7017
Репутация: 1618 ±
Замечаний: 0% ±

Excel 2010
массив
Код
=СУММ(--ЕСЛИОШИБКА(A2:D2;))


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
массив
Код
=СУММ(--ЕСЛИОШИБКА(A2:D2;))

Автор - Nic70y
Дата добавления - 28.08.2021 в 12:54
Afsati Дата: Суббота, 28.08.2021, 21:45 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Эврика! Спасибо вам огромное! Дай Бог здоровья!
 
Ответить
СообщениеЭврика! Спасибо вам огромное! Дай Бог здоровья!

Автор - Afsati
Дата добавления - 28.08.2021 в 21:45
jakim Дата: Воскресенье, 29.08.2021, 14:30 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1035
Репутация: 278 ±
Замечаний: 0% ±

Excel 2010
Две формулы без массивного ввода

Код
=SUMIF(A2:D2;"<1E100")

Код
=AGGREGATE(9;6;A2:D2)
 
Ответить
Сообщение
Две формулы без массивного ввода

Код
=SUMIF(A2:D2;"<1E100")

Код
=AGGREGATE(9;6;A2:D2)

Автор - jakim
Дата добавления - 29.08.2021 в 14:30
bmv98rus Дата: Воскресенье, 29.08.2021, 14:36 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3651
Репутация: 647 ±
Замечаний: 0% ±

Excel 2013/2016
jakim, и обе работают?


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениеjakim, и обе работают?

Автор - bmv98rus
Дата добавления - 29.08.2021 в 14:36
jakim Дата: Воскресенье, 29.08.2021, 15:54 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1035
Репутация: 278 ±
Замечаний: 0% ±

Excel 2010
Работают, если поменять данные на числовой или общий формат.
 
Ответить
Сообщение
Работают, если поменять данные на числовой или общий формат.

Автор - jakim
Дата добавления - 29.08.2021 в 15:54
Nic70y Дата: Воскресенье, 29.08.2021, 18:52 | Сообщение № 7
Группа: Друзья
Ранг: Экселист
Сообщений: 7017
Репутация: 1618 ±
Замечаний: 0% ±

Excel 2010
и обе работают?

Работают, если
а если не если?)) jakim, ну че Вы прикалываетесь постоянно))
Пробовал разными способами (агрегат, массив)
а по чему не получилось?
видимо потому, что
если поменять данные на числовой


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
и обе работают?

Работают, если
а если не если?)) jakim, ну че Вы прикалываетесь постоянно))
Пробовал разными способами (агрегат, массив)
а по чему не получилось?
видимо потому, что
если поменять данные на числовой

Автор - Nic70y
Дата добавления - 29.08.2021 в 18:52
jakim Дата: Понедельник, 30.08.2021, 09:38 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1035
Репутация: 278 ±
Замечаний: 0% ±

Excel 2010
Просто забыл напомнить в своём первом посте о преобразовании данных в числовой формат и даже не думал прикалывться.
 
Ответить
Сообщение
Просто забыл напомнить в своём первом посте о преобразовании данных в числовой формат и даже не думал прикалывться.

Автор - jakim
Дата добавления - 30.08.2021 в 09:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » суммирование ячеек где есть ячейки #H/Д (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!