Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Извлечение текста из диапазона по определенному признаку. - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Извлечение текста из диапазона по определенному признаку. (Формулы/Formulas)
Извлечение текста из диапазона по определенному признаку.
dmitrijaltman8 Дата: Вторник, 31.08.2021, 06:04 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 49
Репутация: 0 ±
Замечаний: 0% ±

2016
Здравствуйте.
Помогите с формулой.

Есть два диапазона с текстом (D4:E1000).
Нужно извлечь в один столбец все слова, которые идут между ключевым словом и запятой ","
Ключевое слово записано в ячейке N3
Показал как должен выглядеть результат - в столбце AR
К сообщению приложен файл: 121124.xlsx(19.4 Kb)
 
Ответить
СообщениеЗдравствуйте.
Помогите с формулой.

Есть два диапазона с текстом (D4:E1000).
Нужно извлечь в один столбец все слова, которые идут между ключевым словом и запятой ","
Ключевое слово записано в ячейке N3
Показал как должен выглядеть результат - в столбце AR

Автор - dmitrijaltman8
Дата добавления - 31.08.2021 в 06:04
krai Дата: Вторник, 31.08.2021, 15:57 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Приветствую!
Сильно тапками не кидайтесь, только учусь, у более опытных решение будет более красивое
Через формулу не знаю как от слова вообще, а регулярки (по другом я пока не знаю как делать) я только сегодня начал учить :)

Ответ пишет в столбец рядом с твоим примером что должно было получиться.
К сообщению приложен файл: 121124.xlsm(32.8 Kb)


Сообщение отредактировал krai - Вторник, 31.08.2021, 15:58
 
Ответить
СообщениеПриветствую!
Сильно тапками не кидайтесь, только учусь, у более опытных решение будет более красивое
Через формулу не знаю как от слова вообще, а регулярки (по другом я пока не знаю как делать) я только сегодня начал учить :)

Ответ пишет в столбец рядом с твоим примером что должно было получиться.

Автор - krai
Дата добавления - 31.08.2021 в 15:57
Светлый Дата: Вторник, 31.08.2021, 19:26 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1685
Репутация: 450 ±
Замечаний: 0% ±

Excel 2013, 2016
Наскоро, массивная:
Код
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(ПСТР(ИНДЕКС(D$1:D$330&E$1:E$330;НАИМЕНЬШИЙ(ЕСЛИ(ПСТР(D$4:D$330&E$4:E$330;СТОЛБЕЦ(A:ALK);ДЛСТР(N$3)+1)=N$3&".";СТРОКА($4:$330)*1000+СТОЛБЕЦ(A:ALK));СТРОКА(A1))/1000);ПРАВБ(НАИМЕНЬШИЙ(ЕСЛИ(ПСТР(D$4:D$330&E$4:E$330;СТОЛБЕЦ(A:ALK);ДЛСТР(N$3)+1)=N$3&".";СТРОКА($4:$330)*1000+СТОЛБЕЦ(A:ALK));СТРОКА(A1));3);999);",";ПОВТОР(" ";99));99));"")


Программировать проще, чем писать стихи.
 
Ответить
СообщениеНаскоро, массивная:
Код
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(ПСТР(ИНДЕКС(D$1:D$330&E$1:E$330;НАИМЕНЬШИЙ(ЕСЛИ(ПСТР(D$4:D$330&E$4:E$330;СТОЛБЕЦ(A:ALK);ДЛСТР(N$3)+1)=N$3&".";СТРОКА($4:$330)*1000+СТОЛБЕЦ(A:ALK));СТРОКА(A1))/1000);ПРАВБ(НАИМЕНЬШИЙ(ЕСЛИ(ПСТР(D$4:D$330&E$4:E$330;СТОЛБЕЦ(A:ALK);ДЛСТР(N$3)+1)=N$3&".";СТРОКА($4:$330)*1000+СТОЛБЕЦ(A:ALK));СТРОКА(A1));3);999);",";ПОВТОР(" ";99));99));"")

Автор - Светлый
Дата добавления - 31.08.2021 в 19:26
dmitrijaltman8 Дата: Вторник, 31.08.2021, 21:29 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 49
Репутация: 0 ±
Замечаний: 0% ±

2016
Светлый, спасибо. Формула работает.
Можно сделать так, чтобы игнорировались числа с правой стороны (чтобы числа по правую сторону - в результатах) - не отображались ?
 
Ответить
СообщениеСветлый, спасибо. Формула работает.
Можно сделать так, чтобы игнорировались числа с правой стороны (чтобы числа по правую сторону - в результатах) - не отображались ?

Автор - dmitrijaltman8
Дата добавления - 31.08.2021 в 21:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Извлечение текста из диапазона по определенному признаку. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!