Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула подтягивания данных с двумя показателями - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула подтягивания данных с двумя показателями (Формулы/Formulas)
Формула подтягивания данных с двумя показателями
lenacia Дата: Пятница, 03.09.2021, 14:26 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 117
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день
Подскажете, пожалуйста формулу что бы данные подтягивались учитывая два показателя - арт и признак. Мне самой не думаться.
В примере в левой части таблица "Данные по стоимости" в ячейку D мне нужно подтянуть стоимость из таблице справа "Прайс", но чтобы учитывались не только арт, но и признак
К сообщению приложен файл: 1294285.xls(27.5 Kb)
 
Ответить
СообщениеДобрый день
Подскажете, пожалуйста формулу что бы данные подтягивались учитывая два показателя - арт и признак. Мне самой не думаться.
В примере в левой части таблица "Данные по стоимости" в ячейку D мне нужно подтянуть стоимость из таблице справа "Прайс", но чтобы учитывались не только арт, но и признак

Автор - lenacia
Дата добавления - 03.09.2021 в 14:26
Serge_007 Дата: Пятница, 03.09.2021, 14:50 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14486
Репутация: 2390 ±
Замечаний: ±

Excel 2010
Здравствуйте

У Вас в таблице "Прайс" есть разные цены для одной и той же пары Признак-Арт:
ОС 20005103 7,00
ОС 20005103 15,00

Что выбирать в таком случае?


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

У Вас в таблице "Прайс" есть разные цены для одной и той же пары Признак-Арт:
ОС 20005103 7,00
ОС 20005103 15,00

Что выбирать в таком случае?

Автор - Serge_007
Дата добавления - 03.09.2021 в 14:50
lenacia Дата: Пятница, 03.09.2021, 15:01 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 117
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Serge_007,
Простите, это моё упущение
я таблицу с примером поправила
К сообщению приложен файл: 4236318.xls(27.5 Kb)
 
Ответить
СообщениеSerge_007,
Простите, это моё упущение
я таблицу с примером поправила

Автор - lenacia
Дата добавления - 03.09.2021 в 15:01
Serge_007 Дата: Пятница, 03.09.2021, 15:05 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14486
Репутация: 2390 ±
Замечаний: ±

Excel 2010
Код
=СУММЕСЛИМН(J$3:J$14;I$3:I$14;B3;H$3:H$14;A3)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Код
=СУММЕСЛИМН(J$3:J$14;I$3:I$14;B3;H$3:H$14;A3)

Автор - Serge_007
Дата добавления - 03.09.2021 в 15:05
Egyptian Дата: Пятница, 03.09.2021, 15:13 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 166
Репутация: 54 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=INDEX($J$3:$J$14;MATCH(A3&B3;INDEX($H$3:$H$14&$I$3:$I$14;);))
 
Ответить
Сообщение
Код
=INDEX($J$3:$J$14;MATCH(A3&B3;INDEX($H$3:$H$14&$I$3:$I$14;);))

Автор - Egyptian
Дата добавления - 03.09.2021 в 15:13
lenacia Дата: Пятница, 03.09.2021, 16:26 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 117
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Serge_007,
спасибо! сейчас буду пробовать
 
Ответить
СообщениеSerge_007,
спасибо! сейчас буду пробовать

Автор - lenacia
Дата добавления - 03.09.2021 в 16:26
lenacia Дата: Пятница, 03.09.2021, 16:27 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 117
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Egyptian,
Спасибо!
 
Ответить
СообщениеEgyptian,
Спасибо!

Автор - lenacia
Дата добавления - 03.09.2021 в 16:27
lenacia Дата: Понедельник, 06.09.2021, 09:46 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 117
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Serge_007,
Добрый день
Вы не подскажите, как будет писаться формула
если в таблице справа Данные по стоимости есть арт, которого нет в Прайсе, мне нужно что бы появлялось слово нет
К сообщению приложен файл: 9706059.xls(28.5 Kb)
 
Ответить
СообщениеSerge_007,
Добрый день
Вы не подскажите, как будет писаться формула
если в таблице справа Данные по стоимости есть арт, которого нет в Прайсе, мне нужно что бы появлялось слово нет

Автор - lenacia
Дата добавления - 06.09.2021 в 09:46
китин Дата: Понедельник, 06.09.2021, 10:03 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 6538
Репутация: 997 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Код
=ЕСЛИОШИБКА(ИНДЕКС($J$3:$J$14;ПОИСКПОЗ(A3&B3;ИНДЕКС($H$3:$H$14&$I$3:$I$14;);));"Нет")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 9706059.xlsx(12.8 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ИНДЕКС($J$3:$J$14;ПОИСКПОЗ(A3&B3;ИНДЕКС($H$3:$H$14&$I$3:$I$14;);));"Нет")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - китин
Дата добавления - 06.09.2021 в 10:03
Egyptian Дата: Понедельник, 06.09.2021, 10:15 | Сообщение № 10
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 166
Репутация: 54 ±
Замечаний: 0% ±

Excel 2013/2016
Вводится одновременным нажатием Ctrl+Shift+Enter

Можно и без массивного ввода. :)
 
Ответить
Сообщение
Вводится одновременным нажатием Ctrl+Shift+Enter

Можно и без массивного ввода. :)

Автор - Egyptian
Дата добавления - 06.09.2021 в 10:15
Serge_007 Дата: Понедельник, 06.09.2021, 10:16 | Сообщение № 11
Группа: Админы
Ранг: Местный житель
Сообщений: 14486
Репутация: 2390 ±
Замечаний: ±

Excel 2010
нужно что бы появлялось слово нет
Ещё вариант см. в файле:
Код
=СУММЕСЛИМН(J3:J13;I3:I13;B3;H3:H13;A3)+-ЕОШИБКА(ПОИСКПОЗ(B3;I$3:I$13;))
К сообщению приложен файл: 20210906_lenaci.xls(68.0 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
нужно что бы появлялось слово нет
Ещё вариант см. в файле:
Код
=СУММЕСЛИМН(J3:J13;I3:I13;B3;H3:H13;A3)+-ЕОШИБКА(ПОИСКПОЗ(B3;I$3:I$13;))

Автор - Serge_007
Дата добавления - 06.09.2021 в 10:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула подтягивания данных с двумя показателями (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!