Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Надо соединить две таблицы по двум столбцам - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Надо соединить две таблицы по двум столбцам
Надо соединить две таблицы по двум столбцам
Lu9999 Дата: Понедельник, 20.05.2013, 21:09 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Помогите, пожалуйста, с еще одной задачей. Надо соединить две таблицы, добавив из одной таблицы столбец во вторую по совпадающим значениям в двух других столбцах одновременно, оставив только пересечение. На примере: два маленьких файла. Из файла1 в файл2 нужно перетащить столбец "индекс" по совпадающим значениям "год" и "код"
К сообщению приложен файл: 3234792.xlsx(9.1 Kb) · 4705698.xlsx(9.9 Kb)
 
Ответить
СообщениеПомогите, пожалуйста, с еще одной задачей. Надо соединить две таблицы, добавив из одной таблицы столбец во вторую по совпадающим значениям в двух других столбцах одновременно, оставив только пересечение. На примере: два маленьких файла. Из файла1 в файл2 нужно перетащить столбец "индекс" по совпадающим значениям "год" и "код"

Автор - Lu9999
Дата добавления - 20.05.2013 в 21:09
Serge_007 Дата: Понедельник, 20.05.2013, 21:22 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15405
Репутация: 2536 ±
Замечаний: ±

Excel 2016
Про формулы массива Вы уже в курсе:
Код
=ИНДЕКС([файл1.xls]Лист1!C$2:C$39;ПОИСКПОЗ(A2&B2;[файл1.xls]Лист1!A$2:A$39&[файл1.xls]Лист1!B$2:B$39;))
К сообщению приложен файл: Lu9999.rar(10.3 Kb)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеПро формулы массива Вы уже в курсе:
Код
=ИНДЕКС([файл1.xls]Лист1!C$2:C$39;ПОИСКПОЗ(A2&B2;[файл1.xls]Лист1!A$2:A$39&[файл1.xls]Лист1!B$2:B$39;))

Автор - Serge_007
Дата добавления - 20.05.2013 в 21:22
Lu9999 Дата: Понедельник, 20.05.2013, 22:14 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Serge_007, спасибо большое!
 
Ответить
СообщениеSerge_007, спасибо большое!

Автор - Lu9999
Дата добавления - 20.05.2013 в 22:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Надо соединить две таблицы по двум столбцам
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!