Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/автоматический подсчет подмножин чет нечет - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » автоматический подсчет подмножин чет нечет (Word)
автоматический подсчет подмножин чет нечет
miroslavpetryk1993 Дата: Пятница, 10.09.2021, 13:31 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Нужнен автоматический подсчет подмножин чет нечет :
1) 111111......
2) 000000.....
3) 101010.....
4) 010101....
 
Ответить
СообщениеНужнен автоматический подсчет подмножин чет нечет :
1) 111111......
2) 000000.....
3) 101010.....
4) 010101....

Автор - miroslavpetryk1993
Дата добавления - 10.09.2021 в 13:31
китин Дата: Пятница, 10.09.2021, 15:18 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6531
Репутация: 997 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
- Прочитайте Правила форума
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 500 кб согласно п.3 Правил форума
без файла на коленке
для Чётных
Код
=СУММ(--ЕЧЁТН(--ПСТР($B3;СТРОКА(ДВССЫЛ("1:"&ДЛСТР($B3)));1)))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

для Нечётных
Код
=ДЛСТР(B3)-СУММ(--ЕЧЁТН(--ПСТР($B3;СТРОКА(ДВССЫЛ("1:"&ДЛСТР($B3)));1)))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
ваше число в ячейке В3


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение- Прочитайте Правила форума
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 500 кб согласно п.3 Правил форума
без файла на коленке
для Чётных
Код
=СУММ(--ЕЧЁТН(--ПСТР($B3;СТРОКА(ДВССЫЛ("1:"&ДЛСТР($B3)));1)))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

для Нечётных
Код
=ДЛСТР(B3)-СУММ(--ЕЧЁТН(--ПСТР($B3;СТРОКА(ДВССЫЛ("1:"&ДЛСТР($B3)));1)))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
ваше число в ячейке В3

Автор - китин
Дата добавления - 10.09.2021 в 15:18
прохожий2019 Дата: Пятница, 10.09.2021, 20:25 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 667
Репутация: 169 ±
Замечаний: 0% ±

365 Beta Channel
на коленке
но зачем так волатильно?
чет
Код
=СУММ(ОСТАТ(ПСТР(B1;СТРОКА($A$1:ИНДЕКС(A:A;ДЛСТР(B1)));1)+1;2))
нечет
Код
=СУММ(ОСТАТ(ПСТР(B2;СТРОКА($A$1:ИНДЕКС(A:A;ДЛСТР(B2)));1);2))

а в современном можно так
Код
=СУММ(ОСТАТ(ПСТР(B1;ПОСЛЕД(ДЛСТР(B1));1)+1;2))
Код
=СУММ(ОСТАТ(ПСТР(B1;ПОСЛЕД(ДЛСТР(B1));1);2))


Сообщение отредактировал прохожий2019 - Суббота, 11.09.2021, 11:24
 
Ответить
Сообщение
на коленке
но зачем так волатильно?
чет
Код
=СУММ(ОСТАТ(ПСТР(B1;СТРОКА($A$1:ИНДЕКС(A:A;ДЛСТР(B1)));1)+1;2))
нечет
Код
=СУММ(ОСТАТ(ПСТР(B2;СТРОКА($A$1:ИНДЕКС(A:A;ДЛСТР(B2)));1);2))

а в современном можно так
Код
=СУММ(ОСТАТ(ПСТР(B1;ПОСЛЕД(ДЛСТР(B1));1)+1;2))
Код
=СУММ(ОСТАТ(ПСТР(B1;ПОСЛЕД(ДЛСТР(B1));1);2))

Автор - прохожий2019
Дата добавления - 10.09.2021 в 20:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » автоматический подсчет подмножин чет нечет (Word)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!