Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/выборка данных с проверкой даты - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » выборка данных с проверкой даты (Формулы/Formulas)
выборка данных с проверкой даты
valsaar Дата: Вторник, 14.09.2021, 10:49 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Коллеги, направьте, пожалуйста, мысль в нужную сторону.
Требуется в одну таблицу подставлять номера актов, содержащиеся в другой справочной таблице, проводя выборку по двум критериям: дата и объект. Все бы ничего, но нужно проверять попадает ли дата в определенный период. И вот тут я не могу найти рабочее решение.
К сообщению приложен файл: 5928941.xlsx(396.8 Kb)
 
Ответить
СообщениеКоллеги, направьте, пожалуйста, мысль в нужную сторону.
Требуется в одну таблицу подставлять номера актов, содержащиеся в другой справочной таблице, проводя выборку по двум критериям: дата и объект. Все бы ничего, но нужно проверять попадает ли дата в определенный период. И вот тут я не могу найти рабочее решение.

Автор - valsaar
Дата добавления - 14.09.2021 в 10:49
Nic70y Дата: Вторник, 14.09.2021, 10:58 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7113
Репутация: 1641 ±
Замечаний: 0% ±

Excel 2010
Код
=ИНДЕКС(Справочник!D$1:D$999;ПОИСКПОЗ(B2;ИНДЕКС(Справочник!C$1:C$999;ПОИСКПОЗ(A2;Справочник!A$1:A$999)):ИНДЕКС(Справочник!C$1:C$999;999);)+ПОИСКПОЗ(A2;Справочник!A$1:A$999)-1)
К сообщению приложен файл: 18.xlsx(397.5 Kb)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
Код
=ИНДЕКС(Справочник!D$1:D$999;ПОИСКПОЗ(B2;ИНДЕКС(Справочник!C$1:C$999;ПОИСКПОЗ(A2;Справочник!A$1:A$999)):ИНДЕКС(Справочник!C$1:C$999;999);)+ПОИСКПОЗ(A2;Справочник!A$1:A$999)-1)

Автор - Nic70y
Дата добавления - 14.09.2021 в 10:58
valsaar Дата: Вторник, 14.09.2021, 11:05 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, благодарю, ИНДЕКС + ПОИСКПОЗ магическая вещь в правильных руках)
 
Ответить
СообщениеNic70y, благодарю, ИНДЕКС + ПОИСКПОЗ магическая вещь в правильных руках)

Автор - valsaar
Дата добавления - 14.09.2021 в 11:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » выборка данных с проверкой даты (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!