Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Скрытие столбцов по условию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Скрытие столбцов по условию (Формулы/Formulas)
Скрытие столбцов по условию
Смольный Дата: Вторник, 28.09.2021, 10:44 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

Добрый день всем, можно ли такое реализовать в эксель? Если в ячейке А1 стоит цифра 1 то столбец С будет скрыт, если цифра 3 то столбец С и D, если 3 то C,D,E скрытие нужно только от 1 до 3 столбцов, после скрытия столбца/столбцов, содержащиеся в них данные и формулы не должны работать. Нумерация столбцов будет статичной.
 
Ответить
СообщениеДобрый день всем, можно ли такое реализовать в эксель? Если в ячейке А1 стоит цифра 1 то столбец С будет скрыт, если цифра 3 то столбец С и D, если 3 то C,D,E скрытие нужно только от 1 до 3 столбцов, после скрытия столбца/столбцов, содержащиеся в них данные и формулы не должны работать. Нумерация столбцов будет статичной.

Автор - Смольный
Дата добавления - 28.09.2021 в 10:44
Serge_007 Дата: Вторник, 28.09.2021, 11:04 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14580
Репутация: 2409 ±
Замечаний: ±

Excel 2010
Здравствуйте

Средствами Excel такое не сделать, но можно написать макрос VBA


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Средствами Excel такое не сделать, но можно написать макрос VBA

Автор - Serge_007
Дата добавления - 28.09.2021 в 11:04
Смольный Дата: Вторник, 28.09.2021, 11:07 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

Serge_007, это платно?
 
Ответить
СообщениеSerge_007, это платно?

Автор - Смольный
Дата добавления - 28.09.2021 в 11:07
китин Дата: Вторник, 28.09.2021, 11:20 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 6547
Репутация: 997 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Смольный, в этом разделе все бесплатно. но при условии соблюдения Правил форума

- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 500 кб


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеСмольный, в этом разделе все бесплатно. но при условии соблюдения Правил форума

- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 500 кб

Автор - китин
Дата добавления - 28.09.2021 в 11:20
Смольный Дата: Вторник, 28.09.2021, 16:19 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

китин, сделал, надеюсь понятно написал.
К сообщению приложен файл: 0163393.xlsx(20.0 Kb)
 
Ответить
Сообщениекитин, сделал, надеюсь понятно написал.

Автор - Смольный
Дата добавления - 28.09.2021 в 16:19
Nic70y Дата: Среда, 29.09.2021, 08:17 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 7117
Репутация: 1641 ±
Замечаний: 0% ±

Excel 2010
Смольный, я так понимаю, что цветом вы выделили для примера, а нужно скрывать числа.
вводим в A1,
в модуль листа
[vba]
Код
Private Sub Worksheet_Change(ByVal Target As Range)
    If Not Intersect(Target, Range("a1")) Is Nothing Then
        Application.ScreenUpdating = False
        u = Target.Value
        For a = 2 To Sheets.Count
            Sheets(a).Columns("ag:ai").EntireColumn.Hidden = False
            If u = 1 Then Sheets(a).Columns("ai").EntireColumn.Hidden = True
            If u = 2 Then Sheets(a).Columns("ah:ai").EntireColumn.Hidden = True
            If u = 3 Then Sheets(a).Columns("ag:ai").EntireColumn.Hidden = True
        Next
        Application.ScreenUpdating = True
    End If
End Sub
[/vba]формулы:
Код
=СУММ(E5:ИНДЕКС(E5:AI5;31-Лист1!$A$1))
Код
=СЧЁТ(E5:ИНДЕКС(E5:AI5;31-Лист1!$A$1))
вдруг правильно
К сообщению приложен файл: 0163393-1-.xlsm(27.4 Kb)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
СообщениеСмольный, я так понимаю, что цветом вы выделили для примера, а нужно скрывать числа.
вводим в A1,
в модуль листа
[vba]
Код
Private Sub Worksheet_Change(ByVal Target As Range)
    If Not Intersect(Target, Range("a1")) Is Nothing Then
        Application.ScreenUpdating = False
        u = Target.Value
        For a = 2 To Sheets.Count
            Sheets(a).Columns("ag:ai").EntireColumn.Hidden = False
            If u = 1 Then Sheets(a).Columns("ai").EntireColumn.Hidden = True
            If u = 2 Then Sheets(a).Columns("ah:ai").EntireColumn.Hidden = True
            If u = 3 Then Sheets(a).Columns("ag:ai").EntireColumn.Hidden = True
        Next
        Application.ScreenUpdating = True
    End If
End Sub
[/vba]формулы:
Код
=СУММ(E5:ИНДЕКС(E5:AI5;31-Лист1!$A$1))
Код
=СЧЁТ(E5:ИНДЕКС(E5:AI5;31-Лист1!$A$1))
вдруг правильно

Автор - Nic70y
Дата добавления - 29.09.2021 в 08:17
Смольный Дата: Среда, 29.09.2021, 10:09 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

Nic70y, проверил на вашем файле, супер, как и нужно было.


Сообщение отредактировал Смольный - Среда, 29.09.2021, 10:12
 
Ответить
СообщениеNic70y, проверил на вашем файле, супер, как и нужно было.

Автор - Смольный
Дата добавления - 29.09.2021 в 10:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Скрытие столбцов по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!