Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма чисел внтури скобок и без них - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма чисел внтури скобок и без них (Формулы/Formulas)
Сумма чисел внтури скобок и без них
Molochkomoe Дата: Вторник, 28.09.2021, 16:29 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Всем доброго времени суток! Нужна помощь для подсчета суммы чисел формата: число (число). То есть должна просчитаться сумма чисел внутри скобок и до скобок. По прикрепленному примеру должен получиться итог: 49(7). Заранее спасибо большое за помощь!
К сообщению приложен файл: 2552250.xlsm(9.1 Kb)
 
Ответить
СообщениеВсем доброго времени суток! Нужна помощь для подсчета суммы чисел формата: число (число). То есть должна просчитаться сумма чисел внутри скобок и до скобок. По прикрепленному примеру должен получиться итог: 49(7). Заранее спасибо большое за помощь!

Автор - Molochkomoe
Дата добавления - 28.09.2021 в 16:29
Serge_007 Дата: Вторник, 28.09.2021, 16:36 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14555
Репутация: 2403 ±
Замечаний: ±

Excel 2010
Здравствуйте

Код
=СУММПРОИЗВ(--ЛЕВБ(A1:A3;ПОИСК(" ";A1:A3)-1))&" ("&СУММПРОИЗВ(--ПСТР(A1:A3;ПОИСК("(";A1:A3)+1;НАЙТИ(")";A1:A3)-ПОИСК("(";A1:A3)-1))&")"


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Код
=СУММПРОИЗВ(--ЛЕВБ(A1:A3;ПОИСК(" ";A1:A3)-1))&" ("&СУММПРОИЗВ(--ПСТР(A1:A3;ПОИСК("(";A1:A3)+1;НАЙТИ(")";A1:A3)-ПОИСК("(";A1:A3)-1))&")"

Автор - Serge_007
Дата добавления - 28.09.2021 в 16:36
Nic70y Дата: Вторник, 28.09.2021, 16:38 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 7113
Репутация: 1641 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММПРОИЗВ(--ЛЕВБ(A1:A3;ПОИСК("(";A1:A3)-1))&" ("&СУММПРОИЗВ(-ПСТР(A1:A3;ПОИСК("(";A1:A3);15))&")"


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(--ЛЕВБ(A1:A3;ПОИСК("(";A1:A3)-1))&" ("&СУММПРОИЗВ(-ПСТР(A1:A3;ПОИСК("(";A1:A3);15))&")"

Автор - Nic70y
Дата добавления - 28.09.2021 в 16:38
Светлый Дата: Вторник, 28.09.2021, 21:45 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1708
Репутация: 457 ±
Замечаний: 0% ±

Excel 2013, 2016
И я свои пять копеек вставлю:
Код
=СУММПРОИЗВ(--ЛЕВБ(A1:A3;ПОИСК(" ";A1:A3)))&" ("&СУММПРОИЗВ(-ПСТР(A1:A3;ПОИСК("(";A1:A3);9))&")"
и с очень большими ограничениями:
Код
=ПОДСТАВИТЬ(СУММПРОИЗВ(-("("&ПОДСТАВИТЬ(A1:A3;" (";",")));",";" (")&")"


Программировать проще, чем писать стихи.
 
Ответить
СообщениеИ я свои пять копеек вставлю:
Код
=СУММПРОИЗВ(--ЛЕВБ(A1:A3;ПОИСК(" ";A1:A3)))&" ("&СУММПРОИЗВ(-ПСТР(A1:A3;ПОИСК("(";A1:A3);9))&")"
и с очень большими ограничениями:
Код
=ПОДСТАВИТЬ(СУММПРОИЗВ(-("("&ПОДСТАВИТЬ(A1:A3;" (";",")));",";" (")&")"

Автор - Светлый
Дата добавления - 28.09.2021 в 21:45
Egyptian Дата: Вторник, 28.09.2021, 22:16 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 183
Репутация: 58 ±
Замечаний: 0% ±

Excel 2013/2016
И еще вариант. Массивный
Код
=SUM(IFERROR(0+LEFTB(SUBSTITUTE(A1:A50;" ";REPT(" ";LEN(A1)));SEARCH(" ";A1:A50)-1);))&" ("&SUM(IFERROR(MID(SUBSTITUTE(SUBSTITUTE(A1:A50;"(";" ");")";" ");SEARCH(" ";A1:A50)+1;LEN(A1))+0;))&")"

или так:
Код
=SUM(IFERROR(0+LEFTB(A1:A50;SEARCH(" ";A1:A50));))&CHAR(32)&TEXT(SUM(0+IFERROR(TRIM(MID(SUBSTITUTE(A1:A50;")";" ");SEARCH("(";A1:A50)+1;LEN(A1)));));"(#)")


Сообщение отредактировал Egyptian - Вторник, 28.09.2021, 23:04
 
Ответить
СообщениеИ еще вариант. Массивный
Код
=SUM(IFERROR(0+LEFTB(SUBSTITUTE(A1:A50;" ";REPT(" ";LEN(A1)));SEARCH(" ";A1:A50)-1);))&" ("&SUM(IFERROR(MID(SUBSTITUTE(SUBSTITUTE(A1:A50;"(";" ");")";" ");SEARCH(" ";A1:A50)+1;LEN(A1))+0;))&")"

или так:
Код
=SUM(IFERROR(0+LEFTB(A1:A50;SEARCH(" ";A1:A50));))&CHAR(32)&TEXT(SUM(0+IFERROR(TRIM(MID(SUBSTITUTE(A1:A50;")";" ");SEARCH("(";A1:A50)+1;LEN(A1)));));"(#)")

Автор - Egyptian
Дата добавления - 28.09.2021 в 22:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма чисел внтури скобок и без них (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!