Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Объединение ячеек в столбце с учетом пустых строк - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Объединение ячеек в столбце с учетом пустых строк (Формулы/Formulas)
Объединение ячеек в столбце с учетом пустых строк
pashatank Дата: Среда, 29.09.2021, 06:33 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 58
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
Приветствую форумчане!
Помогите с макросом на подобии функции "объединить", суть следующая, в одном столбце есть ячейки с данными, после которых есть пустые строки, пример:

Иван
Иванов

Иван
Иванович
Иванов

Иван
Иванов

ели бы кол-во ячеек совпадало, подошла бы и обычная функция "сцепить", растянул бы ее в соседнем столбце и все, но заполненные ячейки не совпадают по кол-ву строк, где-то их две, где-то три, в 2016м офисе были удобные функции объединить и сцеп, но теперь они доступны только по подписке в 365м офисе, помогите, может макросом можно будет объединить эти ячейки в одну, с учетом пустых строк, пример прицепил.
К сообщению приложен файл: new-text-logica.xlsx(10.3 Kb)


Сообщение отредактировал pashatank - Среда, 29.09.2021, 06:35
 
Ответить
СообщениеПриветствую форумчане!
Помогите с макросом на подобии функции "объединить", суть следующая, в одном столбце есть ячейки с данными, после которых есть пустые строки, пример:

Иван
Иванов

Иван
Иванович
Иванов

Иван
Иванов

ели бы кол-во ячеек совпадало, подошла бы и обычная функция "сцепить", растянул бы ее в соседнем столбце и все, но заполненные ячейки не совпадают по кол-ву строк, где-то их две, где-то три, в 2016м офисе были удобные функции объединить и сцеп, но теперь они доступны только по подписке в 365м офисе, помогите, может макросом можно будет объединить эти ячейки в одну, с учетом пустых строк, пример прицепил.

Автор - pashatank
Дата добавления - 29.09.2021 в 06:33
Nic70y Дата: Среда, 29.09.2021, 08:35 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7113
Репутация: 1641 ±
Замечаний: 0% ±

Excel 2010
вариант формулой, с условием пустой строки 1
Код
=ЕСЛИ(И(A1="";A2<>"");СЖПРОБЕЛЫ(A2&" "&A3&" "&A4);"")
К сообщению приложен файл: 18.xlsx(10.5 Kb)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщениевариант формулой, с условием пустой строки 1
Код
=ЕСЛИ(И(A1="";A2<>"");СЖПРОБЕЛЫ(A2&" "&A3&" "&A4);"")

Автор - Nic70y
Дата добавления - 29.09.2021 в 08:35
pashatank Дата: Среда, 29.09.2021, 08:52 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 58
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
Nic70y, превосходно! то, что нужно, огромное, человеческое спасибо!
 
Ответить
СообщениеNic70y, превосходно! то, что нужно, огромное, человеческое спасибо!

Автор - pashatank
Дата добавления - 29.09.2021 в 08:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Объединение ячеек в столбце с учетом пустых строк (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!