Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Запрос на выборку последней даты по двум критериям - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Запрос на выборку последней даты по двум критериям (Формулы/Formulas)
Запрос на выборку последней даты по двум критериям
sashhv Дата: Понедельник, 04.10.2021, 11:39 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!

Прошу подсказать формулу, которая будет выбирать из массива дат самую последнюю по заданным (2-м) критериям поиска.

Спасибо.
К сообщению приложен файл: 1116473.xlsx(9.1 Kb)
 
Ответить
СообщениеДобрый день!

Прошу подсказать формулу, которая будет выбирать из массива дат самую последнюю по заданным (2-м) критериям поиска.

Спасибо.

Автор - sashhv
Дата добавления - 04.10.2021 в 11:39
китин Дата: Понедельник, 04.10.2021, 12:20 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6611
Репутация: 1004 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
чисто по файлу
Код
=ИНДЕКС($B$4:$B$28;МАКС(ЕСЛИ(($D$4:$D$28=$I4)*($C$4:$C$28=$G4);СТРОКА($C$4:$C$28)-3)))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениечисто по файлу
Код
=ИНДЕКС($B$4:$B$28;МАКС(ЕСЛИ(($D$4:$D$28=$I4)*($C$4:$C$28=$G4);СТРОКА($C$4:$C$28)-3)))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - китин
Дата добавления - 04.10.2021 в 12:20
sashhv Дата: Среда, 06.10.2021, 08:31 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
китин, Добрый день!

Поясните, пожалуйста, часть формулы с функцией "Строка" почему там стоит 3?

Спасибо.


Сообщение отредактировал sashhv - Среда, 06.10.2021, 08:32
 
Ответить
Сообщениекитин, Добрый день!

Поясните, пожалуйста, часть формулы с функцией "Строка" почему там стоит 3?

Спасибо.

Автор - sashhv
Дата добавления - 06.10.2021 в 08:31
китин Дата: Среда, 06.10.2021, 08:54 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 6611
Репутация: 1004 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Код
СТРОКА($C$4:$C$28)-3

дает нам массив последовательных чисел от 1: {1:2:3:4:5:6:7:8:9:10:11:12:13:14:15:16:17:18:19:20:21:22:23:24:25}


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Код
СТРОКА($C$4:$C$28)-3

дает нам массив последовательных чисел от 1: {1:2:3:4:5:6:7:8:9:10:11:12:13:14:15:16:17:18:19:20:21:22:23:24:25}

Автор - китин
Дата добавления - 06.10.2021 в 08:54
Serge_007 Дата: Среда, 06.10.2021, 09:19 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 14697
Репутация: 2432 ±
Замечаний: ±

Excel 2010
часть формулы с функцией "Строка" почему там стоит 3?
дает нам массив последовательных чисел
Код
=СТРОКА($C$4:$C$28)-3
эквивалентно
Код
=СТРОКА($1:$25)

К сообщению приложен файл: 2457495.png(19.7 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
часть формулы с функцией "Строка" почему там стоит 3?
дает нам массив последовательных чисел
Код
=СТРОКА($C$4:$C$28)-3
эквивалентно
Код
=СТРОКА($1:$25)


Автор - Serge_007
Дата добавления - 06.10.2021 в 09:19
jakim Дата: Среда, 06.10.2021, 11:42 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1052
Репутация: 280 ±
Замечаний: 0% ±

Excel 2010
Формула без массивного ввода

Код
=AGGREGATE(14;6;B$4:B$30/(C$4:C$30=G4)/(D$4:D$30=I4);1)
 
Ответить
Сообщение
Формула без массивного ввода

Код
=AGGREGATE(14;6;B$4:B$30/(C$4:C$30=G4)/(D$4:D$30=I4);1)

Автор - jakim
Дата добавления - 06.10.2021 в 11:42
Serge_007 Дата: Среда, 06.10.2021, 11:53 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 14697
Репутация: 2432 ±
Замечаний: ±

Excel 2010
Тоже без массивного ввода:
Код
=ИНДЕКС(B$4:B$28;СУММПРОИЗВ(МАКС((C$4:C$28=G4)*(I4=D$4:D$28)*СТРОКА($1:$25))))


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеТоже без массивного ввода:
Код
=ИНДЕКС(B$4:B$28;СУММПРОИЗВ(МАКС((C$4:C$28=G4)*(I4=D$4:D$28)*СТРОКА($1:$25))))

Автор - Serge_007
Дата добавления - 06.10.2021 в 11:53
Nic70y Дата: Среда, 06.10.2021, 12:01 | Сообщение № 8
Группа: Друзья
Ранг: Экселист
Сообщений: 7158
Репутация: 1652 ±
Замечаний: 0% ±

Excel 2010
Тоже
Код
=СУММПРОИЗВ(МАКС((C$4:C$28=G4)*(D$4:D$28=I4)*B$4:B$28))
и причем правильно :)
т.к. последняя дата - это не в нижней* ячейке, а максимальная


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Среда, 06.10.2021, 12:04
 
Ответить
Сообщение
Тоже
Код
=СУММПРОИЗВ(МАКС((C$4:C$28=G4)*(D$4:D$28=I4)*B$4:B$28))
и причем правильно :)
т.к. последняя дата - это не в нижней* ячейке, а максимальная

Автор - Nic70y
Дата добавления - 06.10.2021 в 12:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Запрос на выборку последней даты по двум критериям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!