Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Учет високосного года при расчете платы за разные периоды - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Учет високосного года при расчете платы за разные периоды (Формулы/Formulas)
Учет високосного года при расчете платы за разные периоды
mrjons Дата: Понедельник, 11.10.2021, 15:02 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день
Необходимо определить арендную плату за каждый из трех периодов (ячейки выделены желтым цветом, можно сюда вбивать формулы). В качестве известной величины выступает годовая арендная плата, т.е. руб. в год.
Мной определено количество оставшихся дней за 1 и 3 периоды и количество лет за 2 период.
Арендную плату за 2 период просто получаю путем умножения годовой арендной платы на число лет.
Арендную плату за 1 и 3 периоды рассчитываю путем произведения оставшихся дней на отношение годовой арендной платы к количеству дней в году, 2056 год будет високосным поэтому делю на 366 дней. Хотя здесь по идее нужна формула, которая будет автоматически определять является ли этот год високосным или нет и в зависимости от этого менять количество дней в году (365 или 366). Как эта формула будет выглядеть?
А так как получается, что базовой величиной будет арендная плата за 1 день, то в периоде 2 нужна формула, которая будет учитывать високосные года в этом промежутке.
Заранее благодарю
К сообщению приложен файл: _Microsoft_Exce.xlsx(10.6 Kb)
 
Ответить
СообщениеДобрый день
Необходимо определить арендную плату за каждый из трех периодов (ячейки выделены желтым цветом, можно сюда вбивать формулы). В качестве известной величины выступает годовая арендная плата, т.е. руб. в год.
Мной определено количество оставшихся дней за 1 и 3 периоды и количество лет за 2 период.
Арендную плату за 2 период просто получаю путем умножения годовой арендной платы на число лет.
Арендную плату за 1 и 3 периоды рассчитываю путем произведения оставшихся дней на отношение годовой арендной платы к количеству дней в году, 2056 год будет високосным поэтому делю на 366 дней. Хотя здесь по идее нужна формула, которая будет автоматически определять является ли этот год високосным или нет и в зависимости от этого менять количество дней в году (365 или 366). Как эта формула будет выглядеть?
А так как получается, что базовой величиной будет арендная плата за 1 день, то в периоде 2 нужна формула, которая будет учитывать високосные года в этом промежутке.
Заранее благодарю

Автор - mrjons
Дата добавления - 11.10.2021 в 15:02
Pelena Дата: Понедельник, 11.10.2021, 17:49 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18117
Репутация: 4059 ±
Замечаний: ±

Excel 2016 & Mac Excel
Как вариант (в В2 дата)
Код
=ЕСЛИ(МЕСЯЦ(ДАТА(ГОД(B2);2;28)+1)=2;366;365)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеКак вариант (в В2 дата)
Код
=ЕСЛИ(МЕСЯЦ(ДАТА(ГОД(B2);2;28)+1)=2;366;365)

Автор - Pelena
Дата добавления - 11.10.2021 в 17:49
mrjons Дата: Вторник, 12.10.2021, 16:45 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Pelena, спасибо, все работает
 
Ответить
СообщениеPelena, спасибо, все работает

Автор - mrjons
Дата добавления - 12.10.2021 в 16:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Учет високосного года при расчете платы за разные периоды (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!