Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула значения "Если" - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула значения "Если" (Функции/Function)
Формула значения "Если"
Aleksander777 Дата: Вторник, 12.10.2021, 15:32 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 56
Репутация: 10 ±
Замечаний: 40% ±

Excel 2016
В файле Пример (который прикрепил) есть ячейка "В7" - нужно чтобы Если число было больше нуля, значит значение было "0", если меньше нуля, значит отображалось правильное значение.
Заранее спасибо)
К сообщению приложен файл: 6415120.xlsx(10.8 Kb)
 
Ответить
СообщениеВ файле Пример (который прикрепил) есть ячейка "В7" - нужно чтобы Если число было больше нуля, значит значение было "0", если меньше нуля, значит отображалось правильное значение.
Заранее спасибо)

Автор - Aleksander777
Дата добавления - 12.10.2021 в 15:32
Serge_007 Дата: Вторник, 12.10.2021, 16:40 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14555
Репутация: 2403 ±
Замечаний: ±

Excel 2010
Во первых непонятно что такое "правильное" значение, во вторых зачем Вам для решения этой задачи VBA?


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеВо первых непонятно что такое "правильное" значение, во вторых зачем Вам для решения этой задачи VBA?

Автор - Serge_007
Дата добавления - 12.10.2021 в 16:40
Aleksander777 Дата: Вторник, 12.10.2021, 18:29 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 56
Репутация: 10 ±
Замечаний: 40% ±

Excel 2016
во вторых зачем Вам для решения этой задачи VBA?

да, наверно тему перепутал VBA не нужен

"правильное" значение

В общем нужна формула при которой значение "+" было заменено на "0", значение с "-" остается и не заменяется.
 
Ответить
Сообщение
во вторых зачем Вам для решения этой задачи VBA?

да, наверно тему перепутал VBA не нужен

"правильное" значение

В общем нужна формула при которой значение "+" было заменено на "0", значение с "-" остается и не заменяется.

Автор - Aleksander777
Дата добавления - 12.10.2021 в 18:29
Pelena Дата: Вторник, 12.10.2021, 18:35 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 17943
Репутация: 3997 ±
Замечаний: ±

Excel 2016 & Mac Excel
Цитата Aleksander777, 12.10.2021 в 18:29, в сообщении № 3 ()
значение "+" было заменено на "0", значение с "-" остается и не заменяется

Код
=МИН((B3-B2)*0,15;0)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Цитата Aleksander777, 12.10.2021 в 18:29, в сообщении № 3 ()
значение "+" было заменено на "0", значение с "-" остается и не заменяется

Код
=МИН((B3-B2)*0,15;0)

Автор - Pelena
Дата добавления - 12.10.2021 в 18:35
Aleksander777 Дата: Среда, 13.10.2021, 12:35 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 56
Репутация: 10 ±
Замечаний: 40% ±

Excel 2016
=МИН((B3-B2)*0,15;0)

немного не правильно я сказал.
Нужно чтобы в ячейке (B7) отображалось число, при условии если в ячейке (B6) стоит число с "-" значением, если число в ячейке (B6) стоит "0" или "+", значит в ячейке (B7) должен быть "0"


Сообщение отредактировал Aleksander777 - Среда, 13.10.2021, 12:37
 
Ответить
Сообщение
=МИН((B3-B2)*0,15;0)

немного не правильно я сказал.
Нужно чтобы в ячейке (B7) отображалось число, при условии если в ячейке (B6) стоит число с "-" значением, если число в ячейке (B6) стоит "0" или "+", значит в ячейке (B7) должен быть "0"

Автор - Aleksander777
Дата добавления - 13.10.2021 в 12:35
Pelena Дата: Среда, 13.10.2021, 14:14 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 17943
Репутация: 3997 ±
Замечаний: ±

Excel 2016 & Mac Excel
Замените в формуле (B3-B2)*0,15 на B6


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗамените в формуле (B3-B2)*0,15 на B6

Автор - Pelena
Дата добавления - 13.10.2021 в 14:14
amfor Дата: Среда, 13.10.2021, 14:20 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 221
Репутация: 65 ±
Замечаний: 0% ±

Excel 2016
Как понял.
Код
=ЕСЛИ(B6<0;(B3-B2)*0,15;0)
К сообщению приложен файл: 6491274.xlsx(10.9 Kb)


Семь бед - один RESET.
 
Ответить
СообщениеКак понял.
Код
=ЕСЛИ(B6<0;(B3-B2)*0,15;0)

Автор - amfor
Дата добавления - 13.10.2021 в 14:20
Светлый Дата: Среда, 13.10.2021, 16:08 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1708
Репутация: 457 ±
Замечаний: 0% ±

Excel 2013, 2016
Код
=(B3-B2)*0,15*(B6<0)
Код
=(B3-B2)*15%*(B6<0)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Среда, 13.10.2021, 16:10
 
Ответить
Сообщение
Код
=(B3-B2)*0,15*(B6<0)
Код
=(B3-B2)*15%*(B6<0)

Автор - Светлый
Дата добавления - 13.10.2021 в 16:08
Aleksander777 Дата: Среда, 13.10.2021, 16:40 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 56
Репутация: 10 ±
Замечаний: 40% ±

Excel 2016
Код
=ЕСЛИ(B6<0;(B3-B2)*0,15;0)

Этот Вариант правильный, всем спасибо))))


Сообщение отредактировал Serge_007 - Среда, 13.10.2021, 17:47
 
Ответить
Сообщение
Код
=ЕСЛИ(B6<0;(B3-B2)*0,15;0)

Этот Вариант правильный, всем спасибо))))

Автор - Aleksander777
Дата добавления - 13.10.2021 в 16:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула значения "Если" (Функции/Function)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!