Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/создание несколько копий из столбца списком - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » создание несколько копий из столбца списком (Формулы/Formulas)
создание несколько копий из столбца списком
runa09 Дата: Пятница, 15.10.2021, 14:47 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Добрый день, друзья!
Спасибо, что есть такой сайт!
Подскажите, пожалуйста, как реализовать такую функцию

есть длинный список в столбце А вида:
1
2
3
4

нужно получить список в столбце B вида
1
1
1
1
2
2
2
2
3
3
3
3
4
4
4
4

то есть сделать по 4 копии одинаковых из каждой ячейки.

спасибо за помощь )


Сообщение отредактировал runa09 - Пятница, 15.10.2021, 14:49
 
Ответить
СообщениеДобрый день, друзья!
Спасибо, что есть такой сайт!
Подскажите, пожалуйста, как реализовать такую функцию

есть длинный список в столбце А вида:
1
2
3
4

нужно получить список в столбце B вида
1
1
1
1
2
2
2
2
3
3
3
3
4
4
4
4

то есть сделать по 4 копии одинаковых из каждой ячейки.

спасибо за помощь )

Автор - runa09
Дата добавления - 15.10.2021 в 14:47
Nic70y Дата: Пятница, 15.10.2021, 14:51 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7158
Репутация: 1652 ±
Замечаний: 0% ±

Excel 2010
Код
=ИНДЕКС(A:A;ОКРУГЛВВЕРХ(СТРОКА(A1)/4;))


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ИНДЕКС(A:A;ОКРУГЛВВЕРХ(СТРОКА(A1)/4;))

Автор - Nic70y
Дата добавления - 15.10.2021 в 14:51
Serge_007 Дата: Пятница, 15.10.2021, 14:52 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 14697
Репутация: 2432 ±
Замечаний: ±

Excel 2010
Здравствуйте

Код
=ИНДЕКС(A$1:A$4;ЦЕЛОЕ(СТРОКА()/4,1+1))
Код
=ИНДЕКС(A:A;ОКРВВЕРХ(СТРОКА(A1)/4;1))


Спасибо, что есть такой сайт!
Спасибо Вам за отзыв!


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Код
=ИНДЕКС(A$1:A$4;ЦЕЛОЕ(СТРОКА()/4,1+1))
Код
=ИНДЕКС(A:A;ОКРВВЕРХ(СТРОКА(A1)/4;1))


Спасибо, что есть такой сайт!
Спасибо Вам за отзыв!

Автор - Serge_007
Дата добавления - 15.10.2021 в 14:52
runa09 Дата: Пятница, 15.10.2021, 15:17 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Код
=ИНДЕКС(A$1:A$4;ЦЕЛОЕ(СТРОКА()/4,1+1))

спасибо за молниеносный ответ )
Код
=ИНДЕКС(A$1:A$4;ЦЕЛОЕ(СТРОКА()/4,1+1))
к сожалению, не получается добавить, подскажите, что я не так делаю. Файл прилагаю
спасибо
К сообщению приложен файл: -1-.xlsx(10.2 Kb)


Сообщение отредактировал Serge_007 - Пятница, 15.10.2021, 15:32
 
Ответить
Сообщение
Код
=ИНДЕКС(A$1:A$4;ЦЕЛОЕ(СТРОКА()/4,1+1))

спасибо за молниеносный ответ )
Код
=ИНДЕКС(A$1:A$4;ЦЕЛОЕ(СТРОКА()/4,1+1))
к сожалению, не получается добавить, подскажите, что я не так делаю. Файл прилагаю
спасибо

Автор - runa09
Дата добавления - 15.10.2021 в 15:17
Nic70y Дата: Пятница, 15.10.2021, 15:22 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 7158
Репутация: 1652 ±
Замечаний: 0% ±

Excel 2010
не получается добавить
что не получается?
тяните формулу за правый нижний угол вниз


ЮMoney 41001841029809
 
Ответить
Сообщение
не получается добавить
что не получается?
тяните формулу за правый нижний угол вниз

Автор - Nic70y
Дата добавления - 15.10.2021 в 15:22
runa09 Дата: Пятница, 15.10.2021, 15:29 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Код
=ИНДЕКС(A:A;ОКРУГЛВВЕРХ(СТРОКА(A1)/4;))

ВСЕ ПОЛУЧИЛОСЬ! Я просто не знаю, как запускать, оказывается..... Спасибо, милый человек!


Сообщение отредактировал Serge_007 - Пятница, 15.10.2021, 15:32
 
Ответить
Сообщение
Код
=ИНДЕКС(A:A;ОКРУГЛВВЕРХ(СТРОКА(A1)/4;))

ВСЕ ПОЛУЧИЛОСЬ! Я просто не знаю, как запускать, оказывается..... Спасибо, милый человек!

Автор - runa09
Дата добавления - 15.10.2021 в 15:29
Serge_007 Дата: Пятница, 15.10.2021, 15:34 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 14697
Репутация: 2432 ±
Замечаний: ±

Excel 2010
не получается добавить, подскажите, что я не так делаю. Файл прилагаю
Все формулы в файле
К сообщению приложен файл: 20211015_runa09.xls(65.5 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
не получается добавить, подскажите, что я не так делаю. Файл прилагаю
Все формулы в файле

Автор - Serge_007
Дата добавления - 15.10.2021 в 15:34
runa09 Дата: Пятница, 15.10.2021, 15:43 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

да, все работает, супер! Спасибо
 
Ответить
Сообщениеда, все работает, супер! Спасибо

Автор - runa09
Дата добавления - 15.10.2021 в 15:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » создание несколько копий из столбца списком (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!