Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Значение из ячейки по формуле из другой ячейки - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Значение из ячейки по формуле из другой ячейки (Формулы/Formulas)
Значение из ячейки по формуле из другой ячейки
sbm Дата: Пятница, 15.10.2021, 21:21 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Подскажите, в ячейках Листа2, ссылки на ячейки столбца С Листа1: =Лист1!С3, =Лист1!С15, =Лист1!С21 и др.
Как написать формулу, чтобы получить значение соответствующих ячеек из столбца А Листа1, т.е =Лист1!А3, =Лист1!А15, =Лист1!А21 и т.д.
 
Ответить
СообщениеПодскажите, в ячейках Листа2, ссылки на ячейки столбца С Листа1: =Лист1!С3, =Лист1!С15, =Лист1!С21 и др.
Как написать формулу, чтобы получить значение соответствующих ячеек из столбца А Листа1, т.е =Лист1!А3, =Лист1!А15, =Лист1!А21 и т.д.

Автор - sbm
Дата добавления - 15.10.2021 в 21:21
Pelena Дата: Пятница, 15.10.2021, 21:30 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18127
Репутация: 4061 ±
Замечаний: ±

Excel 2016 & Mac Excel
Файл с примером помог бы в понимании проблемы


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФайл с примером помог бы в понимании проблемы

Автор - Pelena
Дата добавления - 15.10.2021 в 21:30
sbm Дата: Пятница, 15.10.2021, 22:21 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Т.е. в ячейке ссылка на другую ячейку, надо из этой ссылки определить строку и столбец и получить значение в этой строке, но на 2 столбца левее
К сообщению приложен файл: 8115810.xlsx(9.0 Kb)
 
Ответить
СообщениеТ.е. в ячейке ссылка на другую ячейку, надо из этой ссылки определить строку и столбец и получить значение в этой строке, но на 2 столбца левее

Автор - sbm
Дата добавления - 15.10.2021 в 22:21
sbm Дата: Пятница, 15.10.2021, 22:27 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Т.е. в ячейке ссылка на другую ячейку, надо из этой ссылки определить строку и столбец и получить значение в этой строке, но на 2 столбца левее

да, именно так
 
Ответить
Сообщение
Т.е. в ячейке ссылка на другую ячейку, надо из этой ссылки определить строку и столбец и получить значение в этой строке, но на 2 столбца левее

да, именно так

Автор - sbm
Дата добавления - 15.10.2021 в 22:27
Pelena Дата: Пятница, 15.10.2021, 22:32 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 18127
Репутация: 4061 ±
Замечаний: ±

Excel 2016 & Mac Excel
Вариант
Код
=ИНДЕКС(Лист1!$A$1:$A$7;ПОИСКПОЗ(A2;Лист1!$C$1:$C$7;0))
К сообщению приложен файл: 8009895.xlsx(10.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВариант
Код
=ИНДЕКС(Лист1!$A$1:$A$7;ПОИСКПОЗ(A2;Лист1!$C$1:$C$7;0))

Автор - Pelena
Дата добавления - 15.10.2021 в 22:32
sbm Дата: Пятница, 15.10.2021, 22:35 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

=ИНДЕКС(Лист1!$A$1:$A$7;ПОИСКПОЗ(A2;Лист1!$C$1:$C$7;0))

значения могут повторяться, надо из ссылки как-то значения строки и столбца вытаскивать и менять значение столбца на -2


Сообщение отредактировал sbm - Пятница, 15.10.2021, 22:37
 
Ответить
Сообщение
=ИНДЕКС(Лист1!$A$1:$A$7;ПОИСКПОЗ(A2;Лист1!$C$1:$C$7;0))

значения могут повторяться, надо из ссылки как-то значения строки и столбца вытаскивать и менять значение столбца на -2

Автор - sbm
Дата добавления - 15.10.2021 в 22:35
Nic70y Дата: Суббота, 16.10.2021, 08:33 | Сообщение № 7
Группа: Друзья
Ранг: Экселист
Сообщений: 7162
Репутация: 1652 ±
Замечаний: 0% ±

Excel 2010
формула массива
Код
=ИНДЕКС(Лист1!A$1:A$189;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!C$1:C$189=A2;СТРОКА(Лист1!C$1:C$189));СЧЁТЕСЛИ(A$1:A2;A2)))
К сообщению приложен файл: 7870226.xlsx(9.9 Kb)


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Суббота, 16.10.2021, 08:33
 
Ответить
Сообщениеформула массива
Код
=ИНДЕКС(Лист1!A$1:A$189;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!C$1:C$189=A2;СТРОКА(Лист1!C$1:C$189));СЧЁТЕСЛИ(A$1:A2;A2)))

Автор - Nic70y
Дата добавления - 16.10.2021 в 08:33
Pelena Дата: Суббота, 16.10.2021, 08:34 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 18127
Репутация: 4061 ±
Замечаний: ±

Excel 2016 & Mac Excel
Код
=СМЕЩ(ДВССЫЛ(ПОДСТАВИТЬ(Ф.ТЕКСТ(A2);"=";""));0;-2)

правда, летучие СМЕЩ и ДВССЫЛ могут замедлять работу файла


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=СМЕЩ(ДВССЫЛ(ПОДСТАВИТЬ(Ф.ТЕКСТ(A2);"=";""));0;-2)

правда, летучие СМЕЩ и ДВССЫЛ могут замедлять работу файла

Автор - Pelena
Дата добавления - 16.10.2021 в 08:34
sbm Дата: Суббота, 16.10.2021, 21:38 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

=СМЕЩ(ДВССЫЛ(ПОДСТАВИТЬ(Ф.ТЕКСТ(A2);"=";""));0;-2)

у меня ф.текст не работает :'( :'( :'( :'(
=ИНДЕКС(Лист1!A$1:A$189;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!C$1:C$189=A2;СТРОКА(Лист1!C$1:C$189));СЧЁТЕСЛИ(A$1:A2;A2)))

если повторяющиеся числа, то работает не совсем верно, ищет первый, а м.б. и не первый нужен
 
Ответить
Сообщение
=СМЕЩ(ДВССЫЛ(ПОДСТАВИТЬ(Ф.ТЕКСТ(A2);"=";""));0;-2)

у меня ф.текст не работает :'( :'( :'( :'(
=ИНДЕКС(Лист1!A$1:A$189;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!C$1:C$189=A2;СТРОКА(Лист1!C$1:C$189));СЧЁТЕСЛИ(A$1:A2;A2)))

если повторяющиеся числа, то работает не совсем верно, ищет первый, а м.б. и не первый нужен

Автор - sbm
Дата добавления - 16.10.2021 в 21:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Значение из ячейки по формуле из другой ячейки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!