Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула "ЕСЛИ" для разных "ИСТИНА" - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула "ЕСЛИ" для разных "ИСТИНА" (Формулы/Formulas)
Формула "ЕСЛИ" для разных "ИСТИНА"
Houston4044 Дата: Понедельник, 18.10.2021, 14:57 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 20% ±

Всем доброго дня!

Подскажите, вот возник такой вопрос: если В1 = О1, то значение F1 = P1, но В1 может быть равно О2 и соответственно автоматически должно поменяться и значение F1 на Р2. Можно ли на это прописать формулу, что бы растянуть на весь столбец F и он автоматически редактировался в зависимости от показаний В1?

P.S. Значение В1 будет примерно такое "Покрытие. Дорога", то есть поиск только по ключевому слову указанному в столбце O
К сообщению приложен файл: --.xlsx(11.3 Kb)
 
Ответить
СообщениеВсем доброго дня!

Подскажите, вот возник такой вопрос: если В1 = О1, то значение F1 = P1, но В1 может быть равно О2 и соответственно автоматически должно поменяться и значение F1 на Р2. Можно ли на это прописать формулу, что бы растянуть на весь столбец F и он автоматически редактировался в зависимости от показаний В1?

P.S. Значение В1 будет примерно такое "Покрытие. Дорога", то есть поиск только по ключевому слову указанному в столбце O

Автор - Houston4044
Дата добавления - 18.10.2021 в 14:57
Nic70y Дата: Понедельник, 18.10.2021, 15:01 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7158
Репутация: 1652 ±
Замечаний: 0% ±

Excel 2010
Код
=ВПР("*"&B1&"*";O:P;2;)


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ВПР("*"&B1&"*";O:P;2;)

Автор - Nic70y
Дата добавления - 18.10.2021 в 15:01
Houston4044 Дата: Понедельник, 18.10.2021, 15:13 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 20% ±

Спасибо!Но остался вопрос, если пишем "Покрытие", то все ок и столбец F редактируется, но если писать "Покрытие. Дорога", то выдает ошибку


Сообщение отредактировал Serge_007 - Понедельник, 18.10.2021, 15:15
 
Ответить
СообщениеСпасибо!Но остался вопрос, если пишем "Покрытие", то все ок и столбец F редактируется, но если писать "Покрытие. Дорога", то выдает ошибку

Автор - Houston4044
Дата добавления - 18.10.2021 в 15:13
Nic70y Дата: Понедельник, 18.10.2021, 15:21 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 7158
Репутация: 1652 ±
Замечаний: 0% ±

Excel 2010
Код
=ВПР("*"&ЛЕВБ(B1;ПОИСК(".";B1&".")-1)&"*";O:P;2;)
а лучше огласите все варианты


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ВПР("*"&ЛЕВБ(B1;ПОИСК(".";B1&".")-1)&"*";O:P;2;)
а лучше огласите все варианты

Автор - Nic70y
Дата добавления - 18.10.2021 в 15:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула "ЕСЛИ" для разных "ИСТИНА" (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!