Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/три и более условий "если" в одной ячейке - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » три и более условий "если" в одной ячейке (Формулы/Formulas)
три и более условий "если" в одной ячейке
Ryamay Дата: Четверг, 21.10.2021, 20:51 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

больше 10
честно искала подобную тему, не нашла, если есть киньте ссылку

есть несколько условий для одной ячейки
если такое-то значение, то такой- то результат, а если другой , то и результат другой и так 4 раза
в стандартной "если , то" выдает, что слишком много условий, видела что делают через ВПР, но не понимаю логики, прошу, подскажите как создать формулу и ее логику.
Код
"=ЕСЛИ(B1=100;)"11000";ЕСЛИ(B1<100);"8800";ЕСЛИ(B1<;97;95);"5500";ЕСЛИ(B1<95);"0")"

надеюсь правильно оформила
заранее мерси.
К сообщению приложен файл: 8876781.xlsx(9.5 Kb)
 
Ответить
Сообщениечестно искала подобную тему, не нашла, если есть киньте ссылку

есть несколько условий для одной ячейки
если такое-то значение, то такой- то результат, а если другой , то и результат другой и так 4 раза
в стандартной "если , то" выдает, что слишком много условий, видела что делают через ВПР, но не понимаю логики, прошу, подскажите как создать формулу и ее логику.
Код
"=ЕСЛИ(B1=100;)"11000";ЕСЛИ(B1<100);"8800";ЕСЛИ(B1<;97;95);"5500";ЕСЛИ(B1<95);"0")"

надеюсь правильно оформила
заранее мерси.

Автор - Ryamay
Дата добавления - 21.10.2021 в 20:51
Pelena Дата: Четверг, 21.10.2021, 21:01 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18117
Репутация: 4059 ±
Замечаний: ±

Excel 2016 & Mac Excel
вариант без ВПР
Код
=ЕСЛИ(B2<95;0;ЕСЛИ(B2<97;5500;ЕСЛИ(B2<100;8800;ЕСЛИ(B2=100;11000;"больше 100"))))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениевариант без ВПР
Код
=ЕСЛИ(B2<95;0;ЕСЛИ(B2<97;5500;ЕСЛИ(B2<100;8800;ЕСЛИ(B2=100;11000;"больше 100"))))

Автор - Pelena
Дата добавления - 21.10.2021 в 21:01
Ryamay Дата: Четверг, 21.10.2021, 21:07 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

больше 10
Pelena, супер, работает, спасибо!
начинать стоило с меньшего значения условии?
 
Ответить
СообщениеPelena, супер, работает, спасибо!
начинать стоило с меньшего значения условии?

Автор - Ryamay
Дата добавления - 21.10.2021 в 21:07
Pelena Дата: Четверг, 21.10.2021, 21:16 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 18117
Репутация: 4059 ±
Замечаний: ±

Excel 2016 & Mac Excel
Можно и с большего, но тогда с другими знаками
Код
=ЕСЛИ(B1>100;"больше 100";ЕСЛИ(B1=100;11000;ЕСЛИ(B1>=97;8800;ЕСЛИ(B1>=95;5500;0))))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеМожно и с большего, но тогда с другими знаками
Код
=ЕСЛИ(B1>100;"больше 100";ЕСЛИ(B1=100;11000;ЕСЛИ(B1>=97;8800;ЕСЛИ(B1>=95;5500;0))))

Автор - Pelena
Дата добавления - 21.10.2021 в 21:16
Ryamay Дата: Четверг, 21.10.2021, 21:20 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

больше 10
Pelena, благодарю
 
Ответить
СообщениеPelena, благодарю

Автор - Ryamay
Дата добавления - 21.10.2021 в 21:20
Светлый Дата: Пятница, 22.10.2021, 11:47 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1738
Репутация: 473 ±
Замечаний: 0% ±

Excel 2013, 2016
А через ВПР можно так сделать:
Код
=ВПР(B2;{0;0:95;55:97;88:100;110};2)*100


Программировать проще, чем писать стихи.
 
Ответить
СообщениеА через ВПР можно так сделать:
Код
=ВПР(B2;{0;0:95;55:97;88:100;110};2)*100

Автор - Светлый
Дата добавления - 22.10.2021 в 11:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » три и более условий "если" в одной ячейке (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!