Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Условное форматировние с ВПР - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Условное форматировние с ВПР (Формулы/Formulas)
Условное форматировние с ВПР
tchnick Дата: Воскресенье, 24.10.2021, 10:17 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Добрый день!

Помогите, пожалуйста, написать формулу для условного форматирования.

Задача такая:
Если сумма по количеству БРАК превышает разницу между средним показателям ВЫДАНО и ФИНАЛЬНОЕ КОЛ-ВО то текст должен быть красный.
Но форматирование должно работать не для одной строки, а по всем одинаковым строкам из НОМЕР ЗАКАЗ.
Я полагаю тут нужен ВПР...

Буду очень благодарен, если кто то поможет.
К сообщению приложен файл: Rev_5_NCR_Repor.xlsx(9.4 Kb)


Сообщение отредактировал tchnick - Воскресенье, 24.10.2021, 10:18
 
Ответить
СообщениеДобрый день!

Помогите, пожалуйста, написать формулу для условного форматирования.

Задача такая:
Если сумма по количеству БРАК превышает разницу между средним показателям ВЫДАНО и ФИНАЛЬНОЕ КОЛ-ВО то текст должен быть красный.
Но форматирование должно работать не для одной строки, а по всем одинаковым строкам из НОМЕР ЗАКАЗ.
Я полагаю тут нужен ВПР...

Буду очень благодарен, если кто то поможет.

Автор - tchnick
Дата добавления - 24.10.2021 в 10:17
Pelena Дата: Воскресенье, 24.10.2021, 15:28 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18127
Репутация: 4061 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Если правильно поняла, формула для УФ
Код
=СУММЕСЛИ($A$2:$A$6;$A2;$E$2:$E$6)>СРЗНАЧ($C$2:$C$6)-СРЗНАЧ($B$2:$B$6)
К сообщению приложен файл: 8690763.xlsx(9.9 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Если правильно поняла, формула для УФ
Код
=СУММЕСЛИ($A$2:$A$6;$A2;$E$2:$E$6)>СРЗНАЧ($C$2:$C$6)-СРЗНАЧ($B$2:$B$6)

Автор - Pelena
Дата добавления - 24.10.2021 в 15:28
tchnick Дата: Воскресенье, 24.10.2021, 16:18 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Спасибо за ответ, но не совсем так.

Я приложил файл с описанием как должно работать.
К сообщению приложен файл: 8690763_rev1.xlsx(9.4 Kb)
 
Ответить
СообщениеСпасибо за ответ, но не совсем так.

Я приложил файл с описанием как должно работать.

Автор - tchnick
Дата добавления - 24.10.2021 в 16:18
Pelena Дата: Воскресенье, 24.10.2021, 18:26 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 18127
Репутация: 4061 ±
Замечаний: ±

Excel 2016 & Mac Excel
Код
=СУММЕСЛИ($A$2:$A$6;$A2;$E$2:$E$6)>СРЗНАЧЕСЛИ($A$2:$A$6;$A2;$C$2:$C$6)-СРЗНАЧЕСЛИ($A$2:$A$6;$A2;$B$2:$B$6)
К сообщению приложен файл: 4021873.xlsx(9.8 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=СУММЕСЛИ($A$2:$A$6;$A2;$E$2:$E$6)>СРЗНАЧЕСЛИ($A$2:$A$6;$A2;$C$2:$C$6)-СРЗНАЧЕСЛИ($A$2:$A$6;$A2;$B$2:$B$6)

Автор - Pelena
Дата добавления - 24.10.2021 в 18:26
gling Дата: Воскресенье, 24.10.2021, 18:53 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2296
Репутация: 595 ±
Замечаний: 0% ±

2010
Здравствуйте. По вашим условиям все данные в таблице будут красные. Попробуйте формулу
Код
=ЕСЛИ($A2=$H$1;СУММЕСЛИ($A$2:$A$6;$H$1;$E$2:$E$6)>(СРЗНАЧЕСЛИ($A$2:$A$6;$A2;$C$2:$C$6)-СРЗНАЧЕСЛИ($A$2:$A$6;$A2;$B$2:$B$6));)
Вариант использования в файле.
К сообщению приложен файл: 3183876.xlsx(9.7 Kb)


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте. По вашим условиям все данные в таблице будут красные. Попробуйте формулу
Код
=ЕСЛИ($A2=$H$1;СУММЕСЛИ($A$2:$A$6;$H$1;$E$2:$E$6)>(СРЗНАЧЕСЛИ($A$2:$A$6;$A2;$C$2:$C$6)-СРЗНАЧЕСЛИ($A$2:$A$6;$A2;$B$2:$B$6));)
Вариант использования в файле.

Автор - gling
Дата добавления - 24.10.2021 в 18:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Условное форматировние с ВПР (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!