Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Какая сумма из области по сумме в столбце - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Какая сумма из области по сумме в столбце (Формулы/Formulas)
Какая сумма из области по сумме в столбце
s5591378 Дата: Четверг, 28.10.2021, 01:39 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Надо вычислить сумму из области по сумме чисел из столбца, ну вот пример 90 карта+91 карта это будет сумма 363,46, пример диапазона 90 по 230 карту, Как посчитать сумму в деньгах, через ВПР или индекс, я чет поплыл)
К сообщению приложен файл: 5099609.xlsx(16.7 Kb)
 
Ответить
СообщениеНадо вычислить сумму из области по сумме чисел из столбца, ну вот пример 90 карта+91 карта это будет сумма 363,46, пример диапазона 90 по 230 карту, Как посчитать сумму в деньгах, через ВПР или индекс, я чет поплыл)

Автор - s5591378
Дата добавления - 28.10.2021 в 01:39
китин Дата: Четверг, 28.10.2021, 08:50 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6611
Репутация: 1004 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Код
=СУММ(ЕСЛИОШИБКА(ИНДЕКС($D$3:$AF$31;;ПОИСКПОЗ($L$39;$C$3:$C$31))*($B$3:$B$31>=$F$39)*($B$3:$B$31<=$H$39);0))
К сообщению приложен файл: 2621343.xlsx(16.9 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеФормула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Код
=СУММ(ЕСЛИОШИБКА(ИНДЕКС($D$3:$AF$31;;ПОИСКПОЗ($L$39;$C$3:$C$31))*($B$3:$B$31>=$F$39)*($B$3:$B$31<=$H$39);0))

Автор - китин
Дата добавления - 28.10.2021 в 08:50
bigor Дата: Четверг, 28.10.2021, 08:52 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 538
Репутация: 107 ±
Замечаний: 0% ±

нет
s5591378, а почему, если 90 относится ко второму ряду, поиск ведем по первому (это к Вашей формуле, когда 90 карту обсчитываем)
 
Ответить
Сообщениеs5591378, а почему, если 90 относится ко второму ряду, поиск ведем по первому (это к Вашей формуле, когда 90 карту обсчитываем)

Автор - bigor
Дата добавления - 28.10.2021 в 08:52
s5591378 Дата: Четверг, 28.10.2021, 13:01 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

китин, Добрый день, не совсем то что хотелось, сумма должна быть больше в зависимости какая цифра в столбце, ну 90 (1-й столбец) карта при допустим 4000 карт всего(2й-столбец) имеет зарабатывать 24,10 и так каждая карта до 143, 144 карта уже заработок 15,08, вот мне и надо если у человека допустим с 90 по 95 карту то сумма его заработка 120,50, а если допустим с 140 по 145 то заработак 102,46 (3 карты по 24,10 и 2 карты по 15,08)
 
Ответить
Сообщениекитин, Добрый день, не совсем то что хотелось, сумма должна быть больше в зависимости какая цифра в столбце, ну 90 (1-й столбец) карта при допустим 4000 карт всего(2й-столбец) имеет зарабатывать 24,10 и так каждая карта до 143, 144 карта уже заработок 15,08, вот мне и надо если у человека допустим с 90 по 95 карту то сумма его заработка 120,50, а если допустим с 140 по 145 то заработак 102,46 (3 карты по 24,10 и 2 карты по 15,08)

Автор - s5591378
Дата добавления - 28.10.2021 в 13:01
Светлый Дата: Четверг, 28.10.2021, 16:23 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1738
Репутация: 473 ±
Замечаний: 0% ±

Excel 2013, 2016
Может быть, такая формула подойдёт:
Код
=СУММПРОИЗВ(ИНДЕКС(D3:AF31;ПОИСКПОЗ(Ч(ИНДЕКС(СТРОКА(ДВССЫЛ(F39&":"&H39));));B3:B31);ПОИСКПОЗ(L39;C3:C31)))
с 140 по 145 то заработак 102,46 (3 карты по 24,10 и 2 карты по 15,08)
140,141,142,143 и 144,145 - это 4 и 2


Программировать проще, чем писать стихи.
 
Ответить
СообщениеМожет быть, такая формула подойдёт:
Код
=СУММПРОИЗВ(ИНДЕКС(D3:AF31;ПОИСКПОЗ(Ч(ИНДЕКС(СТРОКА(ДВССЫЛ(F39&":"&H39));));B3:B31);ПОИСКПОЗ(L39;C3:C31)))
с 140 по 145 то заработак 102,46 (3 карты по 24,10 и 2 карты по 15,08)
140,141,142,143 и 144,145 - это 4 и 2

Автор - Светлый
Дата добавления - 28.10.2021 в 16:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Какая сумма из области по сумме в столбце (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!