Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ВПР не считывает информацию с ячейки где много информации - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР не считывает информацию с ячейки где много информации (Формулы/Formulas)
ВПР не считывает информацию с ячейки где много информации
klis Дата: Понедельник, 08.11.2021, 11:07 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Доброго времени суток
Есть графа B с информацией, к ней приписаны значения в графе С, графа E через
Код
=ЕСЛИОШИБКА(ВПР("*"&D2&"*";$B$2:$C$491;2;ЛОЖЬ);"")
ищет по частичному совпадению D c B проставляет значения.
Все работает нормально, но на пункте 128 дает сбой, ВПР не может считать с нее информацию. Вариант не правильного формата ячейки отметаем, т.к все задано в одном формате и если удалить половину информации из ячейки, то по оставшейся половине формула ВПР сработает как должна.
В чем может быть проблема и как это исправлять?
Спасибо
К сообщению приложен файл: 2726830.xlsx(29.7 Kb)
 
Ответить
СообщениеДоброго времени суток
Есть графа B с информацией, к ней приписаны значения в графе С, графа E через
Код
=ЕСЛИОШИБКА(ВПР("*"&D2&"*";$B$2:$C$491;2;ЛОЖЬ);"")
ищет по частичному совпадению D c B проставляет значения.
Все работает нормально, но на пункте 128 дает сбой, ВПР не может считать с нее информацию. Вариант не правильного формата ячейки отметаем, т.к все задано в одном формате и если удалить половину информации из ячейки, то по оставшейся половине формула ВПР сработает как должна.
В чем может быть проблема и как это исправлять?
Спасибо

Автор - klis
Дата добавления - 08.11.2021 в 11:07
Pelena Дата: Понедельник, 08.11.2021, 11:20 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18117
Репутация: 4059 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Можно другие функции использовать
Код
=ИНДЕКС($A$2:$A$253;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК(D2;$B$2:$B$253));0))

в этом случае отпадает необходимость в столбце С


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Можно другие функции использовать
Код
=ИНДЕКС($A$2:$A$253;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК(D2;$B$2:$B$253));0))

в этом случае отпадает необходимость в столбце С

Автор - Pelena
Дата добавления - 08.11.2021 в 11:20
Serge_007 Дата: Понедельник, 08.11.2021, 11:23 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 14697
Репутация: 2432 ±
Замечаний: ±

Excel 2010
Здравствуйте

В чем может быть проблема
ВПР возвращает первое вхождение, а в 94-й строке у Вас есть 012-2891-48299/012-2891-48380


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

В чем может быть проблема
ВПР возвращает первое вхождение, а в 94-й строке у Вас есть 012-2891-48299/012-2891-48380

Автор - Serge_007
Дата добавления - 08.11.2021 в 11:23
Egyptian Дата: Понедельник, 08.11.2021, 11:25 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 202
Репутация: 68 ±
Замечаний: 0% ±

Excel 2013/2016
Вы про строку 129? У меня находит число 93. Проверил, данные находятся в строке 94 так что вроде все правильно.
К сообщению приложен файл: 3034342.png(104.8 Kb)
 
Ответить
СообщениеВы про строку 129? У меня находит число 93. Проверил, данные находятся в строке 94 так что вроде все правильно.

Автор - Egyptian
Дата добавления - 08.11.2021 в 11:25
Pelena Дата: Понедельник, 08.11.2021, 11:31 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 18117
Репутация: 4059 ±
Замечаний: ±

Excel 2016 & Mac Excel
Вы про строку 129?
Думаю, про 174 и ниже


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Вы про строку 129?
Думаю, про 174 и ниже

Автор - Pelena
Дата добавления - 08.11.2021 в 11:31
Serge_007 Дата: Понедельник, 08.11.2021, 11:55 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 14697
Репутация: 2432 ±
Замечаний: ±

Excel 2010
Думаю, про 174 и ниже
Код
=СУММПРОИЗВ(ЕЧИСЛО(НАЙТИ(D2;B$2:B$253))*СТРОКА($1:$252))


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Думаю, про 174 и ниже
Код
=СУММПРОИЗВ(ЕЧИСЛО(НАЙТИ(D2;B$2:B$253))*СТРОКА($1:$252))

Автор - Serge_007
Дата добавления - 08.11.2021 в 11:55
klis Дата: Понедельник, 08.11.2021, 11:56 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
ВПР возвращает первое вхождение, а в 94-й строке у Вас есть 012-2891-48299/012-2891-48380

Не понял, причем тут строка 94? Значения 012-2891-48299 и 012-2891-48380 не присутствует в 129(128 п/п строке), как она влияет на нее? Если удалить 94 строку, то ничего не поменяется.


=ИНДЕКС($A$2:$A$253;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК(D2;$B$2:$B$253));0))

в этом случае отпадает необходимость в столбце С

Данные в столбце С это не нумерация, там будет другая информация, которую я не стал расписывать, поэтому без столбца С никак.
 
Ответить
Сообщение
ВПР возвращает первое вхождение, а в 94-й строке у Вас есть 012-2891-48299/012-2891-48380

Не понял, причем тут строка 94? Значения 012-2891-48299 и 012-2891-48380 не присутствует в 129(128 п/п строке), как она влияет на нее? Если удалить 94 строку, то ничего не поменяется.


=ИНДЕКС($A$2:$A$253;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК(D2;$B$2:$B$253));0))

в этом случае отпадает необходимость в столбце С

Данные в столбце С это не нумерация, там будет другая информация, которую я не стал расписывать, поэтому без столбца С никак.

Автор - klis
Дата добавления - 08.11.2021 в 11:56
klis Дата: Понедельник, 08.11.2021, 12:00 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
=СУММПРОИЗВ(ЕЧИСЛО(НАЙТИ(D2;B$2:B$253))*СТРОКА($1:$252))

Да, с этим работает как надо! Но все же почему через мою формулу дает сбой?
upd поспешил, если задать текстовую информацию в столбец С, то ничего не работает


Сообщение отредактировал klis - Понедельник, 08.11.2021, 12:09
 
Ответить
Сообщение
=СУММПРОИЗВ(ЕЧИСЛО(НАЙТИ(D2;B$2:B$253))*СТРОКА($1:$252))

Да, с этим работает как надо! Но все же почему через мою формулу дает сбой?
upd поспешил, если задать текстовую информацию в столбец С, то ничего не работает

Автор - klis
Дата добавления - 08.11.2021 в 12:00
Egyptian Дата: Понедельник, 08.11.2021, 12:03 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 202
Репутация: 68 ±
Замечаний: 0% ±

Excel 2013/2016
Думаю, про 174 и ниже

Тут оказывается все искомые значения со 174 строки находятся в ячейке B129. Видимо, да. ВПР-ом их извлечь не получится.
Но все же почему через мою формулу да

Потому что, как уже написал Serge_007 ВПР возвращает первое вхождение.


Сообщение отредактировал Egyptian - Понедельник, 08.11.2021, 12:06
 
Ответить
Сообщение
Думаю, про 174 и ниже

Тут оказывается все искомые значения со 174 строки находятся в ячейке B129. Видимо, да. ВПР-ом их извлечь не получится.
Но все же почему через мою формулу да

Потому что, как уже написал Serge_007 ВПР возвращает первое вхождение.

Автор - Egyptian
Дата добавления - 08.11.2021 в 12:03
Serge_007 Дата: Понедельник, 08.11.2021, 12:09 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 14697
Репутация: 2432 ±
Замечаний: ±

Excel 2010
Данные в столбце С это не нумерация, там будет другая информация, которую я не стал расписывать, поэтому без столбца С никак
Тогда так:
Код
=ИНДЕКС(C$2:C$253;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК(D2;B$2:B$253));))


почему через мою формулу дает сбой?
Думаю что это из-за ограничения стринг в 255 символов


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Данные в столбце С это не нумерация, там будет другая информация, которую я не стал расписывать, поэтому без столбца С никак
Тогда так:
Код
=ИНДЕКС(C$2:C$253;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК(D2;B$2:B$253));))


почему через мою формулу дает сбой?
Думаю что это из-за ограничения стринг в 255 символов

Автор - Serge_007
Дата добавления - 08.11.2021 в 12:09
klis Дата: Понедельник, 08.11.2021, 12:13 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Тогда так:

=ИНДЕКС(C$2:C$253;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК(D2;B$2:B$253));))

Эмм, формула выдает ошибку, можно пример с файлом?

Думаю что это из-за ограничения стринг в 255 знаков

Можно обойти это ограничение?
 
Ответить
Сообщение
Тогда так:

=ИНДЕКС(C$2:C$253;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК(D2;B$2:B$253));))

Эмм, формула выдает ошибку, можно пример с файлом?

Думаю что это из-за ограничения стринг в 255 знаков

Можно обойти это ограничение?

Автор - klis
Дата добавления - 08.11.2021 в 12:13
Serge_007 Дата: Понедельник, 08.11.2021, 12:15 | Сообщение № 12
Группа: Админы
Ранг: Местный житель
Сообщений: 14697
Репутация: 2432 ±
Замечаний: ±

Excel 2010
формула выдает ошибку
Формулы массива вводятся одновременным нажатием Ctrl+Shift+Enter

Можно обойти это ограничение?
Не уверен
К сообщению приложен файл: 20211108_klis.xls(256.0 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
формула выдает ошибку
Формулы массива вводятся одновременным нажатием Ctrl+Shift+Enter

Можно обойти это ограничение?
Не уверен

Автор - Serge_007
Дата добавления - 08.11.2021 в 12:15
klis Дата: Понедельник, 08.11.2021, 12:18 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо!


Сообщение отредактировал Serge_007 - Понедельник, 08.11.2021, 12:19
 
Ответить
СообщениеСпасибо!

Автор - klis
Дата добавления - 08.11.2021 в 12:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР не считывает информацию с ячейки где много информации (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!