Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Индекс+Поискпоз для трехмерной таблицы - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Индекс+Поискпоз для трехмерной таблицы (Формулы/Formulas)
Индекс+Поискпоз для трехмерной таблицы
mma25011990 Дата: Среда, 10.11.2021, 12:26 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Приветствую.
Имеется трехмерная таблица в листе "ГОСТ, табл.(А.52.3+В.52.1)" со значениями в ячейках серого цвета
На листе "Расчет" в ячейках F45 и F46 почти одинаковыми формулами через инструмент "ИНДЕКС+ПОИСКПОЗ" хочу получить результат трехмерной таблицы по 3 критериям трехмерной таблицы. Критерии выделил на листе красным цветом. 2 из 3 критериев выбираются по выпадающему списку из уникальных значений, которые взяты из таблицы листа "ГОСТ, табл.(А.52.3+В.52.1)".
Формулы взял на основании статьи: https://ru.extendoffice.com/documen....html#a1

Проблема
Результат по формулам (ячейки F45 или F46) корректно выдает значения только для случаев, когда критерий (ячейка F44) равна значению по выпадающему списку A1 или A2. При значениях B1 B2 стоит значение "-" - некорректное значение, но оно имеется в массиве, из которого надо получать значения. А при остальных значениях (C,D1...) выдает результат #ССЫЛКА.
Как исправить чтобы корректно работала формула для всех критериев от A1 до G.
К сообщению приложен файл: __-0.4.xlsx(323.9 Kb)
 
Ответить
СообщениеПриветствую.
Имеется трехмерная таблица в листе "ГОСТ, табл.(А.52.3+В.52.1)" со значениями в ячейках серого цвета
На листе "Расчет" в ячейках F45 и F46 почти одинаковыми формулами через инструмент "ИНДЕКС+ПОИСКПОЗ" хочу получить результат трехмерной таблицы по 3 критериям трехмерной таблицы. Критерии выделил на листе красным цветом. 2 из 3 критериев выбираются по выпадающему списку из уникальных значений, которые взяты из таблицы листа "ГОСТ, табл.(А.52.3+В.52.1)".
Формулы взял на основании статьи: https://ru.extendoffice.com/documen....html#a1

Проблема
Результат по формулам (ячейки F45 или F46) корректно выдает значения только для случаев, когда критерий (ячейка F44) равна значению по выпадающему списку A1 или A2. При значениях B1 B2 стоит значение "-" - некорректное значение, но оно имеется в массиве, из которого надо получать значения. А при остальных значениях (C,D1...) выдает результат #ССЫЛКА.
Как исправить чтобы корректно работала формула для всех критериев от A1 до G.

Автор - mma25011990
Дата добавления - 10.11.2021 в 12:26
Serge_007 Дата: Среда, 10.11.2021, 12:47 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14697
Репутация: 2432 ±
Замечаний: ±

Excel 2010
Здравствуйте

Код
=ИНДЕКС('ГОСТ, табл.(А.52.3+В.52.1) '!L7:S103;ПОИСКПОЗ(F44;'ГОСТ, табл.(А.52.3+В.52.1) '!K7:K103;);ПОИСКПОЗ(F52;'ГОСТ, табл.(А.52.3+В.52.1) '!L5:S5;))
Код
=ИНДЕКС(Таблица2[[Ст.12]:[Ст.19]];ПОИСКПОЗ(F44;Таблица2[Ст.11];);ПОИСКПОЗ(F52;'ГОСТ, табл.(А.52.3+В.52.1) '!L5:S5;))
К сообщению приложен файл: 20211110_mma250.xlsb(316.3 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Код
=ИНДЕКС('ГОСТ, табл.(А.52.3+В.52.1) '!L7:S103;ПОИСКПОЗ(F44;'ГОСТ, табл.(А.52.3+В.52.1) '!K7:K103;);ПОИСКПОЗ(F52;'ГОСТ, табл.(А.52.3+В.52.1) '!L5:S5;))
Код
=ИНДЕКС(Таблица2[[Ст.12]:[Ст.19]];ПОИСКПОЗ(F44;Таблица2[Ст.11];);ПОИСКПОЗ(F52;'ГОСТ, табл.(А.52.3+В.52.1) '!L5:S5;))

Автор - Serge_007
Дата добавления - 10.11.2021 в 12:47
mma25011990 Дата: Среда, 10.11.2021, 13:51 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Спасибо большое! Вторая формула больше нравится - лаконичная, краткая.
 
Ответить
СообщениеСпасибо большое! Вторая формула больше нравится - лаконичная, краткая.

Автор - mma25011990
Дата добавления - 10.11.2021 в 13:51
Serge_007 Дата: Среда, 10.11.2021, 14:14 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14697
Репутация: 2432 ±
Замечаний: ±

Excel 2010
Это обе ваших формулы, Вы в них строки со столбцами перепутали)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЭто обе ваших формулы, Вы в них строки со столбцами перепутали)

Автор - Serge_007
Дата добавления - 10.11.2021 в 14:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Индекс+Поискпоз для трехмерной таблицы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!