Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Объединение данных из повторяющихся результатов поиска - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Объединение данных из повторяющихся результатов поиска (Формулы/Formulas)
Объединение данных из повторяющихся результатов поиска
litikovse Дата: Четверг, 11.11.2021, 14:24 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Добрый день просьба помочь с формулой, получается вытянуть только с одной строки. Пояснения еще есть в таблице, думаю там понятнее будет. Есть некая таблица "База" состоящая из столбцов А, В и С. И вторая таблица "Результат готовности". Формула требуется в столбец F. Результаты нужны только в тех случаях если в столбце Е значение "Не готов", в остальных пустая ячейка "". Рассмотрим приложенный файл, результат ячейки F2, в ячейке Е2 указано "Не готово", значит формула ищет значение ячейки D2 в столбце А (могут повторяться, в этом у меня и возникла проблема), а результат формулы должны быть значения из столбцов В и С. Также повторяющиеся значения и пустые из столбцов В и С и не должны попасть в результат. Пояснения еще есть в таблице, думаю там понятнее будет.
К сообщению приложен файл: ____.xlsx(9.6 Kb)
 
Ответить
СообщениеДобрый день просьба помочь с формулой, получается вытянуть только с одной строки. Пояснения еще есть в таблице, думаю там понятнее будет. Есть некая таблица "База" состоящая из столбцов А, В и С. И вторая таблица "Результат готовности". Формула требуется в столбец F. Результаты нужны только в тех случаях если в столбце Е значение "Не готов", в остальных пустая ячейка "". Рассмотрим приложенный файл, результат ячейки F2, в ячейке Е2 указано "Не готово", значит формула ищет значение ячейки D2 в столбце А (могут повторяться, в этом у меня и возникла проблема), а результат формулы должны быть значения из столбцов В и С. Также повторяющиеся значения и пустые из столбцов В и С и не должны попасть в результат. Пояснения еще есть в таблице, думаю там понятнее будет.

Автор - litikovse
Дата добавления - 11.11.2021 в 14:24
litikovse Дата: Пятница, 12.11.2021, 05:27 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Добавил пояснения. И добавил Лист2 с формулой, но она не работает, как следует.
К сообщению приложен файл: 4148813.xlsx(14.2 Kb)
 
Ответить
СообщениеДобавил пояснения. И добавил Лист2 с формулой, но она не работает, как следует.

Автор - litikovse
Дата добавления - 12.11.2021 в 05:27
Pelena Дата: Пятница, 12.11.2021, 09:24 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 18556
Репутация: 4203 ±
Замечаний: ±

Excel 2016 & Mac Excel
Формула вряд ли справится. Пользовательской функцией подойдёт? Макросы должны быть разрешены.
Хотя, если у Вас работает ОБЪЕДИНИТЬ, то должна быть и LAMBDA. Есть такая функция в Вашей версии Excel?


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеФормула вряд ли справится. Пользовательской функцией подойдёт? Макросы должны быть разрешены.
Хотя, если у Вас работает ОБЪЕДИНИТЬ, то должна быть и LAMBDA. Есть такая функция в Вашей версии Excel?

Автор - Pelena
Дата добавления - 12.11.2021 в 09:24
litikovse Дата: Пятница, 12.11.2021, 09:37 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Pelena, Да, имеется.
 
Ответить
СообщениеPelena, Да, имеется.

Автор - litikovse
Дата добавления - 12.11.2021 в 09:37
Pelena Дата: Пятница, 12.11.2021, 10:46 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 18556
Репутация: 4203 ±
Замечаний: ±

Excel 2016 & Mac Excel
Пока получилось только с повторами
Код
=ЕСЛИ(C2="Не готово";ОБЪЕДИНИТЬ(" ";ИСТИНА;ФИЛЬТР('Table 1'!$D$2:$G$15000;A2='Table 1'!$A$2:$A$15000));"")
К сообщению приложен файл: 7607703_2.xlsx(418.3 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеПока получилось только с повторами
Код
=ЕСЛИ(C2="Не готово";ОБЪЕДИНИТЬ(" ";ИСТИНА;ФИЛЬТР('Table 1'!$D$2:$G$15000;A2='Table 1'!$A$2:$A$15000));"")

Автор - Pelena
Дата добавления - 12.11.2021 в 10:46
litikovse Дата: Пятница, 12.11.2021, 11:08 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Pelena, Это уже хорошо, даже очень. Большое спасибо. Вот лямбда заинтересовала, буду гугл мучать, что это такое и как её едят.
 
Ответить
СообщениеPelena, Это уже хорошо, даже очень. Большое спасибо. Вот лямбда заинтересовала, буду гугл мучать, что это такое и как её едят.

Автор - litikovse
Дата добавления - 12.11.2021 в 11:08
Pelena Дата: Пятница, 12.11.2021, 11:10 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 18556
Репутация: 4203 ±
Замечаний: ±

Excel 2016 & Mac Excel
Я пока обошлась без лямбды, вовремя вспомнила про ФИЛЬТР()
Про LAMBDA можно здесь почитать


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЯ пока обошлась без лямбды, вовремя вспомнила про ФИЛЬТР()
Про LAMBDA можно здесь почитать

Автор - Pelena
Дата добавления - 12.11.2021 в 11:10
litikovse Дата: Пятница, 12.11.2021, 12:16 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Pelena, хорошо, спасибо.
 
Ответить
СообщениеPelena, хорошо, спасибо.

Автор - litikovse
Дата добавления - 12.11.2021 в 12:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Объединение данных из повторяющихся результатов поиска (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!