Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск ячеек, соответствующих нескольким заданным условиям - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск ячеек, соответствующих нескольким заданным условиям (Формулы/Formulas)
Поиск ячеек, соответствующих нескольким заданным условиям
Nuny Дата: Пятница, 12.11.2021, 11:12 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте! Нужна помощь с формулой. В файле написала как должно идти сравнение. Важно, чтобы названия и должности были прописаны в формуле словами, а не ссылались на ячейки.
К сообщению приложен файл: 0011835.xlsx(9.6 Kb)
 
Ответить
СообщениеЗдравствуйте! Нужна помощь с формулой. В файле написала как должно идти сравнение. Важно, чтобы названия и должности были прописаны в формуле словами, а не ссылались на ячейки.

Автор - Nuny
Дата добавления - 12.11.2021 в 11:12
Pelena Дата: Пятница, 12.11.2021, 11:21 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18117
Репутация: 4059 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Код
=ЕСЛИ(ИЛИ(И(B2 = "Электромонтер по оперативным переключениям в распределительных сетях 5 разряда"; A2="БАС");И(B2= "Электромонтер по обслуживанию электрооборузования";A2="Хромц");И(B2="Электромонтер по обслужванию подстанций";A2="ОДС"));12;8)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ЕСЛИ(ИЛИ(И(B2 = "Электромонтер по оперативным переключениям в распределительных сетях 5 разряда"; A2="БАС");И(B2= "Электромонтер по обслуживанию электрооборузования";A2="Хромц");И(B2="Электромонтер по обслужванию подстанций";A2="ОДС"));12;8)

Автор - Pelena
Дата добавления - 12.11.2021 в 11:21
Nuny Дата: Пятница, 12.11.2021, 11:34 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Pelena, спасибо! Больше 4х аргументов excel не дает поставить :( Альтернативного варианта нет?
 
Ответить
СообщениеPelena, спасибо! Больше 4х аргументов excel не дает поставить :( Альтернативного варианта нет?

Автор - Nuny
Дата добавления - 12.11.2021 в 11:34
Serge_007 Дата: Пятница, 12.11.2021, 11:37 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14697
Репутация: 2432 ±
Замечаний: ±

Excel 2010
Больше 4х аргументов excel не дает поставить
Дает
Что именно у Вас не получается?

Вариант:
Код
=ВЫБОР((B2 = "Электромонтер по оперативным переключениям в распределительных сетях 5 разряда")*( A2="БАС")+(B2= "Электромонтер по обслуживанию электрооборузования")*(A2="Хромц")+(B2="Электромонтер по обслужванию подстанций")*(A2="ОДС")+1;8;12)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Больше 4х аргументов excel не дает поставить
Дает
Что именно у Вас не получается?

Вариант:
Код
=ВЫБОР((B2 = "Электромонтер по оперативным переключениям в распределительных сетях 5 разряда")*( A2="БАС")+(B2= "Электромонтер по обслуживанию электрооборузования")*(A2="Хромц")+(B2="Электромонтер по обслужванию подстанций")*(A2="ОДС")+1;8;12)

Автор - Serge_007
Дата добавления - 12.11.2021 в 11:37
Pelena Дата: Пятница, 12.11.2021, 11:41 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 18117
Репутация: 4059 ±
Замечаний: ±

Excel 2016 & Mac Excel
Больше 4х аргументов excel не дает поставить

создайте вспомогательную таблицу с должностями и значениями и ВПР-ом её


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Больше 4х аргументов excel не дает поставить

создайте вспомогательную таблицу с должностями и значениями и ВПР-ом её

Автор - Pelena
Дата добавления - 12.11.2021 в 11:41
Nuny Дата: Пятница, 12.11.2021, 12:16 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Serge_007, вот с Вашим вариантом получилось. спасибо!
 
Ответить
СообщениеSerge_007, вот с Вашим вариантом получилось. спасибо!

Автор - Nuny
Дата добавления - 12.11.2021 в 12:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск ячеек, соответствующих нескольким заданным условиям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!