Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование по двум условиям - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование по двум условиям (Формулы/Formulas)
Суммирование по двум условиям
tn955 Дата: Пятница, 12.11.2021, 16:29 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Подскажите пожалуйста, можно ли использовать формулу счётеслимн и суммеслимн в одном ячейке, в моем случае суммировать ячейки например в Е:Е на выбранном диапазоне
например =СЧЁТЕСЛИМН(Лист1!$B:B;"БЕЛЫЙ"; и дальше хотел суммировать ячейки E:E
Можно ли суммировать в командах счётесли?
 
Ответить
СообщениеПодскажите пожалуйста, можно ли использовать формулу счётеслимн и суммеслимн в одном ячейке, в моем случае суммировать ячейки например в Е:Е на выбранном диапазоне
например =СЧЁТЕСЛИМН(Лист1!$B:B;"БЕЛЫЙ"; и дальше хотел суммировать ячейки E:E
Можно ли суммировать в командах счётесли?

Автор - tn955
Дата добавления - 12.11.2021 в 16:29
Serge_007 Дата: Пятница, 12.11.2021, 17:17 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14697
Репутация: 2432 ±
Замечаний: ±

Excel 2010
можно ли использовать формулу счётеслимн и суммеслимн в одном ячейке
Можно


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
можно ли использовать формулу счётеслимн и суммеслимн в одном ячейке
Можно

Автор - Serge_007
Дата добавления - 12.11.2021 в 17:17
tn955 Дата: Суббота, 13.11.2021, 17:44 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Serge_007
=СЧЁТЕСЛИМН(Лист1!$B:B;"БЕЛЫЙ"; и дальше хотел суммировать ячейки E:E вообще не смог продолжить дальше там везде ошибка можете оставить формулу здесь?
 
Ответить
СообщениеSerge_007
=СЧЁТЕСЛИМН(Лист1!$B:B;"БЕЛЫЙ"; и дальше хотел суммировать ячейки E:E вообще не смог продолжить дальше там везде ошибка можете оставить формулу здесь?

Автор - tn955
Дата добавления - 13.11.2021 в 17:44
Pelena Дата: Суббота, 13.11.2021, 18:11 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 18117
Репутация: 4059 ±
Замечаний: ±

Excel 2016 & Mac Excel
tn955, файл с примером приложите и название темы придумайте более конкретное, отражающее суть задачи


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеtn955, файл с примером приложите и название темы придумайте более конкретное, отражающее суть задачи

Автор - Pelena
Дата добавления - 13.11.2021 в 18:11
tn955 Дата: Воскресенье, 14.11.2021, 09:43 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

вот здесь я прикрепил файл, можете посмотреть и там сразу формулу...? пожалуйста.
К сообщению приложен файл: 7978952.xlsx(10.6 Kb)
 
Ответить
Сообщениевот здесь я прикрепил файл, можете посмотреть и там сразу формулу...? пожалуйста.

Автор - tn955
Дата добавления - 14.11.2021 в 09:43
Pelena Дата: Воскресенье, 14.11.2021, 10:12 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 18117
Репутация: 4059 ±
Замечаний: ±

Excel 2016 & Mac Excel
Для белого и железного
Код
=СУММПРОИЗВ(C6:E29*(B6:B29="белый")*(C5:E5="железный"))
К сообщению приложен файл: 4752966.xlsx(11.6 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеДля белого и железного
Код
=СУММПРОИЗВ(C6:E29*(B6:B29="белый")*(C5:E5="железный"))

Автор - Pelena
Дата добавления - 14.11.2021 в 10:12
jakim Дата: Воскресенье, 14.11.2021, 15:10 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1052
Репутация: 280 ±
Замечаний: 0% ±

Excel 2010
Вариант с PQ вроде сводной.

[vba]
Код
let
    Source = Excel.CurrentWorkbook(){[Name="Table1"]}[Content],
    #"Changed Type" = Table.TransformColumnTypes(Source,{{"цвет", type text}, {"железный ", Int64.Type}, {"деревянный", Int64.Type}, {"битумный", Int64.Type}}),
    #"Grouped Rows" = Table.Group(#"Changed Type", {"цвет"}, {{"Count", each List.Sum([#"железный "]), type number}, {"der", each List.Sum([деревянный]), type number}, {"битумный", each List.Sum([битумный]), type number}}),
    #"Renamed Columns" = Table.RenameColumns(#"Grouped Rows",{{"Count", "железный"}, {"der", "деревянный"}})
in
    #"Renamed Columns"
[/vba]
К сообщению приложен файл: 5816499.xlsx(18.4 Kb)


Сообщение отредактировал Serge_007 - Понедельник, 15.11.2021, 11:46
 
Ответить
Сообщение
Вариант с PQ вроде сводной.

[vba]
Код
let
    Source = Excel.CurrentWorkbook(){[Name="Table1"]}[Content],
    #"Changed Type" = Table.TransformColumnTypes(Source,{{"цвет", type text}, {"железный ", Int64.Type}, {"деревянный", Int64.Type}, {"битумный", Int64.Type}}),
    #"Grouped Rows" = Table.Group(#"Changed Type", {"цвет"}, {{"Count", each List.Sum([#"железный "]), type number}, {"der", each List.Sum([деревянный]), type number}, {"битумный", each List.Sum([битумный]), type number}}),
    #"Renamed Columns" = Table.RenameColumns(#"Grouped Rows",{{"Count", "железный"}, {"der", "деревянный"}})
in
    #"Renamed Columns"
[/vba]

Автор - jakim
Дата добавления - 14.11.2021 в 15:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование по двум условиям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!