Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенести данные без пустых колонок - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенести данные без пустых колонок (Формулы/Formulas)
Перенести данные без пустых колонок
Andrey032 Дата: Пятница, 12.11.2021, 16:32 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Добрый вечер, помогите пожалуйста есть таблица 1 состоит из колонок с 15 ячейками ,в этой таблице есть пустые колонки (удаляются вручную,ненужные) как сделать чтобы данные переносились в таблицу 2 без этих пустых колонок автоматически,сейчас вручную делаю ,может кто то подскажет,спасибо.
К сообщению приложен файл: 2781922.xlsx(9.7 Kb)


Сообщение отредактировал Andrey032 - Пятница, 12.11.2021, 16:33
 
Ответить
СообщениеДобрый вечер, помогите пожалуйста есть таблица 1 состоит из колонок с 15 ячейками ,в этой таблице есть пустые колонки (удаляются вручную,ненужные) как сделать чтобы данные переносились в таблицу 2 без этих пустых колонок автоматически,сейчас вручную делаю ,может кто то подскажет,спасибо.

Автор - Andrey032
Дата добавления - 12.11.2021 в 16:32
Serge_007 Дата: Пятница, 12.11.2021, 17:15 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15403
Репутация: 2536 ±
Замечаний: ±

Excel 2016
Здравствуйте

Формула массива:
Код
=ИНДЕКС($A3:$M3;НАИМЕНЬШИЙ(ЕСЛИ($A3:$M3<>"";СТОЛБЕЦ($A1:$M1));СТОЛБЕЦ(A1)))
К сообщению приложен файл: 20211112_Andrey.xls(92.0 Kb)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Формула массива:
Код
=ИНДЕКС($A3:$M3;НАИМЕНЬШИЙ(ЕСЛИ($A3:$M3<>"";СТОЛБЕЦ($A1:$M1));СТОЛБЕЦ(A1)))

Автор - Serge_007
Дата добавления - 12.11.2021 в 17:15
Andrey032 Дата: Пятница, 12.11.2021, 18:27 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Спасибо thumb
 
Ответить
СообщениеСпасибо thumb

Автор - Andrey032
Дата добавления - 12.11.2021 в 18:27
Andrey032 Дата: Суббота, 25.12.2021, 22:21 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Добрый вечер, помогите пожалуйста ,с таблицей в которой есть пустые колонки с этим всё разобрались ,всё отлично у меня дополнительный вопрос ,а если колонки с нулями их можно так же как то убирать?
 
Ответить
СообщениеДобрый вечер, помогите пожалуйста ,с таблицей в которой есть пустые колонки с этим всё разобрались ,всё отлично у меня дополнительный вопрос ,а если колонки с нулями их можно так же как то убирать?

Автор - Andrey032
Дата добавления - 25.12.2021 в 22:21
Andrey032 Дата: Воскресенье, 26.12.2021, 05:58 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Сейчас до самого дошло что нужно просто "" поменять на 0 ,верно?
 
Ответить
СообщениеСейчас до самого дошло что нужно просто "" поменять на 0 ,верно?

Автор - Andrey032
Дата добавления - 26.12.2021 в 05:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенести данные без пустых колонок (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!