Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод значения из таблицы другого листа - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод значения из таблицы другого листа (Формулы/Formulas)
Вывод значения из таблицы другого листа
NikitaO_o Дата: Пятница, 19.11.2021, 09:36 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 20% ±

Здравствуйте. Передо мной стоит задача (файл приложил). В файле есть 2 листа (Справочник-донор и Лист1). Нужно создать какую-то формулу, которая берет значение в "Справочнике-донор" из столбца "Код услуги ФРГУ" и такое же значение в Лист1 , и если оно совпадает, то выводило бы: значение из "Лист 1" столбец "Наименование" в "Справочник Донор" в стаоолец "Сравнение". ПОнял, что как-то можно через функцию ВПР или Индек, но уже битый час бьюсь, не могу понять как же сделать. Подскажите пожалуйста , или помогите.
К сообщению приложен файл: 4833213.xlsx(17.5 Kb)
 
Ответить
СообщениеЗдравствуйте. Передо мной стоит задача (файл приложил). В файле есть 2 листа (Справочник-донор и Лист1). Нужно создать какую-то формулу, которая берет значение в "Справочнике-донор" из столбца "Код услуги ФРГУ" и такое же значение в Лист1 , и если оно совпадает, то выводило бы: значение из "Лист 1" столбец "Наименование" в "Справочник Донор" в стаоолец "Сравнение". ПОнял, что как-то можно через функцию ВПР или Индек, но уже битый час бьюсь, не могу понять как же сделать. Подскажите пожалуйста , или помогите.

Автор - NikitaO_o
Дата добавления - 19.11.2021 в 09:36
bigor Дата: Пятница, 19.11.2021, 10:00 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 575
Репутация: 112 ±
Замечаний: 0% ±

нет
Добрый день
В K2 и протянуть вниз
Код
=IFERROR(INDEX(Лист1.$A$2:$A$5;MATCH(B2;Лист1.$B$2:$B$5;0));"Не найдено")

ps если Код будет повторятся на Лист1, то выведет значение соответствующее первому совпадению


Сообщение отредактировал bigor - Пятница, 19.11.2021, 10:02
 
Ответить
СообщениеДобрый день
В K2 и протянуть вниз
Код
=IFERROR(INDEX(Лист1.$A$2:$A$5;MATCH(B2;Лист1.$B$2:$B$5;0));"Не найдено")

ps если Код будет повторятся на Лист1, то выведет значение соответствующее первому совпадению

Автор - bigor
Дата добавления - 19.11.2021 в 10:00
китин Дата: Пятница, 19.11.2021, 10:47 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 6686
Репутация: 1020 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
или так
Код
=ПРОСМОТР(2;1/($A2='Справочник-донор'!$J$2:$J$6);'Справочник-донор'!$B$2:$B$6)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеили так
Код
=ПРОСМОТР(2;1/($A2='Справочник-донор'!$J$2:$J$6);'Справочник-донор'!$B$2:$B$6)

Автор - китин
Дата добавления - 19.11.2021 в 10:47
NikitaO_o Дата: Пятница, 19.11.2021, 11:06 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 20% ±

Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1.$A$2:$A$5;ПОИСКПОЗ(B2;Лист1.$B$2:$B$5;0));"Не найдено")
Спасибо за то, что откликнулись! Но к сожалеию говорит, что ошибка где-то в формуле. Скриншот приложил
К сообщению приложен файл: 7163548.png(102.4 Kb)


Сообщение отредактировал Serge_007 - Пятница, 19.11.2021, 11:20
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1.$A$2:$A$5;ПОИСКПОЗ(B2;Лист1.$B$2:$B$5;0));"Не найдено")
Спасибо за то, что откликнулись! Но к сожалеию говорит, что ошибка где-то в формуле. Скриншот приложил

Автор - NikitaO_o
Дата добавления - 19.11.2021 в 11:06
NikitaO_o Дата: Пятница, 19.11.2021, 11:14 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 20% ±

Код
=ПРОСМОТР(2;1/($A2='Справочник-донор'!$J$2:$J$6);'Справочник-донор'!$B$2:$B$6)

Аналогично, спасибо за отлик! Но к сожалению не работает.


Сообщение отредактировал Serge_007 - Пятница, 19.11.2021, 11:21
 
Ответить
Сообщение
Код
=ПРОСМОТР(2;1/($A2='Справочник-донор'!$J$2:$J$6);'Справочник-донор'!$B$2:$B$6)

Аналогично, спасибо за отлик! Но к сожалению не работает.

Автор - NikitaO_o
Дата добавления - 19.11.2021 в 11:14
Serge_007 Дата: Пятница, 19.11.2021, 11:28 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 14866
Репутация: 2462 ±
Замечаний: ±

Excel 2016
не работает
Обе формулы рабочие (см. вложение)
К сообщению приложен файл: 20211119_Nikita.xls(77.0 Kb)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
не работает
Обе формулы рабочие (см. вложение)

Автор - Serge_007
Дата добавления - 19.11.2021 в 11:28
NikitaO_o Дата: Пятница, 19.11.2021, 11:33 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 20% ±

Обе формулы рабочие

После названия листа нужно было поставить восклицительный знак в формуле, а тут не было. Поэтому не работало. Спасибо большое, что прикрепили файл! Помогли разобраться!
 
Ответить
Сообщение
Обе формулы рабочие

После названия листа нужно было поставить восклицительный знак в формуле, а тут не было. Поэтому не работало. Спасибо большое, что прикрепили файл! Помогли разобраться!

Автор - NikitaO_o
Дата добавления - 19.11.2021 в 11:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод значения из таблицы другого листа (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!