Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование данных по диапазонам дат и условиям - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование данных по диапазонам дат и условиям (Формулы/Formulas)
Суммирование данных по диапазонам дат и условиям
valsaar Дата: Воскресенье, 21.11.2021, 16:17 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Доброго дня.
Есть таблица исходных данных объемов работ по датам. Необходимо просуммировать объемы по видам работ и исполнителям. Сложность в том, что нужно суммировать с учетом диапазонов дат:
с 11 числа месяца по 25 и с 26 по 10 число следующего месяца.
Подскажите, пожалуйста, решение.
К сообщению приложен файл: 6573495.xlsx(10.2 Kb)
 
Ответить
СообщениеДоброго дня.
Есть таблица исходных данных объемов работ по датам. Необходимо просуммировать объемы по видам работ и исполнителям. Сложность в том, что нужно суммировать с учетом диапазонов дат:
с 11 числа месяца по 25 и с 26 по 10 число следующего месяца.
Подскажите, пожалуйста, решение.

Автор - valsaar
Дата добавления - 21.11.2021 в 16:17
mikaelw Дата: Воскресенье, 21.11.2021, 16:19 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 126
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010, 2013, 2016
Самое простое формулой, но я бы пошел через Сводную таблицу, можно более гибко настраивать.


Сообщение отредактировал mikaelw - Воскресенье, 21.11.2021, 16:41
 
Ответить
СообщениеСамое простое формулой, но я бы пошел через Сводную таблицу, можно более гибко настраивать.

Автор - mikaelw
Дата добавления - 21.11.2021 в 16:19
valsaar Дата: Воскресенье, 21.11.2021, 16:38 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Сводник не подойдет, нужна формула и вот тут у меня не хватает знаний. Как учесть все 3 условия: диапазон дат, фио и вид работ?
 
Ответить
СообщениеСводник не подойдет, нужна формула и вот тут у меня не хватает знаний. Как учесть все 3 условия: диапазон дат, фио и вид работ?

Автор - valsaar
Дата добавления - 21.11.2021 в 16:38
mikaelw Дата: Воскресенье, 21.11.2021, 16:56 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 126
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010, 2013, 2016
Как учесть все 3 условия: диапазон дат, фио и вид работ?


Пример нормальный выложи.
 
Ответить
Сообщение
Как учесть все 3 условия: диапазон дат, фио и вид работ?


Пример нормальный выложи.

Автор - mikaelw
Дата добавления - 21.11.2021 в 16:56
valsaar Дата: Воскресенье, 21.11.2021, 16:59 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

а что в этом примере не так? исходная таблица есть, на выходе нужно получить суммированную таблицу по фио и видам работ с учетом диапазонов дат
 
Ответить
Сообщениеа что в этом примере не так? исходная таблица есть, на выходе нужно получить суммированную таблицу по фио и видам работ с учетом диапазонов дат

Автор - valsaar
Дата добавления - 21.11.2021 в 16:59
китин Дата: Понедельник, 22.11.2021, 09:39 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 6611
Репутация: 1004 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
С доп.табличкой пойдет?
Код
=СУММПРОИЗВ(Лист1!$D$2:$D$39*(Лист1!$B$2:$B$39=Лист2!$A2)*(Лист1!$C$2:$C$39=Лист2!$B2)*(Лист1!$A$2:$A$39>=Лист2!C$1)*(Лист1!$A$2:$A$39<Лист2!D$1))
К сообщению приложен файл: valsaar.xlsx(12.5 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеС доп.табличкой пойдет?
Код
=СУММПРОИЗВ(Лист1!$D$2:$D$39*(Лист1!$B$2:$B$39=Лист2!$A2)*(Лист1!$C$2:$C$39=Лист2!$B2)*(Лист1!$A$2:$A$39>=Лист2!C$1)*(Лист1!$A$2:$A$39<Лист2!D$1))

Автор - китин
Дата добавления - 22.11.2021 в 09:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование данных по диапазонам дат и условиям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!