Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула отопления за зимний период - Мир MS Excel

Старая форма входа
  • Страница 1 из 2
  • 1
  • 2
  • »
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула отопления за зимний период (Формулы/Formulas)
Формула отопления за зимний период
Юрий_Ф Дата: Среда, 08.12.2021, 02:05 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 520
Репутация: -3 ±
Замечаний: 20% ±

Excel 2010
Ведена формула, которая работает (должна, по крайней мере - если я правильно ввёл) в октябре, ноябре, декабре:
Код
=ЕСЛИ(МЕСЯЦ(СЕГОДНЯ())>9;D2;"")

Подскажите, пожалуйста, как её дополнить (изменить), чтобы работала и в январе, феврале, марте?
К сообщению приложен файл: 5901730.xlsx(8.1 Kb)


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеВедена формула, которая работает (должна, по крайней мере - если я правильно ввёл) в октябре, ноябре, декабре:
Код
=ЕСЛИ(МЕСЯЦ(СЕГОДНЯ())>9;D2;"")

Подскажите, пожалуйста, как её дополнить (изменить), чтобы работала и в январе, феврале, марте?

Автор - Юрий_Ф
Дата добавления - 08.12.2021 в 02:05
DrMini Дата: Среда, 08.12.2021, 04:59 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 883
Репутация: 71 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
как её дополнить (изменить), чтобы работала и в январе, феврале, марте?

Код
=ЕСЛИ(МЕСЯЦ(СЕГОДНЯ())>=1;D2;"")

Только не пойму зачем это?
Раньше у Вас был результат из ячейки D2 начиная с октября, а сейчас будет результат ячейки D2 весь год.
Что-то мне подсказывает, что Вы ищите не то.
Может вот так нужно:
Код
=ЕСЛИ(РАЗНДАТ("30.09.2021";СЕГОДНЯ();"d")>0;D2;"")

или так:
Код
=ЕСЛИ(ДАТА(2021;10;)<СЕГОДНЯ();D2;"")


Сообщение отредактировал DrMini - Среда, 08.12.2021, 06:13
 
Ответить
Сообщение
как её дополнить (изменить), чтобы работала и в январе, феврале, марте?

Код
=ЕСЛИ(МЕСЯЦ(СЕГОДНЯ())>=1;D2;"")

Только не пойму зачем это?
Раньше у Вас был результат из ячейки D2 начиная с октября, а сейчас будет результат ячейки D2 весь год.
Что-то мне подсказывает, что Вы ищите не то.
Может вот так нужно:
Код
=ЕСЛИ(РАЗНДАТ("30.09.2021";СЕГОДНЯ();"d")>0;D2;"")

или так:
Код
=ЕСЛИ(ДАТА(2021;10;)<СЕГОДНЯ();D2;"")

Автор - DrMini
Дата добавления - 08.12.2021 в 04:59
китин Дата: Среда, 08.12.2021, 07:38 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 6907
Репутация: 1057 ±
Замечаний: 0% ±

Excel 2007;2010;2016
ну или так
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(МЕСЯЦ(СЕГОДНЯ());{1;2;3;10;11;12};0));$D$2;"")


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщениену или так
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(МЕСЯЦ(СЕГОДНЯ());{1;2;3;10;11;12};0));$D$2;"")

Автор - китин
Дата добавления - 08.12.2021 в 07:38
Светлый Дата: Среда, 08.12.2021, 10:28 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1742
Репутация: 478 ±
Замечаний: 0% ±

Excel 2013, 2016
Список зимних месяцев можно задать в формуле:
Код
=ЕСЛИ(ИЛИ(МЕСЯЦ(СЕГОДНЯ())={1;2;3;10;11;12});$D$2;"")


Программировать проще, чем писать стихи.
 
Ответить
СообщениеСписок зимних месяцев можно задать в формуле:
Код
=ЕСЛИ(ИЛИ(МЕСЯЦ(СЕГОДНЯ())={1;2;3;10;11;12});$D$2;"")

Автор - Светлый
Дата добавления - 08.12.2021 в 10:28
Юрий_Ф Дата: Среда, 08.12.2021, 12:55 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 520
Репутация: -3 ±
Замечаний: 20% ±

Excel 2010
Спасибо, друзья!
Сколько много вариантов!
Сейчас буду пробовать и разбираться, как это работает!
hands


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеСпасибо, друзья!
Сколько много вариантов!
Сейчас буду пробовать и разбираться, как это работает!
hands

Автор - Юрий_Ф
Дата добавления - 08.12.2021 в 12:55
Юрий_Ф Дата: Среда, 08.12.2021, 12:59 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 520
Репутация: -3 ±
Замечаний: 20% ±

Excel 2010
Уважаемый DrMini

Весь год не нужно! Это же отопление! Только зимние месяцы!


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!


Сообщение отредактировал Юрий_Ф - Среда, 08.12.2021, 13:27
 
Ответить
СообщениеУважаемый DrMini

Весь год не нужно! Это же отопление! Только зимние месяцы!

Автор - Юрий_Ф
Дата добавления - 08.12.2021 в 12:59
bmv98rus Дата: Среда, 08.12.2021, 18:55 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3953
Репутация: 732 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=IF(ABS(MONTH(TODAY())-6.5)>3;d2;"")


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Четверг, 09.12.2021, 07:53
 
Ответить
Сообщение
Код
=IF(ABS(MONTH(TODAY())-6.5)>3;d2;"")

Автор - bmv98rus
Дата добавления - 08.12.2021 в 18:55
Юрий_Ф Дата: Четверг, 09.12.2021, 01:34 | Сообщение № 8
Группа: Проверенные
Ранг: Ветеран
Сообщений: 520
Репутация: -3 ±
Замечаний: 20% ±

Excel 2010
bmv98rus

Система пишет:
Цитата
Для данной функции введено слишком много аргументов


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
Сообщениеbmv98rus

Система пишет:
Цитата
Для данной функции введено слишком много аргументов

Автор - Юрий_Ф
Дата добавления - 09.12.2021 в 01:34
DrMini Дата: Четверг, 09.12.2021, 04:57 | Сообщение № 9
Группа: Проверенные
Ранг: Ветеран
Сообщений: 883
Репутация: 71 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
введено слишком много аргументов

Исправьте ;5 на ,5:
Код
=ЕСЛИ(ABS(МЕСЯЦ(СЕГОДНЯ())-6,5)>3;D2;"")


Сообщение отредактировал DrMini - Четверг, 09.12.2021, 11:00
 
Ответить
Сообщение
введено слишком много аргументов

Исправьте ;5 на ,5:
Код
=ЕСЛИ(ABS(МЕСЯЦ(СЕГОДНЯ())-6,5)>3;D2;"")

Автор - DrMini
Дата добавления - 09.12.2021 в 04:57
bmv98rus Дата: Четверг, 09.12.2021, 07:54 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3953
Репутация: 732 ±
Замечаний: 0% ±

Excel 2013/2016
Исправьте ;5 на ,5:
это шутки тэга , там была ","
[vba]
Код
[code]=IF(ABS(MONTH(TODAY())-6,5)>3;d2;"")
[/code][/vba]


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Исправьте ;5 на ,5:
это шутки тэга , там была ","
[vba]
Код
[code]=IF(ABS(MONTH(TODAY())-6,5)>3;d2;"")
[/code][/vba]

Автор - bmv98rus
Дата добавления - 09.12.2021 в 07:54
Юрий_Ф Дата: Четверг, 09.12.2021, 16:11 | Сообщение № 11
Группа: Проверенные
Ранг: Ветеран
Сообщений: 520
Репутация: -3 ±
Замечаний: 20% ±

Excel 2010
DrMini
Да, пропускает система. И она будет работать в зимние месяцы?
А причём тут 6,5? Не могу разобраться, как ЭТО работает!


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеDrMini
Да, пропускает система. И она будет работать в зимние месяцы?
А причём тут 6,5? Не могу разобраться, как ЭТО работает!

Автор - Юрий_Ф
Дата добавления - 09.12.2021 в 16:11
DrMini Дата: Четверг, 09.12.2021, 16:32 | Сообщение № 12
Группа: Проверенные
Ранг: Ветеран
Сообщений: 883
Репутация: 71 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
А причём тут 6,5? Не могу разобраться, как ЭТО работает!

Код
МЕСЯЦ(СЕГОДНЯ()

это текущий месяц (в данном случае 12)
Код
ABS(МЕСЯЦ(СЕГОДНЯ())-6,5

Это текущий месяц -6,5 и всегда положительный результат. В данном случае 12-6,5=5,5 (а это больше 3)
В следующем месяце будет 1-6,5=-5,5 а так, как стоит функция ABS то будет не -5,5 а 5,5 (а это больше 3)
Ну, а дальше я думаю понятно.
 
Ответить
Сообщение
А причём тут 6,5? Не могу разобраться, как ЭТО работает!

Код
МЕСЯЦ(СЕГОДНЯ()

это текущий месяц (в данном случае 12)
Код
ABS(МЕСЯЦ(СЕГОДНЯ())-6,5

Это текущий месяц -6,5 и всегда положительный результат. В данном случае 12-6,5=5,5 (а это больше 3)
В следующем месяце будет 1-6,5=-5,5 а так, как стоит функция ABS то будет не -5,5 а 5,5 (а это больше 3)
Ну, а дальше я думаю понятно.

Автор - DrMini
Дата добавления - 09.12.2021 в 16:32
bmv98rus Дата: Пятница, 10.12.2021, 21:30 | Сообщение № 13
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3953
Репутация: 732 ±
Замечаний: 0% ±

Excel 2013/2016
конечно в формулу заложено что 6 месяцев без 0,5 не согреться, но пояснение DrMini тоже ничего :D


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениеконечно в формулу заложено что 6 месяцев без 0,5 не согреться, но пояснение DrMini тоже ничего :D

Автор - bmv98rus
Дата добавления - 10.12.2021 в 21:30
Юрий_Ф Дата: Понедельник, 13.12.2021, 02:06 | Сообщение № 14
Группа: Проверенные
Ранг: Ветеран
Сообщений: 520
Репутация: -3 ±
Замечаний: 20% ±

Excel 2010
DrMini

Спасибо! Вы опять помогли, добрый человек! hands


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеDrMini

Спасибо! Вы опять помогли, добрый человек! hands

Автор - Юрий_Ф
Дата добавления - 13.12.2021 в 02:06
Юрий_Ф Дата: Понедельник, 13.12.2021, 21:01 | Сообщение № 15
Группа: Проверенные
Ранг: Ветеран
Сообщений: 520
Репутация: -3 ±
Замечаний: 20% ±

Excel 2010
Ещё про зимние месяцы!
В октябре и в марте только пол месяца оплата за отопление. Другими словами значение ячейки $D$2 можно в эти месяцы (март и октябрь) делить пополам!
Я попытался это как-то ввести:
Код
ЕСЛИ(ИЛИ(МЕСЯЦ(СЕГОДНЯ())={1;2;11;12});$D$2);ИЛИ(МЕСЯЦ(СЕГОДНЯ())={3;10});$D$2/2;"")

Но, собачка, не работает! %)
Прошу помочь решить эту задачку!


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!


Сообщение отредактировал Юрий_Ф - Понедельник, 13.12.2021, 21:01
 
Ответить
СообщениеЕщё про зимние месяцы!
В октябре и в марте только пол месяца оплата за отопление. Другими словами значение ячейки $D$2 можно в эти месяцы (март и октябрь) делить пополам!
Я попытался это как-то ввести:
Код
ЕСЛИ(ИЛИ(МЕСЯЦ(СЕГОДНЯ())={1;2;11;12});$D$2);ИЛИ(МЕСЯЦ(СЕГОДНЯ())={3;10});$D$2/2;"")

Но, собачка, не работает! %)
Прошу помочь решить эту задачку!

Автор - Юрий_Ф
Дата добавления - 13.12.2021 в 21:01
bmv98rus Дата: Понедельник, 13.12.2021, 21:14 | Сообщение № 16
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3953
Репутация: 732 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=IF(ABS(MONTH(TODAY())-6,5)>3;$D$2/(1+(ABS(MONTH(TODAY())-6,5)=3,5));"")


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Понедельник, 13.12.2021, 22:07
 
Ответить
Сообщение
Код
=IF(ABS(MONTH(TODAY())-6,5)>3;$D$2/(1+(ABS(MONTH(TODAY())-6,5)=3,5));"")

Автор - bmv98rus
Дата добавления - 13.12.2021 в 21:14
Gustav Дата: Понедельник, 13.12.2021, 21:22 | Сообщение № 17
Группа: Друзья
Ранг: Старожил
Сообщений: 2211
Репутация: 893 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Я попытался это как-то ввести:

ЕСЛИ(ИЛИ(МЕСЯЦ(СЕГОДНЯ())={1;2;11;12});$D$2);ИЛИ(МЕСЯЦ(СЕГОДНЯ())={3;10});$D$2/2;"")

Здесь второго ЕСЛИ в середине не хватает:
Код
=ЕСЛИ(ИЛИ(МЕСЯЦ(СЕГОДНЯ())={1;2;11;12});$D$2;ЕСЛИ(ИЛИ(МЕСЯЦ(СЕГОДНЯ())={3;10});$D$2/2;""))


А вообще при конечном (и нестрашном) числе месяцев, считаю, что некоторые решения "в лоб" вполне приемлемы:
Код
=$D$2*ВЫБОР(МЕСЯЦ(СЕГОДНЯ());1;1;0,5;0;0;0;0;0;0;0,5;1;1)


МОИ: Ник, Tip box: 41001663842605

Сообщение отредактировал Gustav - Понедельник, 13.12.2021, 21:34
 
Ответить
Сообщение
Я попытался это как-то ввести:

ЕСЛИ(ИЛИ(МЕСЯЦ(СЕГОДНЯ())={1;2;11;12});$D$2);ИЛИ(МЕСЯЦ(СЕГОДНЯ())={3;10});$D$2/2;"")

Здесь второго ЕСЛИ в середине не хватает:
Код
=ЕСЛИ(ИЛИ(МЕСЯЦ(СЕГОДНЯ())={1;2;11;12});$D$2;ЕСЛИ(ИЛИ(МЕСЯЦ(СЕГОДНЯ())={3;10});$D$2/2;""))


А вообще при конечном (и нестрашном) числе месяцев, считаю, что некоторые решения "в лоб" вполне приемлемы:
Код
=$D$2*ВЫБОР(МЕСЯЦ(СЕГОДНЯ());1;1;0,5;0;0;0;0;0;0;0,5;1;1)

Автор - Gustav
Дата добавления - 13.12.2021 в 21:22
Юрий_Ф Дата: Понедельник, 13.12.2021, 21:41 | Сообщение № 18
Группа: Проверенные
Ранг: Ветеран
Сообщений: 520
Репутация: -3 ±
Замечаний: 20% ±

Excel 2010
Уважаемый Gustav

Интересно! И помощь по моему варианту тоже! hands


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеУважаемый Gustav

Интересно! И помощь по моему варианту тоже! hands

Автор - Юрий_Ф
Дата добавления - 13.12.2021 в 21:41
Юрий_Ф Дата: Понедельник, 13.12.2021, 21:43 | Сообщение № 19
Группа: Проверенные
Ранг: Ветеран
Сообщений: 520
Репутация: -3 ±
Замечаний: 20% ±

Excel 2010
bmv98rus,

Это английский вариант наших МЕСЯЦ и СЕГОДНЯ? А IF? Это не наше И? %)


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
Сообщениеbmv98rus,

Это английский вариант наших МЕСЯЦ и СЕГОДНЯ? А IF? Это не наше И? %)

Автор - Юрий_Ф
Дата добавления - 13.12.2021 в 21:43
Юрий_Ф Дата: Понедельник, 13.12.2021, 21:48 | Сообщение № 20
Группа: Проверенные
Ранг: Ветеран
Сообщений: 520
Репутация: -3 ±
Замечаний: 20% ±

Excel 2010
bmv98rus

Ввёл:
Код
=И(ABS(МЕСЯЦ(СЕГОДНЯ())-6,5)>3;$D$2/(1+(ABS(МЕСЯЦ(СЕГОДНЯ())-6,5)=3,5));"")

Система пишет:
Цитата
#ЗНАЧ!


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
Сообщениеbmv98rus

Ввёл:
Код
=И(ABS(МЕСЯЦ(СЕГОДНЯ())-6,5)>3;$D$2/(1+(ABS(МЕСЯЦ(СЕГОДНЯ())-6,5)=3,5));"")

Система пишет:
Цитата
#ЗНАЧ!

Автор - Юрий_Ф
Дата добавления - 13.12.2021 в 21:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула отопления за зимний период (Формулы/Formulas)
  • Страница 1 из 2
  • 1
  • 2
  • »
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!