Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Соединение двух таблиц с сопряжением данных - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Соединение двух таблиц с сопряжением данных (Формулы/Formulas)
Соединение двух таблиц с сопряжением данных
illyxa Дата: Среда, 08.12.2021, 21:47 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Доброго времени суток Уважаемые! Подскажите как упростить задачу (автоматизировать). Соединены две таблицы во вкладке "Начало" в одну (порядковый номер второй таблицы перед слиянием удален специально, чтоб потом проще найти и удалить дублеров). Вопрос: Как при повторяющихся значениях перенести данные с одно ячейки в другую (Пример во вкладе "Итог". Условия фильтра (одинаковых значений) по столбцу "КОД".
К сообщению приложен файл: 3198378.xlsx(12.0 Kb)
 
Ответить
СообщениеДоброго времени суток Уважаемые! Подскажите как упростить задачу (автоматизировать). Соединены две таблицы во вкладке "Начало" в одну (порядковый номер второй таблицы перед слиянием удален специально, чтоб потом проще найти и удалить дублеров). Вопрос: Как при повторяющихся значениях перенести данные с одно ячейки в другую (Пример во вкладе "Итог". Условия фильтра (одинаковых значений) по столбцу "КОД".

Автор - illyxa
Дата добавления - 08.12.2021 в 21:47
Pelena Дата: Четверг, 09.12.2021, 07:34 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18233
Репутация: 4096 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Соединены две таблицы во вкладке "Начало" в одну

а изначально они как были расположены?
На мой взгляд, из двух разных таблиц проще подтянуть данные с помощью ВПР()


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Соединены две таблицы во вкладке "Начало" в одну

а изначально они как были расположены?
На мой взгляд, из двух разных таблиц проще подтянуть данные с помощью ВПР()

Автор - Pelena
Дата добавления - 09.12.2021 в 07:34
illyxa Дата: Четверг, 09.12.2021, 09:32 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Во вкладке начало с номером по порядку - это первая таблица (обведена жирными границами), без номера п/п вторая (вставленная) таблица. Повторяются значения в столбце "КОД" по одному разу (т.е. всего в таблица будет одно совпадение чисел в строке "КОД", либо совпадений не будет).
 
Ответить
СообщениеВо вкладке начало с номером по порядку - это первая таблица (обведена жирными границами), без номера п/п вторая (вставленная) таблица. Повторяются значения в столбце "КОД" по одному разу (т.е. всего в таблица будет одно совпадение чисел в строке "КОД", либо совпадений не будет).

Автор - illyxa
Дата добавления - 09.12.2021 в 09:32
Nic70y Дата: Четверг, 09.12.2021, 10:22 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 7302
Репутация: 1686 ±
Замечаний: 0% ±

Excel 2010
1) выделяете диапазон "дней"
2) жмете F5 -- выделить -- пустые ячейки -- ОК
3) в строку формул вставляете:
Код
=ЕСЛИОШИБКА(ВПР(ИНДЕКС($B:$B;СТРОКА());ИНДЕКС($1:$1048576;СТРОКА()+1;2):ИНДЕКС($1:$1048576;18000;СТОЛБЕЦ());СТОЛБЕЦ()-1;);ВПР(ИНДЕКС($B:$B;СТРОКА());$B$1:ИНДЕКС($1:$1048576;СТРОКА()-1;СТОЛБЕЦ());СТОЛБЕЦ()-1;))

4) жмете ctrl+enter
5) выделяете диапазон "дней", копируете, вставляете значения
6) удаляете дубликаты

столбец с п/п в процессе не участвует.


ЮMoney 41001841029809
 
Ответить
Сообщение1) выделяете диапазон "дней"
2) жмете F5 -- выделить -- пустые ячейки -- ОК
3) в строку формул вставляете:
Код
=ЕСЛИОШИБКА(ВПР(ИНДЕКС($B:$B;СТРОКА());ИНДЕКС($1:$1048576;СТРОКА()+1;2):ИНДЕКС($1:$1048576;18000;СТОЛБЕЦ());СТОЛБЕЦ()-1;);ВПР(ИНДЕКС($B:$B;СТРОКА());$B$1:ИНДЕКС($1:$1048576;СТРОКА()-1;СТОЛБЕЦ());СТОЛБЕЦ()-1;))

4) жмете ctrl+enter
5) выделяете диапазон "дней", копируете, вставляете значения
6) удаляете дубликаты

столбец с п/п в процессе не участвует.

Автор - Nic70y
Дата добавления - 09.12.2021 в 10:22
Pelena Дата: Четверг, 09.12.2021, 10:26 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 18233
Репутация: 4096 ±
Замечаний: ±

Excel 2016 & Mac Excel
Для разных таблиц
Код
=ЕСЛИОШИБКА(ВПР(B2;$J$2:$M$8;4;0);"")
К сообщению приложен файл: 8003867.xlsx(13.2 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеДля разных таблиц
Код
=ЕСЛИОШИБКА(ВПР(B2;$J$2:$M$8;4;0);"")

Автор - Pelena
Дата добавления - 09.12.2021 в 10:26
illyxa Дата: Пятница, 21.01.2022, 17:46 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

СПАСИБО за помощь! Вы очень помогли, а я в свою очередь помог своей супруге :D Помог совет Nic70y!
 
Ответить
СообщениеСПАСИБО за помощь! Вы очень помогли, а я в свою очередь помог своей супруге :D Помог совет Nic70y!

Автор - illyxa
Дата добавления - 21.01.2022 в 17:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Соединение двух таблиц с сопряжением данных (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!