Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти строку, в которой текст меняется на числовое значение - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти строку, в которой текст меняется на числовое значение (Формулы/Formulas)
Найти строку, в которой текст меняется на числовое значение
Максим5900 Дата: Пятница, 10.12.2021, 16:36 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 20% ±

Доброго утра\дня\вечера, форумчане!
Прошу совета в таком вопросе: есть таблица (приложенная). В ячейки P54, Q54, R54 и S54 необходимо внести данные из ячеек в столбцах P, Q, R и S из той строки, в которой последнее значение "ВПУ".

Точнее, необходима формула которая, в столбце С найдет строку в которой "ВПУ" меняется на числовое значение (это может быть 500 или любое другое, в моем случае это строка 13 и залита синим) и возвращает в ячейки P54, Q54, R54 и S54 (зеленая заливка) значения из ячеек искомой строки, то есть из P13, Q13, R13 и S13 (желтая заливка).

может быть путанно, но суть понятна будет из файла.
К сообщению приложен файл: 0567215.xlsx(28.3 Kb)
 
Ответить
СообщениеДоброго утра\дня\вечера, форумчане!
Прошу совета в таком вопросе: есть таблица (приложенная). В ячейки P54, Q54, R54 и S54 необходимо внести данные из ячеек в столбцах P, Q, R и S из той строки, в которой последнее значение "ВПУ".

Точнее, необходима формула которая, в столбце С найдет строку в которой "ВПУ" меняется на числовое значение (это может быть 500 или любое другое, в моем случае это строка 13 и залита синим) и возвращает в ячейки P54, Q54, R54 и S54 (зеленая заливка) значения из ячеек искомой строки, то есть из P13, Q13, R13 и S13 (желтая заливка).

может быть путанно, но суть понятна будет из файла.

Автор - Максим5900
Дата добавления - 10.12.2021 в 16:36
Serge_007 Дата: Пятница, 10.12.2021, 16:48 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14868
Репутация: 2463 ±
Замечаний: ±

Excel 2016
Зравствуйте
Код
=ИНДЕКС($P4:$S44;ПОИСКПОЗ("ВПУ";$C4:$C44;1);СТОЛБЕЦ()-15)
Код
=ИНДЕКС($P4:$S44;СУММПРОИЗВ(МАКС(("ВПУ"=$C4:$C44)*СТРОКА(1:41)));СТОЛБЕЦ()-15)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗравствуйте
Код
=ИНДЕКС($P4:$S44;ПОИСКПОЗ("ВПУ";$C4:$C44;1);СТОЛБЕЦ()-15)
Код
=ИНДЕКС($P4:$S44;СУММПРОИЗВ(МАКС(("ВПУ"=$C4:$C44)*СТРОКА(1:41)));СТОЛБЕЦ()-15)

Автор - Serge_007
Дата добавления - 10.12.2021 в 16:48
Максим5900 Дата: Воскресенье, 12.12.2021, 14:45 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 20% ±

Serge_007, премного благодарен!
 
Ответить
СообщениеSerge_007, премного благодарен!

Автор - Максим5900
Дата добавления - 12.12.2021 в 14:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти строку, в которой текст меняется на числовое значение (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!