Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск идентификатора при частичном совпадении критерия - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск идентификатора при частичном совпадении критерия (Формулы/Formulas)
Поиск идентификатора при частичном совпадении критерия
Orishniy9361 Дата: Воскресенье, 12.12.2021, 10:35 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте дорогие форумчане!

У меня возникла такая проблема.
Имеется таблица данных (см. файл Пример2 вкладку "Таблица данных")
На вкладке "Выписка из таблицы" вводится искомое значение "Клеймо" а затем с помощью массива ищется уникальный идентификатор "Номер заявки".

Вопрос:
Как изменить формулу, чтобы он вытягивал идентификаторы не только, когда имеется полное совпадение клейма (в примере 274P), но и в комбинации клейм (6A95/274P-BBE1).

Находил в интернете вот такую формулу
Код
"=ИНДЕКС($A$10:$B$12;ПОИСКПОЗ("*" &A2&"*";$A$10:$A$12;0);2)
",
ключевое здесь ("*"&"*)

переработал её под мой массив, но что-то она у меня не заработала, выдаёт ошибку !ЧИСЛО
К сообщению приложен файл: 9272293.xlsx(130.9 Kb)


Сообщение отредактировал Orishniy9361 - Воскресенье, 12.12.2021, 10:37
 
Ответить
СообщениеЗдравствуйте дорогие форумчане!

У меня возникла такая проблема.
Имеется таблица данных (см. файл Пример2 вкладку "Таблица данных")
На вкладке "Выписка из таблицы" вводится искомое значение "Клеймо" а затем с помощью массива ищется уникальный идентификатор "Номер заявки".

Вопрос:
Как изменить формулу, чтобы он вытягивал идентификаторы не только, когда имеется полное совпадение клейма (в примере 274P), но и в комбинации клейм (6A95/274P-BBE1).

Находил в интернете вот такую формулу
Код
"=ИНДЕКС($A$10:$B$12;ПОИСКПОЗ("*" &A2&"*";$A$10:$A$12;0);2)
",
ключевое здесь ("*"&"*)

переработал её под мой массив, но что-то она у меня не заработала, выдаёт ошибку !ЧИСЛО

Автор - Orishniy9361
Дата добавления - 12.12.2021 в 10:35
bmv98rus Дата: Воскресенье, 12.12.2021, 11:27 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3944
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013/2016


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеКрос

Автор - bmv98rus
Дата добавления - 12.12.2021 в 11:27
Pelena Дата: Воскресенье, 12.12.2021, 11:53 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 18555
Репутация: 4202 ±
Замечаний: ±

Excel 2016 & Mac Excel
Формула массива
Код
=ИНДЕКС( 'Таблица данных'!$A$2:$A$6;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК($A$2;'Таблица данных'!$D$2:$D$6));СТРОКА('Таблица данных'!$A$2:$A$6)-1;"");СТРОКА()-4))

или обычная
Код
=ИНДЕКС( 'Таблица данных'!$A$2:$A$6;АГРЕГАТ(15;6;(СТРОКА('Таблица данных'!$A$2:$A$6)-1)/ЕЧИСЛО(ПОИСК($A$2;'Таблица данных'!$D$2:$D$6));СТРОКА()-4))
К сообщению приложен файл: 0181756.xlsx(132.3 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеФормула массива
Код
=ИНДЕКС( 'Таблица данных'!$A$2:$A$6;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК($A$2;'Таблица данных'!$D$2:$D$6));СТРОКА('Таблица данных'!$A$2:$A$6)-1;"");СТРОКА()-4))

или обычная
Код
=ИНДЕКС( 'Таблица данных'!$A$2:$A$6;АГРЕГАТ(15;6;(СТРОКА('Таблица данных'!$A$2:$A$6)-1)/ЕЧИСЛО(ПОИСК($A$2;'Таблица данных'!$D$2:$D$6));СТРОКА()-4))

Автор - Pelena
Дата добавления - 12.12.2021 в 11:53
Orishniy9361 Дата: Понедельник, 13.12.2021, 06:18 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Формула массива


Большое Вам спасибо, Pelena!
Эта формула замыкает мои идеи. Сделал систему по анализу выборки из общего котла данных.
 
Ответить
Сообщение
Формула массива


Большое Вам спасибо, Pelena!
Эта формула замыкает мои идеи. Сделал систему по анализу выборки из общего котла данных.

Автор - Orishniy9361
Дата добавления - 13.12.2021 в 06:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск идентификатора при частичном совпадении критерия (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!