Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/перемножить и суммировать два столбца по условию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » перемножить и суммировать два столбца по условию (Формулы/Formulas)
перемножить и суммировать два столбца по условию
irina_mn Дата: Суббота, 18.12.2021, 19:59 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

добрый день! Плз помогите, нужна помощь - Функция СУММПРОИЗВ с условием (перемножить и суммировать два столбца по условию) , файл задачки прилагаю ... Спасибо :)
К сообщению приложен файл: 0530803.xlsx(8.7 Kb)


Сообщение отредактировал irina_mn - Суббота, 18.12.2021, 20:51
 
Ответить
Сообщениедобрый день! Плз помогите, нужна помощь - Функция СУММПРОИЗВ с условием (перемножить и суммировать два столбца по условию) , файл задачки прилагаю ... Спасибо :)

Автор - irina_mn
Дата добавления - 18.12.2021 в 19:59
Pelena Дата: Воскресенье, 19.12.2021, 07:37 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18606
Репутация: 4219 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Код
=СУММПРОИЗВ(($A$2:$A$8=E2)*$B$2:$B$8*$C$2:$C$8)
К сообщению приложен файл: 6842887.xlsx(9.8 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=СУММПРОИЗВ(($A$2:$A$8=E2)*$B$2:$B$8*$C$2:$C$8)

Автор - Pelena
Дата добавления - 19.12.2021 в 07:37
jakim Дата: Воскресенье, 19.12.2021, 18:32 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1125
Репутация: 298 ±
Замечаний: 0% ±

Excel 2010
Power Query

[vba]
Код
let
    Source = Excel.CurrentWorkbook(){[Name="Table1"]}[Content],
    #"Changed Type" = Table.TransformColumnTypes(Source,{{"Группа", type text}, {"Cумма", Int64.Type}, {"%", type number}}),
    #"Added Custom" = Table.AddColumn(#"Changed Type", "Custom", each [Cумма]*[#"%"]),
    #"Grouped Rows" = Table.Group(#"Added Custom", {"Группа"}, {{"Count", each List.Sum([Custom]), type number}}),
    #"Renamed Columns" = Table.RenameColumns(#"Grouped Rows",{{"Count", "sum"}})
in
    #"Renamed Columns"
[/vba]
К сообщению приложен файл: 6007127.xlsx(16.4 Kb)
 
Ответить
Сообщение
Power Query

[vba]
Код
let
    Source = Excel.CurrentWorkbook(){[Name="Table1"]}[Content],
    #"Changed Type" = Table.TransformColumnTypes(Source,{{"Группа", type text}, {"Cумма", Int64.Type}, {"%", type number}}),
    #"Added Custom" = Table.AddColumn(#"Changed Type", "Custom", each [Cумма]*[#"%"]),
    #"Grouped Rows" = Table.Group(#"Added Custom", {"Группа"}, {{"Count", each List.Sum([Custom]), type number}}),
    #"Renamed Columns" = Table.RenameColumns(#"Grouped Rows",{{"Count", "sum"}})
in
    #"Renamed Columns"
[/vba]

Автор - jakim
Дата добавления - 19.12.2021 в 18:32
прохожий2019 Дата: Воскресенье, 19.12.2021, 19:21 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 952
Репутация: 261 ±
Замечаний: 0% ±

365 Beta Channel
Power Query
на больших массивах может быть шустрее:
[vba]
Код
let
    from = Excel.CurrentWorkbook(){[Name="Table1"]}[Content],
    to = Table.Group(from,"Группа",{"sum",each List.Sum(List.Transform(List.Zip({[Cумма],[#"%"]}),(x)=>x{0}*x{1}))})
in
    to
[/vba]
 
Ответить
Сообщение
Power Query
на больших массивах может быть шустрее:
[vba]
Код
let
    from = Excel.CurrentWorkbook(){[Name="Table1"]}[Content],
    to = Table.Group(from,"Группа",{"sum",each List.Sum(List.Transform(List.Zip({[Cумма],[#"%"]}),(x)=>x{0}*x{1}))})
in
    to
[/vba]

Автор - прохожий2019
Дата добавления - 19.12.2021 в 19:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » перемножить и суммировать два столбца по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!