Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/СУММЕСЛИ выдает "0" - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СУММЕСЛИ выдает "0" (Формулы/Formulas)
СУММЕСЛИ выдает "0"
Natysik_s Дата: Четверг, 23.12.2021, 14:22 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Добрый день! Помогите, пожалуйста, уже голову сломала)
Для примера выкладываю файл. Задача простая: даты по порядку с 01.01.2022 по 31.12.2022. Рядом часы работы по графику. Надо считать сколько часов остается отработать до конца года начиная с даты приема.
СУММЕСЛИ выдает "0"( Меняла уже форматы ячеек. Не помогает
К сообщению приложен файл: 5717240.xlsx(13.7 Kb)
 
Ответить
СообщениеДобрый день! Помогите, пожалуйста, уже голову сломала)
Для примера выкладываю файл. Задача простая: даты по порядку с 01.01.2022 по 31.12.2022. Рядом часы работы по графику. Надо считать сколько часов остается отработать до конца года начиная с даты приема.
СУММЕСЛИ выдает "0"( Меняла уже форматы ячеек. Не помогает

Автор - Natysik_s
Дата добавления - 23.12.2021 в 14:22
amfor Дата: Четверг, 23.12.2021, 14:40 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 247
Репутация: 74 ±
Замечаний: 0% ±

Excel 2016
Добрый. Так?
Код
=СУММЕСЛИ(A1:A365;">="&E2;B1:B365)
К сообщению приложен файл: 5876122.xlsx(14.1 Kb)


Семь бед - один RESET.
 
Ответить
СообщениеДобрый. Так?
Код
=СУММЕСЛИ(A1:A365;">="&E2;B1:B365)

Автор - amfor
Дата добавления - 23.12.2021 в 14:40
Serge_007 Дата: Четверг, 23.12.2021, 14:49 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 15568
Репутация: 2559 ±
Замечаний: ±

Excel 2016
Меняла уже форматы ячеек. Не помогает
А как смена формата, хотя бы теоретически, могла бы помочь? Ведь значения в ячейках остаются прежние, от формата они не зависят...

Код
=СУММПРОИЗВ((A1:A365>=E2)*(B1:B365))


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Меняла уже форматы ячеек. Не помогает
А как смена формата, хотя бы теоретически, могла бы помочь? Ведь значения в ячейках остаются прежние, от формата они не зависят...

Код
=СУММПРОИЗВ((A1:A365>=E2)*(B1:B365))

Автор - Serge_007
Дата добавления - 23.12.2021 в 14:49
Natysik_s Дата: Четверг, 23.12.2021, 15:54 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

amfor, Спасибо Огромное! Помогло
 
Ответить
Сообщениеamfor, Спасибо Огромное! Помогло

Автор - Natysik_s
Дата добавления - 23.12.2021 в 15:54
mekh2809 Дата: Вторник, 15.11.2022, 23:55 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Суммесли выдает 0. В одном столбце А указан вес в тоннах и в граммах. Нужно чтобы считало только тонны т.е. цифры с 4 знаками после запятой. Формула:
Код
=СУММЕСЛИ(А2:А20; "#_####")
выдает 0. Думаю я не правильно задала критерий. Подскажите как создать работающую формулу.
К сообщению приложен файл: 3775179.xlsx(8.6 Kb)
 
Ответить
СообщениеСуммесли выдает 0. В одном столбце А указан вес в тоннах и в граммах. Нужно чтобы считало только тонны т.е. цифры с 4 знаками после запятой. Формула:
Код
=СУММЕСЛИ(А2:А20; "#_####")
выдает 0. Думаю я не правильно задала критерий. Подскажите как создать работающую формулу.

Автор - mekh2809
Дата добавления - 15.11.2022 в 23:55
китин Дата: Среда, 16.11.2022, 08:26 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 6907
Репутация: 1057 ±
Замечаний: 0% ±

Excel 2007;2010;2016
Код
=СУММ(ЦЕЛОЕ(A2:A4))

формула массива


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщение
Код
=СУММ(ЦЕЛОЕ(A2:A4))

формула массива

Автор - китин
Дата добавления - 16.11.2022 в 08:26
Nic70y Дата: Среда, 16.11.2022, 08:35 | Сообщение № 7
Группа: Друзья
Ранг: Экселист
Сообщений: 7866
Репутация: 1892 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММПРОИЗВ((ДЛСТР(ОКРУГЛ(ОСТАТ(A1:A4;1);4))=6)*A1:A4)
если будет 2,0010 не сосчитает, как и любая другая формула,
нужна новая тема и решение на VBA,
наверное, конкретику надо.


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Среда, 16.11.2022, 08:45
 
Ответить
Сообщение
Код
=СУММПРОИЗВ((ДЛСТР(ОКРУГЛ(ОСТАТ(A1:A4;1);4))=6)*A1:A4)
если будет 2,0010 не сосчитает, как и любая другая формула,
нужна новая тема и решение на VBA,
наверное, конкретику надо.

Автор - Nic70y
Дата добавления - 16.11.2022 в 08:35
Gustav Дата: Среда, 16.11.2022, 11:42 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2211
Репутация: 893 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Привожу пользовательскую функцию на VBA "Сумма Ячеек С Заданным Форматом" - не столько для использования, сколько для объяснения того, как лично я понял задачу:
[vba]
Код
Function SumOfNumberFormat(ByVal numberFormatLocal, ParamArray rng())
    Dim area, cell, arr(), i
    ReDim arr(0)
    For Each area In rng
        For Each cell In area.Cells
            If cell.numberFormatLocal = numberFormatLocal Then
                i = i + 1
                ReDim Preserve arr(i)
                arr(i) = cell
            End If
        Next cell
    Next area
    SumOfNumberFormat = WorksheetFunction.Sum(arr)
End Function
[/vba]
Но можно, конечно, и использовать. Пример формулы на рабочем листе:
Код
=SumOfNumberFormat("# ##0,0000"; A2:A4)

При вычислении суммы учтутся все ячейки заданного диапазона/диапазонов, имеющие формат как на рисунке:
К сообщению приложен файл: 4999812.png(20.7 Kb)


МОИ: Ник, Tip box: 41001663842605
 
Ответить
СообщениеПривожу пользовательскую функцию на VBA "Сумма Ячеек С Заданным Форматом" - не столько для использования, сколько для объяснения того, как лично я понял задачу:
[vba]
Код
Function SumOfNumberFormat(ByVal numberFormatLocal, ParamArray rng())
    Dim area, cell, arr(), i
    ReDim arr(0)
    For Each area In rng
        For Each cell In area.Cells
            If cell.numberFormatLocal = numberFormatLocal Then
                i = i + 1
                ReDim Preserve arr(i)
                arr(i) = cell
            End If
        Next cell
    Next area
    SumOfNumberFormat = WorksheetFunction.Sum(arr)
End Function
[/vba]
Но можно, конечно, и использовать. Пример формулы на рабочем листе:
Код
=SumOfNumberFormat("# ##0,0000"; A2:A4)

При вычислении суммы учтутся все ячейки заданного диапазона/диапазонов, имеющие формат как на рисунке:

Автор - Gustav
Дата добавления - 16.11.2022 в 11:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СУММЕСЛИ выдает "0" (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!