Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск значения по горизонтали таблицы и подстановка ячейку - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения по горизонтали таблицы и подстановка ячейку (Формулы/Formulas)
Поиск значения по горизонтали таблицы и подстановка ячейку
GP75 Дата: Понедельник, 27.12.2021, 22:57 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 111
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте товарищи.
Давненько не заглядывал на форум, и вот снова незнание формул заставило.
Буду очень признателен, если сооринтируете как составить зависимость подстаyjвки ячеек (пример в прикреплении)
Какой функцией можно сделать зависимость, чтобы в ячейке В2 появлялось значение из колонки Е6-Е10, если в одной из ячеек напротив F6-F10 поставить плюс? Например если F7=+, то В2=Е7. А если + поставить в ячейку F9, то B2=E9. И так далее. Пытался комбинировать функциями ВПР ПОИСКПОЗ и ЕСЛИ, но что-то не из оттого места руки растут.
К сообщению приложен файл: 4296457.xls(26.5 Kb)


Сообщение отредактировал GP75 - Понедельник, 27.12.2021, 22:57
 
Ответить
СообщениеЗдравствуйте товарищи.
Давненько не заглядывал на форум, и вот снова незнание формул заставило.
Буду очень признателен, если сооринтируете как составить зависимость подстаyjвки ячеек (пример в прикреплении)
Какой функцией можно сделать зависимость, чтобы в ячейке В2 появлялось значение из колонки Е6-Е10, если в одной из ячеек напротив F6-F10 поставить плюс? Например если F7=+, то В2=Е7. А если + поставить в ячейку F9, то B2=E9. И так далее. Пытался комбинировать функциями ВПР ПОИСКПОЗ и ЕСЛИ, но что-то не из оттого места руки растут.

Автор - GP75
Дата добавления - 27.12.2021 в 22:57
gling Дата: Понедельник, 27.12.2021, 23:13 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2372
Репутация: 617 ±
Замечаний: 0% ±

2010
Здравствуйте.
Варианты
Код
=СУММЕСЛИ(F6:F10;"+";E6:E10)
Код
=ИНДЕКС(E6:E10;ПОИСКПОЗ("+";F6:F10;))
Код
=ПРОСМОТР("+";F6:F10;E6:E10)
При двух и более "+" результаты будут разные.


ЯД-41001506838083

Сообщение отредактировал gling - Понедельник, 27.12.2021, 23:18
 
Ответить
СообщениеЗдравствуйте.
Варианты
Код
=СУММЕСЛИ(F6:F10;"+";E6:E10)
Код
=ИНДЕКС(E6:E10;ПОИСКПОЗ("+";F6:F10;))
Код
=ПРОСМОТР("+";F6:F10;E6:E10)
При двух и более "+" результаты будут разные.

Автор - gling
Дата добавления - 27.12.2021 в 23:13
GP75 Дата: Понедельник, 27.12.2021, 23:37 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 111
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо товарищ!
Всё гениальное просто оказывается!
А если В2 и таблица на разных листах,? что-то не могут зависимость установить. Пишет что нужно ввести апостроф. Только не могу понять куда
Файл прикрепил - формулу записал без =
К сообщению приложен файл: 9600870.xls(27.5 Kb)
 
Ответить
СообщениеСпасибо товарищ!
Всё гениальное просто оказывается!
А если В2 и таблица на разных листах,? что-то не могут зависимость установить. Пишет что нужно ввести апостроф. Только не могу понять куда
Файл прикрепил - формулу записал без =

Автор - GP75
Дата добавления - 27.12.2021 в 23:37
gling Дата: Понедельник, 27.12.2021, 23:43 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2372
Репутация: 617 ±
Замечаний: 0% ±

2010
Код
=ИНДЕКС('2'!E6:E10;ПОИСКПОЗ("+";'2'!F6:F10;))


ЯД-41001506838083
 
Ответить
Сообщение
Код
=ИНДЕКС('2'!E6:E10;ПОИСКПОЗ("+";'2'!F6:F10;))

Автор - gling
Дата добавления - 27.12.2021 в 23:43
Egyptian Дата: Понедельник, 27.12.2021, 23:51 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 393
Репутация: 134 ±
Замечаний: 0% ±

Excel 2013/2016
Вариант на случай один плюс - одно значение. При двух и более плюсах формула выдаст 0.
Код
=SUMPRODUCT((COUNTIF($F$6:$F$10;$F$6:$F$10)=1)*$E$6:$E$10)
К сообщению приложен файл: 7709743.xls(27.0 Kb)
 
Ответить
СообщениеВариант на случай один плюс - одно значение. При двух и более плюсах формула выдаст 0.
Код
=SUMPRODUCT((COUNTIF($F$6:$F$10;$F$6:$F$10)=1)*$E$6:$E$10)

Автор - Egyptian
Дата добавления - 27.12.2021 в 23:51
GP75 Дата: Понедельник, 27.12.2021, 23:51 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 111
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Ещё раз благодарю.
Я сегодня туплю видимо.
С наступающим и всех благ!
 
Ответить
СообщениеЕщё раз благодарю.
Я сегодня туплю видимо.
С наступающим и всех благ!

Автор - GP75
Дата добавления - 27.12.2021 в 23:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения по горизонтали таблицы и подстановка ячейку (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!